audio/swh-plugins-lv2: Updated for version 1.0.16.
Signed-off-by: B. Watson <yalhcru@gmail.com>
This commit is contained in:
parent
314dab4113
commit
a667aaac47
|
@ -1,12 +0,0 @@
|
|||
diff -Naur swh-lv2-1.0.15/Makefile swh-lv2-1.0.15.patched/Makefile
|
||||
--- swh-lv2-1.0.15/Makefile 2008-01-09 16:02:08.000000000 -0500
|
||||
+++ swh-lv2-1.0.15.patched/Makefile 2010-01-02 19:30:31.000000000 -0500
|
||||
@@ -72,7 +72,7 @@
|
||||
|
||||
%.so: NAME = $(shell echo -n $@ | sed 's/plugins\/\(.*\)-swh.*/\1/')
|
||||
%.so: %.xml %.o %.ttl
|
||||
- $(CC) $*.o $(PLUGIN_LDFLAGS) $($(NAME)_LDFLAGS) -o $@
|
||||
+ $(CC) $*.o $(PLUGIN_LDFLAGS) $($(NAME)_LDFLAGS) -o $@ -lm
|
||||
cp $@ $*-$(OS).$(EXT)
|
||||
sed 's/@OS@/$(OS)/g' < `dirname $@`/manifest.ttl.in > `dirname $@`/manifest.ttl
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
diff -Naur swh-lv2-1.0.15/Makefile swh-lv2-1.0.15.patched/Makefile
|
||||
--- swh-lv2-1.0.15/Makefile 2008-01-09 16:02:08.000000000 -0500
|
||||
+++ swh-lv2-1.0.15.patched/Makefile 2010-06-24 18:28:09.000000000 -0400
|
||||
@@ -44,7 +44,7 @@
|
||||
BUILD_PLUGINS = $(PLUGINS)
|
||||
else
|
||||
EXT = so
|
||||
-PLUGIN_CFLAGS = -Wall -I. -Iinclude -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -fPIC -DPIC $(CFLAGS)
|
||||
+PLUGIN_CFLAGS = -Wall -I. -Iinclude -fPIC -DPIC $(SLKCFLAGS)
|
||||
PLUGIN_LDFLAGS = -shared $(LDFLAGS)
|
||||
BUILD_PLUGINS = $(PLUGINS) $(FFT_PLUGINS)
|
||||
endif
|
|
@ -7,11 +7,11 @@
|
|||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
PRGNAM=swh-plugins-lv2
|
||||
VERSION=${VERSION:-1.0.15}
|
||||
VERSION=${VERSION:-1.0.16}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
TARNAME="swh-lv2"
|
||||
TARNAME="lv2"
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
|
@ -56,13 +56,9 @@ find -L . \
|
|||
-exec chmod 644 {} \;
|
||||
|
||||
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
|
||||
patch -p1 < $CWD/slkcflags.diff
|
||||
sed -i 's,-O3.*-funroll-loops,$(SLKCFLAGS),' Makefile
|
||||
fi
|
||||
|
||||
# Add -lm when linking the .so files. Without this, the plugins fail to
|
||||
# load in ardour.
|
||||
patch -p1 < $CWD/libm.diff
|
||||
|
||||
make PREFIX=/usr SLKCFLAGS="$SLKCFLAGS"
|
||||
make install-system INSTALL_DIR=$PKG/usr/lib$LIBDIRSUFFIX/lv2
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="swh-plugins-lv2"
|
||||
VERSION="1.0.15"
|
||||
VERSION="1.0.16"
|
||||
HOMEPAGE="http://plugin.org.uk/"
|
||||
DOWNLOAD="http://distfiles.gentoo.org/distfiles/swh-lv2-1.0.15.tar.gz"
|
||||
MD5SUM="c78f42c36d7bf2fb5b17f795ef9636d1"
|
||||
DOWNLOAD="https://github.com/swh/lv2/archive/v1.0.16/lv2-1.0.16.tar.gz"
|
||||
MD5SUM="adc191d7e00e2ef9de0e6e5b546651a6"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="slv2"
|
||||
|
|
Loading…
Reference in New Issue