graphics/fly: Added to 12.0 repository

This commit is contained in:
Grant Coady 2010-05-11 20:00:36 +02:00 committed by Robby Workman
parent 9cb923ae53
commit a590b0e413
5 changed files with 97 additions and 0 deletions

View File

@ -0,0 +1,13 @@
--- fly-2.0.0/Makefile.orig 2007-12-16 15:12:22.497364100 -0600
+++ fly-2.0.0/Makefile 2007-12-16 15:15:01.594430525 -0600
@@ -9,8 +9,8 @@
INCDIRS = -I$(GD) -I/usr/local/web/include
CC = gcc
-CFLAGS = -O -pedantic -Wall $(INCDIRS) $(LIBDIRS)
-LIBS = -lgd -lm -lz -lttf -lpng -ljpeg #-lXpm
+CFLAGS += -pedantic -Wall $(INCDIRS) $(LIBDIRS)
+LIBS = -lgd -lm -lz -lpng -ljpeg #-lXpm
all: fly

8
graphics/fly/README Normal file
View File

@ -0,0 +1,8 @@
fly - Create images from a text description file.
fly is small program that takes a text input command file and creates an
image file 'on the fly' to .gif, .jpg or .png format using the gd library.
fly is suited for creating images from bash or awk scripts.
This SlackBuild script patches the Makefile to remove an unused (obsolete)
linking to the old ttf (before freetype) library so we get a clean compile.

View File

@ -0,0 +1,49 @@
#!/bin/sh
# Slackware build script for fly
# Written by Grant Coady <http://bugsplatter.mine.nu> GPLv2
PRGNAM=fly
VERSION=2.0.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Patch the Makefile to support adding SLKCFLAGS and remove old -lttf linkage
patch -p1 < $CWD/Makefile.diff
CFLAGS="$SLKCFLAGS" make
install -D -m 0755 fly $PKG/usr/bin/fly
strip --strip-unneeded $PKG/usr/bin/fly
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc/* examples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

8
graphics/fly/fly.info Normal file
View File

@ -0,0 +1,8 @@
PRGNAM="fly"
VERSION="2.0.0"
HOMEPAGE="http://martin.gleeson.com/fly/index.html"
DOWNLOAD="http://martin.gleeson.com/fly/dist/fly-2.0.0.tar.gz"
MD5SUM="b5efc8435a76ba2b2c592156ec5db4e2"
MAINTAINER="Grant Coady"
EMAIL="bugsplatter@gmail.com"
APPROVED="rworkman"

19
graphics/fly/slack-desc Normal file
View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
fly: fly (Create images from a text description file)
fly:
fly: fly is small program that takes a text input command file and
fly: creates an image file 'on the fly' to .gif, .jpg or .png format
fly: using the gd library. fly is suited to creating images from
fly: bash or awk scripts.
fly:
fly: Homepage: http://martin.gleeson.com/fly/index.html
fly:
fly:
fly: