system/slim: Updated for version 1.3.5.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Niels Horn 2013-04-07 18:07:20 -05:00 committed by Robby Workman
parent 0ec3ca9a61
commit a4c796f352
3 changed files with 22 additions and 34 deletions

View File

@ -1,15 +0,0 @@
diff -Nur slim-1.3.2.orig//Makefile slim-1.3.2/Makefile
--- slim-1.3.2.orig//Makefile 2010-07-08 00:04:10.000000000 -0500
+++ slim-1.3.2/Makefile 2010-08-16 15:41:08.470912088 -0500
@@ -5,9 +5,9 @@
#######################################################
CXX=/usr/bin/g++
CC=/usr/bin/gcc
-CFLAGS=-Wall -I. -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include
+CFLAGS=-Wall -I. -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libpng14 -I/usr/include
CXXFLAGS=$(CFLAGS)
-LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng12 -lz -lm -lcrypt -lXmu -lpng -ljpeg -lrt
+LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng14 -lz -lm -lcrypt -lXmu -ljpeg -lrt
CUSTOM=-DHAVE_SHADOW
ifdef USE_PAM
LDFLAGS+= -lpam

View File

@ -3,6 +3,8 @@
# Slackware build script for SLiM
# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# Copyright 2010,2013 Niels Horn, Rio de Janeiro, Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -22,13 +24,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Maintained until v1.3.1 by Frank Caraballo <fecaraballo{at}gmail{dot}com>
# As of v1.3.2 maintained by Niels Horn <niels.horn@gmail.com>
# revision date: 2010/09/15
# revision date: 2013/03/30
PRGNAM=slim
VERSION=${VERSION:-1.3.2}
VERSION=${VERSION:-1.3.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -45,11 +44,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
# Since PAM is not included on a stock Slackware system, default to NO.
# If you have PAM installed, then run the build script like this:
# USE_PAM=1 ./slim.SlackBuild
USE_PAM=${USE_PAM:-""}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@ -82,13 +76,19 @@ find . \
# Correct the path used for suspend:
patch -p0 < $CWD/slim.conf.patch
# Use libpng14
patch -p1 < $CWD/slim-1.3.2-use_libpng14.patch
# Fix location of man-pages
sed "s/share\/man/man/" -i CMakeLists.txt
make \
CFLAGS+="$SLKCFLAGS" \
USE_PAM=${USE_PAM}
make install DESTDIR=$PKG
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
# Don't overwrite existing config file:
mv $PKG/etc/slim.conf $PKG/etc/slim.conf.new
@ -100,6 +100,9 @@ tar xvf $CWD/slackware-black.tar.bz2 -C $PKG/usr/share/slim/themes
mkdir -p $PKG/etc/logrotate.d
cat $CWD/slim.logrotate > $PKG/etc/logrotate.d/slim.new
# Kill the incorrectly-placed (and useless anyway) systemd stuff
rm -rf $PKG/usr/usr
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

View File

@ -1,8 +1,8 @@
PRGNAM="slim"
VERSION="1.3.2"
VERSION="1.3.5"
HOMEPAGE="http://slim.berlios.de/"
DOWNLOAD="http://download.berlios.de/slim/slim-1.3.2.tar.gz"
MD5SUM="ca1ae6120e6f4b4969f2d6cf94f47b42"
DOWNLOAD="http://download.berlios.de/slim/slim-1.3.5.tar.gz"
MD5SUM="1153e6993f9c9333e4cf745411d03472"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""