multimedia/mozplugger: Updated for version 2.1.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
4681802043
commit
a3f2b83669
|
@ -1,31 +1,32 @@
|
|||
diff -Nur mozplugger-1.14.3.orig//Makefile.in mozplugger-1.14.3/Makefile.in
|
||||
--- mozplugger-1.14.3.orig//Makefile.in 2011-03-03 15:40:49.000000000 -0600
|
||||
+++ mozplugger-1.14.3/Makefile.in 2011-05-08 14:10:21.550678141 -0500
|
||||
@@ -152,17 +152,16 @@
|
||||
diff -Naur mozplugger-2.1.4.orig/Makefile.in mozplugger-2.1.4/Makefile.in
|
||||
--- mozplugger-2.1.4.orig/Makefile.in 2013-11-17 12:09:16.000000000 -0600
|
||||
+++ mozplugger-2.1.4/Makefile.in 2013-12-05 00:30:39.794211258 -0600
|
||||
@@ -266,17 +266,17 @@
|
||||
make localinstall BROWSERDIR=.opera
|
||||
|
||||
install:
|
||||
- -@$(MKDIR) @bindir@
|
||||
- -@$(MKDIR) $(prefix)$(libprefix)/mozilla/plugins
|
||||
- -@$(MKDIR) @mandir@/man7
|
||||
- -@$(MKDIR) @sysconfdir@
|
||||
- cp mozplugger-helper @bindir@
|
||||
- cp mozplugger-controller @bindir@
|
||||
- cp mozplugger-linker @bindir@
|
||||
- for target in ${PLUGINDIRS}; do cp mozplugger.so $${target}; done
|
||||
-# cp mozplugger.so $(prefix)$(libprefix)/mozilla/plugins/
|
||||
- cp $(srcdir)/mozpluggerrc @sysconfdir@
|
||||
- cp $(srcdir)/mozplugger.7 @mandir@/man7/
|
||||
+ -@$(MKDIR) $(root)/@bindir@
|
||||
+ -@$(MKDIR) $(root)/@mandir@/man7
|
||||
+ -@$(MKDIR) $(root)/@sysconfdir@
|
||||
+ cp mozplugger-helper $(root)/@bindir@
|
||||
+ cp mozplugger-controller $(root)/@bindir@
|
||||
+ cp mozplugger-linker $(root)/@bindir@
|
||||
+ for target in ${PLUGINDIRS}; do $(MKDIR) $(root)/$${target} ; cp mozplugger.so $(root)/$${target}; done
|
||||
+# cp mozplugger.so $(root)/$(prefix)$(libprefix)/mozilla/plugins/
|
||||
+ cp $(srcdir)/mozpluggerrc $(root)/@sysconfdir@
|
||||
+ cp $(srcdir)/mozplugger.7 $(root)/@mandir@/man7/
|
||||
- -install -d @bindir@
|
||||
- install mozplugger-helper @bindir@
|
||||
- install mozplugger-controller @bindir@
|
||||
- install mozplugger-linker @bindir@
|
||||
- install mozplugger-update @bindir@
|
||||
- -for a in ${PLUGINDIRS}; do install -d $$a ; done
|
||||
- for a in ${PLUGINDIRS}; do install mozplugger.so $$a ; done
|
||||
- -install -d @sysconfdir@
|
||||
- install $(srcdir)/mozpluggerrc @sysconfdir@
|
||||
- -install -d @mandir@/man7
|
||||
- install $(srcdir)/mozplugger.7 @mandir@/man7/
|
||||
+ -install -d $(root)/@bindir@
|
||||
+ install mozplugger-helper $(root)/@bindir@
|
||||
+ install mozplugger-controller $(root)/@bindir@
|
||||
+ install mozplugger-linker $(root)/@bindir@
|
||||
+ install mozplugger-update $(root)/@bindir@
|
||||
+ -for a in ${PLUGINDIRS}; do install -d $(root)/$$a ; done
|
||||
+ for a in ${PLUGINDIRS}; do install mozplugger.so $(root)/$$a ; done
|
||||
+ -install -d $(root)/@sysconfdir@
|
||||
+ install $(srcdir)/mozpluggerrc $(root)/@sysconfdir@
|
||||
+ -install -d $(root)/@mandir@/man7
|
||||
+ install $(srcdir)/mozplugger.7 $(root)/@mandir@/man7/
|
||||
|
||||
mozplugger.tar.gz: $(SOURCE_FILES)
|
||||
@( DIR=`pwd`;\
|
||||
uninstall:
|
||||
-rm -f @sysconfdir@/mozpluggerrc
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
The goal of the mozplugger project is to provide a minimalist, clean,
|
||||
and stable general purpose Mozilla plugin module that allows the
|
||||
user to embed and launch their favorite application to handle the
|
||||
and stable general purpose Mozilla plugin module that allows the
|
||||
user to embed and launch their favorite application to handle the
|
||||
various different types of media found on the Internet.
|
||||
|
||||
You must run mozplugger-update if you update package.
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for mozplugger
|
||||
|
||||
# Copyright (c) jue 2009, Dhaby Xiloj <slack.dhabyx@gmail.com>
|
||||
# Copyright (c) 2009-2013, Dhaby Xiloj <slack.dhabyx@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
|
@ -22,7 +22,7 @@
|
|||
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=mozplugger
|
||||
VERSION=${VERSION:-1.14.3}
|
||||
VERSION=${VERSION:-2.1.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -46,14 +46,14 @@ elif [ "$ARCH" = "i686" ]; then
|
|||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -march=native -fPIC"
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
|
@ -63,12 +63,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
|||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# sigh --rworkman
|
||||
# updated for 2.1.4 version
|
||||
patch -p1 < $CWD/Makefile.in.diff
|
||||
|
||||
./configure \
|
||||
|
@ -93,6 +94,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
|
|||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="mozplugger"
|
||||
VERSION="1.14.3"
|
||||
VERSION="2.1.4"
|
||||
HOMEPAGE="http://mozplugger.mozdev.org/"
|
||||
DOWNLOAD="http://mozplugger.mozdev.org/files/mozplugger-1.14.3.tar.gz"
|
||||
MD5SUM="ac2f916ac93c3b59dec2ebfc511d00a0"
|
||||
DOWNLOAD="http://mozplugger.mozdev.org/files/mozplugger-2.1.4.tar.gz"
|
||||
MD5SUM="b5b26f927d5c7c5f15ecc70576b8cae0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="dhabyx"
|
||||
MAINTAINER="DhabyX"
|
||||
EMAIL="slack.dhabyx@gmail.com"
|
||||
|
|
Loading…
Reference in New Issue