libraries/irrlicht: Updated for svn_3843 and new maintainer.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
b48f59e596
commit
a33f1f0141
|
@ -1,37 +1,12 @@
|
|||
From: Christoph Egger <Christoph.Egger@gmx.de>
|
||||
Subject: [PATCH] debian/correct-install
|
||||
|
||||
The variables setup for the install target does not work. We're correcting it here
|
||||
|
||||
Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
|
||||
|
||||
---
|
||||
source/Irrlicht/Makefile | 13 +++++++++++--
|
||||
1 files changed, 11 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/source/Irrlicht/Makefile b/source/Irrlicht/Makefile
|
||||
index 49f990d..a66980b 100644
|
||||
--- a/source/Irrlicht/Makefile
|
||||
+++ b/source/Irrlicht/Makefile
|
||||
@@ -141,8 +141,17 @@ install install_osx:
|
||||
--- irrlicht-svn_3843/source/Irrlicht/Makefile 2011-05-18 18:32:00.000000000 -0300
|
||||
+++ irrlicht-svn_3843_patched/source/Irrlicht/Makefile 2011-10-24 21:25:05.000000000 -0200
|
||||
@@ -142,7 +142,8 @@
|
||||
mkdir -p $(INSTALL_DIR)/../include/irrlicht
|
||||
cp ../../include/*.h $(INSTALL_DIR)/../include/irrlicht/
|
||||
cp $(LIB_PATH)/$(SHARED_LIB).$(VERSION) $(INSTALL_DIR)
|
||||
- cd $(INSTALL_DIR) && ln -s -f $(SHARED_LIB).$(VERSION) $(SHARED_LIB)
|
||||
-# ldconfig -n $(INSTALL_DIR)
|
||||
- cd $(INSTALL_DIR) && ln -s -f $(SHARED_LIB).$(VERSION) $(COMPATIBILITY_VERSION)
|
||||
+ cp $(LIB_PATH)/$(STATIC_LIB) $(INSTALL_DIR)
|
||||
+ cd $(INSTALL_DIR) && ln -s -f libIrrlicht.so.$(VERSION) $(SHARED_LIB)
|
||||
+ #ldconfig -n $(INSTALL_DIR)
|
||||
+
|
||||
+install_osx:
|
||||
+ $(RM) -r $(INSTALL_DIR)/../include/irrlicht
|
||||
+ mkdir -p $(INSTALL_DIR)/../include/irrlicht
|
||||
+ cp ../../include/*.h $(INSTALL_DIR)/../include/irrlicht
|
||||
+ cp $(LIB_PATH)/$(SHARED_LIB).$(VERSION) $(INSTALL_DIR)
|
||||
+ cd $(INSTALL_DIR) && ln -s libIrrlicht.dylib.$(VERSION) $(SHARED_LIB)
|
||||
+ ldconfig -n $(INSTALL_DIR)
|
||||
|
||||
TAGS:
|
||||
ctags *.cpp ../../include/*.h *.h
|
||||
--
|
||||
tg: (9f40966..) debian/correct-install (depends on: master)
|
||||
# ldconfig -n $(INSTALL_DIR)
|
||||
|
||||
|
|
|
@ -2,10 +2,31 @@
|
|||
|
||||
# Slackware build script for irrlicht
|
||||
|
||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2010 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2011 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# Revision date 2011/10/26
|
||||
|
||||
PRGNAM=irrlicht
|
||||
VERSION=${VERSION:-1.7.2}
|
||||
VERSION=${VERSION:-svn_3843}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -42,7 +63,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
unzip $CWD/$PRGNAM-$VERSION.zip
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
|
@ -51,7 +72,8 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Correct the install sequence.
|
||||
# Correct the install sequence to get a working link to the shared lib
|
||||
# Based on a patch from Debian, adapted for the newer irrlicht versions
|
||||
patch -p1 < $CWD/correct-install.diff
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="irrlicht"
|
||||
VERSION="1.7.2"
|
||||
VERSION="svn_3843"
|
||||
HOMEPAGE="http://irrlicht.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/irrlicht/irrlicht-1.7.2.zip"
|
||||
MD5SUM="eb627d4c432bf73f12bc6d9ddc700b07"
|
||||
DOWNLOAD="http://www.nielshorn.net/_download/slackware/source/irrlicht-svn_3843.tar.bz2"
|
||||
MD5SUM="ba7c12dad405bd86159c1842dc57a33e"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Larry Halali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
APPROVED="Niels Horn"
|
||||
MAINTAINER="Niels Horn"
|
||||
EMAIL="niels.horn@gmail.com"
|
||||
APPROVED="rworkman"
|
||||
|
|
Loading…
Reference in New Issue