multimedia/gnash: Fix a linking error
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
b7448da42a
commit
a23950a58c
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for gnash
|
||||
|
||||
# Copyright 2012 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# Copyright 2012-2013 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=gnash
|
||||
VERSION=${VERSION:-0.8.10}
|
||||
BUILD=${BUILD:-4}
|
||||
BUILD=${BUILD:-5}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -78,13 +78,14 @@ rm -rf $PRGNAM-$VERSION
|
|||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-st .
|
||||
chmod -R u+w,go-w,a+rX-st .
|
||||
|
||||
# Fix compilation with GCC 4.7.
|
||||
patch -p1 < $CWD/patch/gcc47.patch
|
||||
|
||||
# Fix paths for kde plugin and a cve patch.
|
||||
# Fix a boost linking error, paths for kde plugin, and a cve patch.
|
||||
# Ripped from gentoo
|
||||
patch -p1 < $CWD/patch/gnash-0.8.10-boost-1.50.patch
|
||||
patch -p1 < $CWD/patch/gnash-0.8.10-klash.patch
|
||||
patch -p1 < $CWD/patch/gnash-0.8.10-kde4-libdir.patch
|
||||
patch -p1 < $CWD/patch/gnash-0.8.10-cve-2012-1175.patch
|
||||
|
|
|
@ -5,6 +5,6 @@ DOWNLOAD="ftp://mirrors.kernel.org/gnu/gnash/0.8.10/gnash-0.8.10.tar.bz2"
|
|||
MD5SUM="63e9f79c41d93d48c5a2fa94856548c4"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="agg xulrunner"
|
||||
REQUIRES="%README% agg xulrunner"
|
||||
MAINTAINER="Kyle Guinn"
|
||||
EMAIL="elyk03@gmail.com"
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
diff -ur a/macros/boost.m4 b/macros/boost.m4
|
||||
--- a/macros/boost.m4 2012-09-03 17:11:43.000000000 +0200
|
||||
+++ b/macros/boost.m4 2012-10-16 01:58:28.000000000 +0200
|
||||
@@ -37,7 +37,7 @@
|
||||
boost_headers="detail/lightweight_mutex.hpp thread/thread.hpp multi_index_container.hpp multi_index/key_extractors.hpp thread/mutex.hpp program_options/options_description.hpp iostreams/stream.hpp"
|
||||
dnl this is a list of *required* libraries. If any of these are missing, this
|
||||
dnl test will return a failure, and Gnash won't build.
|
||||
- boost_libs="thread program_options iostreams"
|
||||
+ boost_libs="thread program_options iostreams system"
|
||||
|
||||
dnl this is a list of *recommended* libraries. If any of these are missing, this
|
||||
dnl test will return a warning, and Gnash will build, but testing won't work.
|
||||
diff -ur a/plugin/npapi/Makefile.am b/plugin/npapi/Makefile.am
|
||||
--- a/plugin/npapi/Makefile.am 2012-09-03 17:11:43.000000000 +0200
|
||||
+++ b/plugin/npapi/Makefile.am 2012-10-16 01:58:57.000000000 +0200
|
||||
@@ -78,7 +78,7 @@
|
||||
|
||||
libgnashplugin_la_LIBADD = \
|
||||
$(GLIB_LIBS) \
|
||||
- -lboost_iostreams \
|
||||
+ $(BOOST_LIBS) \
|
||||
$(NULL)
|
||||
|
||||
# Scriptable plugin support
|
|
@ -1,8 +1,8 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
|
|
Loading…
Reference in New Issue