desktop/wmii: Removed (unmaintained)

Reference: http://lists.slackbuilds.org/pipermail/slackbuilds-users/2008-November/003181.html

Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Robby Workman 2011-03-14 15:31:26 -05:00
parent cd9babc28e
commit a0c774bf5e
7 changed files with 0 additions and 221 deletions

View File

@ -1,10 +0,0 @@
wmii - window manager improved 2
wmii is a dynamic window manager for X11. It supports classic and
dynamic window management with extended keyboard, mouse, and
filesystem based remote control. It replaces the workspace paradigm
with a new tagging approach. Its minimalist philosophy attempts to
not exceed 10.000 lines of code (including all shipped utilities and
libraries), to enforce simplicity and clarity.
This requires libixp, plan9port, and dmenu.

View File

@ -1,17 +0,0 @@
config() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
# If there's no config file by that name, mv it over:
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
# toss the redundant copy
rm $NEW
fi
# Otherwise, we leave the .new copy for the admin to consider...
}
config etc/wmii-3.5/wmiirc.new
config etc/wmii-3.5/welcome.new
config etc/wmii-3.5/rc.wmii.new

View File

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
wmii: wmii (window manager improved 2)
wmii:
wmii: wmii is a dynamic window manager for X11. It supports classic and
wmii: dynamic window management with extended keyboard, mouse, and
wmii: filesystem based remote control. It replaces the workspace paradigm
wmii: with a new tagging approach. Its minimalist philosophy attempts to
wmii: not exceed 10.000 lines of code (including all shipped utilities and
wmii: libraries), to enforce simplicity and clarity.
wmii:
wmii: Homepage: http://wmii.suckless.org
wmii:

View File

@ -1,29 +0,0 @@
diff -Nur wmii-3.6.orig/config.mk wmii-3.6/config.mk
--- wmii-3.6.orig/config.mk 2007-11-16 07:59:15.000000000 -0600
+++ wmii-3.6/config.mk 2009-08-03 01:14:13.179886673 -0500
@@ -10,11 +10,12 @@
# Includes and libs
INCPATH = .:${ROOT}/include:${INCLUDE}:/usr/include
-LIBS = -L/usr/lib -lc -L${ROOT}/lib
+LIBS = -L${LIBDIR} -lc -L${ROOT}/lib
# Flags
include ${ROOT}/mk/gcc.mk
-CFLAGS += -g -O0 -DIXPlint
+OPT ?= -O0
+CFLAGS += -g ${OPT} -DIXPlint
LDFLAGS += -g ${LIBS}
STATIC = -static
MKDEP = cpp -M
@@ -29,8 +30,8 @@
AWKPATH = $$(which awk)
P9PATHS = ${PLAN9}:"'$${HOME}/plan9'":/usr/local/plan9:/usr/local/9:/opt/plan9:/opt/9:/usr/plan9:/usr/9
-INCX11 = -I/usr/X11R6/include
-LIBX11 = -L/usr/X11R6/lib -lX11
+INCX11 = -I${PREFIX}include
+LIBX11 = -L${LIBDIR}/X11 -lX11
LIBICONV = # Leave blank if your libc includes iconv (glibc does)
LIBIXP = ${ROOT}/libixp/libixp.a
LIBIXP = ${LIBDIR}/libixp.a

View File

@ -1,118 +0,0 @@
#!/bin/sh
# Slackware build script for wmii
# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are met:
# 1.- Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Thanks to selkfoster <selkfoster@gmail.com>
PRGNAM=wmii
VERSION=3.6
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fixup config.mk
patch -p1 < $CWD/wmii-3.6-config_mk.diff
make \
OPT="$SLKCLAGS" \
PREFIX=/usr \
MAN=/usr/man \
ETC=/etc \
LIBDIR=/usr/lib${LIBDIRSUFFIX}
make install \
OPT="$SLKCLAGS" \
PREFIX=$PKG/usr \
MAN=$PKG/usr/man \
ETC=$PKG/etc \
LIBDIR=/usr/lib${LIBDIRSUFFIX}
# Nothing is installed to LIBDIR
# Add wmii to xwmconfig's list
install -D -m 0755 $CWD/xinitrc.wmii $PKG/etc/X11/xinit/xinitrc.wmii
# Don't clobber config files
mv $PKG/etc/wmii-3.5/wmiirc $PKG/etc/wmii-3.5/wmiirc.new
mv $PKG/etc/wmii-3.5/welcome $PKG/etc/wmii-3.5/welcome.new
mv $PKG/etc/wmii-3.5/rc.wmii $PKG/etc/wmii-3.5/rc.wmii.new
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -1,10 +0,0 @@
PRGNAM="wmii"
VERSION="3.6"
HOMEPAGE="http://wmii.suckless.org"
DOWNLOAD="http://code.suckless.org/dl/wmii/wmii-3.6.tar.gz"
MD5SUM="9d17a09871fada998b4d989d9318bbf5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Antonio Hernández Blas"
EMAIL="hba.nihilismus@gmail.com"
APPROVED="dsomero"

View File

@ -1,18 +0,0 @@
#!/bin/sh
userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap
# Merge in defaults and keymaps
[ -f $sysresources ] && xrdb -merge $sysresources
[ -f $sysmodmap ] && xmodmap $sysmodmap
[ -f $userresources ] && xrdb -merge $userresources
[ -f $usermodmap ] && xmodmap $usermodmap
# Start the window manager:
until wmii; do
true
done