games/assaultcube: Upgraded to 1.2.0.1
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
a701db839e
commit
9c616aa23c
|
@ -1,10 +1,9 @@
|
|||
diff -Naur 1.1.0.0.orig/source/src/Makefile 1.1.0.0/source/src/Makefile
|
||||
--- 1.1.0.0.orig/source/src/Makefile 2010-08-03 17:33:18.000000000 +0000
|
||||
+++ 1.1.0.0/source/src/Makefile 2010-08-05 23:42:36.631639906 +0000
|
||||
@@ -1,5 +1,5 @@
|
||||
//CXX=g++-gcc-4.2.3
|
||||
diff -Naur AssaultCube_v1.2.0.1.orig/source/src/Makefile AssaultCube_v1.2.0.1/source/src/Makefile
|
||||
--- AssaultCube_v1.2.0.1.orig/source/src/Makefile 2013-10-29 09:20:58.000000000 +0000
|
||||
+++ AssaultCube_v1.2.0.1/source/src/Makefile 2013-11-07 06:01:04.715696077 +0000
|
||||
@@ -1,4 +1,4 @@
|
||||
-CXXFLAGS= -O3 -fomit-frame-pointer
|
||||
+CXXFLAGS= $(EXTRA_CXXFLAGS) -fomit-frame-pointer
|
||||
CXX=clang++ # Use clang++, as g++ optimizations cause crashes...
|
||||
override CXXFLAGS+= -Wall -fsigned-char
|
||||
|
||||
PLATFORM= $(shell uname -s)
|
||||
|
|
|
@ -3,6 +3,6 @@ based on the game Cube. Set in a realistic looking
|
|||
environment, as far as that´s possible with this
|
||||
engine, while gameplay stays fast and arcade.
|
||||
|
||||
Note: If upgrading from version 1.0 or earlier then the new
|
||||
directory "~/.assaultcube_v1.1" will be created and previous
|
||||
Note: If upgrading from version 1.1 or earlier then the new
|
||||
directory "~/.assaultcube_v1.2" will be created and previous
|
||||
settings will not be applied to new version.
|
||||
|
|
|
@ -2,12 +2,30 @@
|
|||
|
||||
# Slackware build script for assaultcube
|
||||
|
||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2011-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
SRCNAM=AssaultCube
|
||||
PRGNAM=assaultcube
|
||||
VERSION=1.1.0.4
|
||||
BUILD=${BUILD:-3}
|
||||
VERSION=${VERSION:-1.2.0.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -38,11 +56,11 @@ set -e
|
|||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $VERSION
|
||||
tar xvf $CWD/${SRCNAM}_v${VERSION}_source.tar.bz2
|
||||
rm -rf ${SRCNAM}_v${VERSION}
|
||||
tar xvf $CWD/${SRCNAM}_v${VERSION}.tar.bz2
|
||||
cd $VERSION
|
||||
cd ${SRCNAM}_v${VERSION}
|
||||
chown -R root:root .
|
||||
find . -type f ! -name configure -exec chmod 644 '{}' \;
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
|
@ -51,12 +69,11 @@ find . \
|
|||
|
||||
# Use custom SLKCFLAGS and remove precompiled binaries.
|
||||
patch -p1 < $CWD/Makefile.patch
|
||||
# From upstream. Missing -Xll
|
||||
patch -p1 < $CWD/missing-X11.patch
|
||||
sed -i 's/\r//g' changelog.txt
|
||||
sed -i "s|-O2|$SLKCFLAGS|" source/enet/configure
|
||||
rm -f bin_unix/*
|
||||
|
||||
#autoreconf -ivf source/enet
|
||||
# Fix an illegal string literal.
|
||||
sed -i "s|Couldn.t|Couldn't|" source/src/bot/bot_waypoint.cpp
|
||||
|
||||
EXTRA_CXXFLAGS="$SLKCFLAGS" \
|
||||
make -C source/src
|
||||
|
@ -64,11 +81,12 @@ EXTRA_CXXFLAGS="$SLKCFLAGS" \
|
|||
make -C source/src install
|
||||
|
||||
mkdir -p $PKG/usr/games $PKG/usr/share/$PRGNAM
|
||||
sed -i "/^CUBE_DIR/s|=.*|=\"/usr/share/${PRGNAM}\"|" $PRGNAM.sh
|
||||
sed -i "/^CUBE_DIR/s|=.*|=\"/usr/share/${PRGNAM}\"|" $PRGNAM.sh server.sh
|
||||
install -m 0755 $PRGNAM.sh $PKG/usr/games/$PRGNAM
|
||||
install -m 0755 server.sh $PKG/usr/games/$PRGNAM-server
|
||||
chmod 0755 bin_unix/*
|
||||
cp -ar \
|
||||
bin_unix config demos mods packages screenshots \
|
||||
bin_unix bot config demos mods packages screenshots scripts \
|
||||
$PKG/usr/share/$PRGNAM
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
|
@ -76,11 +94,15 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|||
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
|
||||
install -D -m 0644 $CWD/$PRGNAM.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
|
||||
for i in 16 24 32 48 64 96 128 256; do
|
||||
convert docs/images/icon.png -resize ${i}x${i}! $PRGNAM-$i.png
|
||||
install -D -m 0644 $PRGNAM-$i.png \
|
||||
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
|
||||
done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
source/*.txt source/src/*.txt docs README.html \
|
||||
changelog.txt source/*.txt source/src/*.txt docs/*.txt README.html \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
PRGNAM="assaultcube"
|
||||
VERSION="1.1.0.4"
|
||||
VERSION="1.2.0.1"
|
||||
HOMEPAGE="http://assault.cubers.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/actiongame/AssaultCube_v1.1.0.4.tar.bz2 \
|
||||
http://downloads.sourceforge.net/actiongame/AssaultCube_v1.1.0.4_source.tar.bz2"
|
||||
MD5SUM="a5eb79eaf564c5b4de1ffad0883e45e8 \
|
||||
603b97a4262fb59ea86d483730b712e9"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/actiongame/AssaultCube_v1.2.0.1.tar.bz2"
|
||||
MD5SUM="d159e60bc7cc09e7675c0db941906f56"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="OpenAL"
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -Naur 1.1.0.4.orig/source/src/Makefile 1.1.0.4/source/src/Makefile
|
||||
--- 1.1.0.4.orig/source/src/Makefile 2010-11-14 18:46:24.000000000 +0000
|
||||
+++ 1.1.0.4/source/src/Makefile 2012-07-10 03:43:41.110712746 +0000
|
||||
@@ -26,7 +26,7 @@
|
||||
override CXXFLAGS+= -rdynamic
|
||||
CLIENT_INCLUDES= $(INCLUDES) -I/usr/include `sdl-config --cflags` -idirafter ../include
|
||||
# -lSDL_ttf
|
||||
-CLIENT_LIBS= -L../enet/.libs -lenet -L$(USRLIB) `sdl-config --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile
|
||||
+CLIENT_LIBS= -L../enet/.libs -lenet -L$(USRLIB) -lX11 `sdl-config --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile
|
||||
endif
|
||||
|
||||
CLIENT_OBJS= \
|
Loading…
Reference in New Issue