desktop/cairo-compmgr: Fixed underlinking and REQUIRES

This commit is contained in:
dsomero 2012-09-16 19:02:00 -04:00
parent bbd8fd4435
commit 9bd329be05
6 changed files with 278 additions and 12 deletions

View File

@ -7,7 +7,7 @@
PRGNAM=cairo-compmgr
VERSION=${VERSION:-0.3.0}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -37,7 +37,7 @@ else
LIBDIRSUFFIX=""
fi
set -e # Exit on most errors
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@ -51,13 +51,6 @@ find . \
-type f -perm /111 -exec chmod 755 {} \; -o \
-type f -exec chmod 644 {} \;
if pkg-config --exists gconf-2.0 ; then
WITH_GCONF=YES
gconf_flags="--enable-gconf --with-gconf-source=\"xml::/etc/gconf/gconf.xml.defaults\" --disable-schemas-install"
else
gconf_flags="--disable-gconf --disable-schemas-install"
fi
if pkg-config --exists libgtop-2.0 ; then
WITH_PERF=YES
perf_flags="--enable-perf-plugin"
@ -67,7 +60,12 @@ fi
# If vala changes the name of the pkgconfig file from libvala-0.12.pc,
# then this patch will have to be changed. It works with vala-0.11.2.
patch -p1 < $CWD/fixup-vala-requirement.patch
patch -p1 < $CWD/patches/fixup-vala-requirement.patch
# Fix underlinking
patch -p1 < $CWD/patches/cairo-compmgr-fix-link.patch
patch -p1 < $CWD/patches/cairo-compmgr-link-gmodule.patch
patch -p1 < $CWD/patches/cairo-compmgr-link-libICE.patch
# gobject introspection will not be 'stable' until GTK+3
CFLAGS="$SLKCFLAGS" \
@ -83,7 +81,9 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-static \
--disable-gobject-introspection \
--build=$ARCH-slackware-linux \
${gconf_flags} \
--enable-gconf \
--with-gconf-source=\"xml::/etc/gconf/gconf.xml.defaults\" \
--disable-schemas-install \
${perf_flags}
make

View File

@ -5,6 +5,6 @@ DOWNLOAD="http://download.tuxfamily.org/ccm/cairo-compmgr/cairo-compmgr-0.3.0.ta
MD5SUM="f8a2b31d99505ca0308f3533160d8d3b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="vala"
REQUIRES="vala-12"
MAINTAINER="Geoff Ritter"
EMAIL="geoff dot ritter at gmail dot com"

View File

@ -0,0 +1,88 @@
Index: cairo-compmgr-0.3.0/configure.ac
===================================================================
--- cairo-compmgr-0.3.0.orig/configure.ac
+++ cairo-compmgr-0.3.0/configure.ac
@@ -81,6 +81,7 @@ PKG_CHECK_MODULES(CAIRO_COMPMGR,
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
Index: cairo-compmgr-0.3.0/configure
===================================================================
--- cairo-compmgr-0.3.0.orig/configure
+++ cairo-compmgr-0.3.0/configure
@@ -13369,6 +13369,7 @@ if test -n "$PKG_CONFIG"; then
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= \$CAIRO_REQUIRED,
pixman-1 >= \$PIXMAN_REQUIRED,
@@ -13378,6 +13379,7 @@ if test -n "$PKG_CONFIG"; then
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
@@ -13390,6 +13392,7 @@ if test -n "$PKG_CONFIG"; then
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
@@ -13411,6 +13414,7 @@ if test -n "$PKG_CONFIG"; then
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= \$CAIRO_REQUIRED,
pixman-1 >= \$PIXMAN_REQUIRED,
@@ -13420,6 +13424,7 @@ if test -n "$PKG_CONFIG"; then
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
@@ -13432,6 +13437,7 @@ if test -n "$PKG_CONFIG"; then
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
@@ -13459,6 +13465,7 @@ fi
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
@@ -13469,6 +13476,7 @@ fi
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
@@ -13482,6 +13490,7 @@ fi
xdamage,
xext,
xi,
+ x11,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,

View File

@ -0,0 +1,88 @@
Index: cairo-compmgr-0.3.0/configure
===================================================================
--- cairo-compmgr-0.3.0.orig/configure
+++ cairo-compmgr-0.3.0/configure
@@ -13372,6 +13372,7 @@ if test -n "$PKG_CONFIG"; then
sm,
cairo >= \$CAIRO_REQUIRED,
pixman-1 >= \$PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= \$GTK_REQUIRED
vala-1.0 >= \$VALA_REQUIRED\""; } >&5
($PKG_CONFIG --exists --print-errors "xcomposite,
@@ -13381,6 +13382,7 @@ if test -n "$PKG_CONFIG"; then
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED") 2>&5
ac_status=$?
@@ -13393,6 +13395,7 @@ if test -n "$PKG_CONFIG"; then
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED" 2>/dev/null`
else
@@ -13414,6 +13417,7 @@ if test -n "$PKG_CONFIG"; then
sm,
cairo >= \$CAIRO_REQUIRED,
pixman-1 >= \$PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= \$GTK_REQUIRED
vala-1.0 >= \$VALA_REQUIRED\""; } >&5
($PKG_CONFIG --exists --print-errors "xcomposite,
@@ -13423,6 +13427,7 @@ if test -n "$PKG_CONFIG"; then
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED") 2>&5
ac_status=$?
@@ -13435,6 +13440,7 @@ if test -n "$PKG_CONFIG"; then
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED" 2>/dev/null`
else
@@ -13462,6 +13468,7 @@ fi
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED"`
else
@@ -13472,6 +13479,7 @@ fi
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED"`
fi
@@ -13485,6 +13493,7 @@ fi
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED) were not met:
Index: cairo-compmgr-0.3.0/configure.ac
===================================================================
--- cairo-compmgr-0.3.0.orig/configure.ac
+++ cairo-compmgr-0.3.0/configure.ac
@@ -84,6 +84,7 @@ PKG_CHECK_MODULES(CAIRO_COMPMGR,
sm,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
+ gmodule-2.0,
gtk+-2.0 >= $GTK_REQUIRED
vala-1.0 >= $VALA_REQUIRED])
AC_SUBST(CAIRO_COMPMGR_CFLAGS)

View File

@ -0,0 +1,90 @@
http://cairo-compmgr.tuxfamily.org/bugs/index.php?do=details&task_id=80
Index: cairo-compmgr-0.3.0/configure
===================================================================
--- cairo-compmgr-0.3.0.orig/configure
+++ cairo-compmgr-0.3.0/configure
@@ -13371,6 +13371,7 @@ if test -n "$PKG_CONFIG"; then
xi,
x11,
sm,
+ ice,
cairo >= \$CAIRO_REQUIRED,
pixman-1 >= \$PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13382,6 +13383,7 @@ if test -n "$PKG_CONFIG"; then
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13396,6 +13398,7 @@ if test -n "$PKG_CONFIG"; then
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13419,6 +13422,7 @@ if test -n "$PKG_CONFIG"; then
xi,
x11,
sm,
+ ice,
cairo >= \$CAIRO_REQUIRED,
pixman-1 >= \$PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13430,6 +13434,7 @@ if test -n "$PKG_CONFIG"; then
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13444,6 +13449,7 @@ if test -n "$PKG_CONFIG"; then
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13473,6 +13479,7 @@ fi
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13485,6 +13492,7 @@ fi
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,
@@ -13500,6 +13508,7 @@ fi
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,
Index: cairo-compmgr-0.3.0/configure.ac
===================================================================
--- cairo-compmgr-0.3.0.orig/configure.ac
+++ cairo-compmgr-0.3.0/configure.ac
@@ -83,6 +83,7 @@ PKG_CHECK_MODULES(CAIRO_COMPMGR,
xi,
x11,
sm,
+ ice,
cairo >= $CAIRO_REQUIRED,
pixman-1 >= $PIXMAN_REQUIRED,
gmodule-2.0,