graphics/qiv: Updated for version 2.3.3.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
4f6096d5c7
commit
9b9e267ed0
|
@ -9,10 +9,7 @@ you can use qiv to set your X11-Desktop background.
|
||||||
|
|
||||||
These formats are supported by default:
|
These formats are supported by default:
|
||||||
|
|
||||||
GIF TIFF XPM PNG PPM PNM PGM BMP JPEG SVG ICO TGA ICNS WMF[*]
|
GIF TIFF XPM PNG PPM PNM PGM BMP JPEG SVG ICO TGA ICNS JP2
|
||||||
|
|
||||||
[*] If .wmf files won't load for you, make sure you've updated
|
|
||||||
Slackware recently (e.g. "slackpkg upgrade-all").
|
|
||||||
|
|
||||||
Optional supported formats:
|
Optional supported formats:
|
||||||
|
|
||||||
|
@ -22,16 +19,20 @@ PCX | pcx-pixbuf-loader
|
||||||
------------------------+-----------------------------------------------
|
------------------------+-----------------------------------------------
|
||||||
PSD (PhotoShop native) | gdk-pixbuf-psd
|
PSD (PhotoShop native) | gdk-pixbuf-psd
|
||||||
------------------------+-----------------------------------------------
|
------------------------+-----------------------------------------------
|
||||||
WEBP | imlib2 webp-pixbuf-loader. Build and
|
|
||||||
| install *in that order*.
|
|
||||||
------------------------+-----------------------------------------------
|
|
||||||
XCF (Gimp native) | xcf-pixbuf-loader
|
|
||||||
------------------------+-----------------------------------------------
|
|
||||||
RAW (camera images, | libopenraw. Note that only a few raw image
|
RAW (camera images, | libopenraw. Note that only a few raw image
|
||||||
various extensions) | formats will actually display with qiv. These
|
various extensions) | formats will actually display with qiv. These
|
||||||
| include .crw (Canon), .erf (Epson), and
|
| include .crw (Canon), .erf (Epson), and
|
||||||
| .nef (Nikon).
|
| .nef (Nikon).
|
||||||
------------------------+-----------------------------------------------
|
------------------------+-----------------------------------------------
|
||||||
|
WEBP | imlib2 and webp-pixbuf-loader. Build and
|
||||||
|
| install *in that order*.
|
||||||
|
------------------------+-----------------------------------------------
|
||||||
|
WMF (Windows MetaFile) | libwmf-type1-fonts (only needed for .wmf files
|
||||||
|
| with embedded text, but all the ones I tested
|
||||||
|
| do have text...)
|
||||||
|
------------------------+-----------------------------------------------
|
||||||
|
XCF (Gimp native) | xcf-pixbuf-loader
|
||||||
|
------------------------+-----------------------------------------------
|
||||||
|
|
||||||
These are runtime dependencies, so they can be installed at any time
|
These are runtime dependencies, so they can be installed at any time
|
||||||
without rebuilding qiv.
|
without rebuilding qiv.
|
||||||
|
|
|
@ -1,25 +1,22 @@
|
||||||
diff -Naur qiv-2.3.2/Makefile qiv-2.3.2.patched/Makefile
|
diff -Naur qiv-2.3.3/Makefile qiv-2.3.3.patched/Makefile
|
||||||
--- qiv-2.3.2/Makefile 2017-11-03 14:27:27.000000000 -0400
|
--- qiv-2.3.3/Makefile 2023-01-28 16:37:29.000000000 -0500
|
||||||
+++ qiv-2.3.2.patched/Makefile 2019-12-31 14:06:51.304388148 -0500
|
+++ qiv-2.3.3.patched/Makefile 2023-06-06 02:52:08.518230436 -0400
|
||||||
@@ -24,7 +24,7 @@
|
@@ -26,7 +26,7 @@
|
||||||
# skipped.) It should reflect whatever is compiled into imlib.
|
# or is compiled into imlib.
|
||||||
# The latest version of imlib has removed imagemagick fallback support,
|
# The latest version of imlib has removed imagemagick fallback support,
|
||||||
# so some extensions (XBM TGA) have been removed.
|
# so some extensions (XBM TGA) have been removed.
|
||||||
-EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO
|
-EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP HEIF
|
||||||
+EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP XCF PSD ICNS TGA RAW
|
+EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP HEIF XCF PSD ICNS TGA RAW JP2
|
||||||
|
|
||||||
# Comment this line out if your system doesn't have getopt_long().
|
# Comment this line out if your system doesn't have getopt_long().
|
||||||
GETOPT_LONG = -DHAVE_GETOPT_LONG
|
GETOPT_LONG = -DHAVE_GETOPT_LONG
|
||||||
diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
|
diff -Naur qiv-2.3.3/main.h qiv-2.3.3.patched/main.h
|
||||||
--- qiv-2.3.2/main.h 2017-11-03 14:27:27.000000000 -0400
|
--- qiv-2.3.3/main.h 2023-01-28 16:37:29.000000000 -0500
|
||||||
+++ qiv-2.3.2.patched/main.h 2019-12-31 14:27:29.455909124 -0500
|
+++ qiv-2.3.3.patched/main.h 2023-06-06 02:58:13.422196095 -0400
|
||||||
@@ -199,6 +199,27 @@
|
@@ -211,6 +211,21 @@
|
||||||
#ifdef EXTN_SVG
|
#ifdef EXTN_HEIF
|
||||||
".svg",
|
".heic", ".heif",
|
||||||
#endif
|
#endif
|
||||||
+#ifdef EXTN_WEBP
|
|
||||||
+ ".webp",
|
|
||||||
+#endif
|
|
||||||
+#ifdef EXTN_XCF
|
+#ifdef EXTN_XCF
|
||||||
+ ".xcf",
|
+ ".xcf",
|
||||||
+#endif
|
+#endif
|
||||||
|
@ -29,25 +26,19 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
|
||||||
+#ifdef EXTN_ICNS
|
+#ifdef EXTN_ICNS
|
||||||
+ ".icns",
|
+ ".icns",
|
||||||
+#endif
|
+#endif
|
||||||
+ /* BROKEN in slackware 14.2, using newer versions
|
|
||||||
+ of jasper and gdk-pixbuf2 built with jasper didn't help.
|
|
||||||
+ Disabled in Makefile. */
|
|
||||||
+#ifdef EXTN_JP2
|
+#ifdef EXTN_JP2
|
||||||
+ ".jp2", ".jpc", ".jpx", ".j2k", ".jpf",
|
+ ".jp2", ".jpc", ".jpx", ".j2k", ".jpf",
|
||||||
+#endif
|
+#endif
|
||||||
+#ifdef EXTN_RAW
|
+#ifdef EXTN_RAW
|
||||||
+ "dng", "cr2", "crw", "nef", "orf", "pef", "arw", "erf", "mrw", "raf",
|
+ ".dng", ".cr2", ".crw", ".nef", ".orf", ".pef", ".arw", ".erf", ".mrw", ".raf",
|
||||||
+#endif
|
+#endif
|
||||||
NULL
|
NULL
|
||||||
};
|
};
|
||||||
|
|
||||||
@@ -238,6 +259,29 @@
|
@@ -256,6 +271,27 @@
|
||||||
#ifdef EXTN_ICO
|
#ifdef EXTN_HEIF
|
||||||
"MS Windows icon resource",
|
"ISO Media, HEIF Image",
|
||||||
#endif
|
#endif
|
||||||
+#ifdef EXTN_WEBP
|
|
||||||
+ "RIFF (little-endian) data, Web/P image",
|
|
||||||
+#endif
|
|
||||||
+#ifdef EXTN_XCF
|
+#ifdef EXTN_XCF
|
||||||
+ "GIMP XCF image data",
|
+ "GIMP XCF image data",
|
||||||
+#endif
|
+#endif
|
||||||
|
@ -62,7 +53,8 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
|
||||||
+#endif
|
+#endif
|
||||||
+#ifdef EXTN_RAW
|
+#ifdef EXTN_RAW
|
||||||
+ /* 20191231 bkw: some of these (dng, nef, erf, pef) show up as TIFF
|
+ /* 20191231 bkw: some of these (dng, nef, erf, pef) show up as TIFF
|
||||||
+ with the file command, so we can't include them here. */
|
+ with the file command, so we can't include them here. cr3 is "ISO Media",
|
||||||
|
+ which fails to work if added here. */
|
||||||
+ "Canon CIFF",
|
+ "Canon CIFF",
|
||||||
+ "Canon CR2",
|
+ "Canon CR2",
|
||||||
+ "Olympus ORF",
|
+ "Olympus ORF",
|
||||||
|
|
|
@ -1,7 +1,8 @@
|
||||||
|
imlib2
|
||||||
libopenraw
|
libopenraw
|
||||||
libwebp
|
|
||||||
webp-pixbuf-loader
|
webp-pixbuf-loader
|
||||||
xcf-pixbuf-loader
|
xcf-pixbuf-loader
|
||||||
gdk-pixbuf-psd
|
gdk-pixbuf-psd
|
||||||
pcx-pixbuf-loader
|
pcx-pixbuf-loader
|
||||||
imlib2
|
libwmf-type1-fonts
|
||||||
|
qiv
|
||||||
|
|
|
@ -8,6 +8,14 @@
|
||||||
# version had no license, modified version released under the WTFPL. See
|
# version had no license, modified version released under the WTFPL. See
|
||||||
# http://www.wtfpl.net/txt/copying/ for details.
|
# http://www.wtfpl.net/txt/copying/ for details.
|
||||||
|
|
||||||
|
# 20230605 bkw:
|
||||||
|
# - Update for v2.3.3.
|
||||||
|
# - JPEG 2000 works now, so enable it in the Makefile.
|
||||||
|
# - WMF is broken. Fixed by adding new libwmf-type1-fonts optional
|
||||||
|
# dep. Documented in README.
|
||||||
|
# - Rework new_formats.diff. Script can no longer build old version.
|
||||||
|
# - Fix and update qiv-allfmt.sqf.
|
||||||
|
|
||||||
# 20191231 bkw:
|
# 20191231 bkw:
|
||||||
# - Add libopenraw (raw camera image) formats, BUILD=2.
|
# - Add libopenraw (raw camera image) formats, BUILD=2.
|
||||||
# - Remove mention of wmf-pixbuf loader from README and .sqf
|
# - Remove mention of wmf-pixbuf loader from README and .sqf
|
||||||
|
@ -32,8 +40,8 @@
|
||||||
cd $(dirname $0) ; CWD=$(pwd)
|
cd $(dirname $0) ; CWD=$(pwd)
|
||||||
|
|
||||||
PRGNAM=qiv
|
PRGNAM=qiv
|
||||||
VERSION=${VERSION:-2.3.2}
|
VERSION=${VERSION:-2.3.3}
|
||||||
BUILD=${BUILD:-2}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
PKGTYPE=${PKGTYPE:-tgz}
|
PKGTYPE=${PKGTYPE:-tgz}
|
||||||
|
|
||||||
|
@ -56,16 +64,12 @@ OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
if [ "$ARCH" = "i586" ]; then
|
if [ "$ARCH" = "i586" ]; then
|
||||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||||
LIBDIRSUFFIX=""
|
|
||||||
elif [ "$ARCH" = "i686" ]; then
|
elif [ "$ARCH" = "i686" ]; then
|
||||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||||
LIBDIRSUFFIX=""
|
|
||||||
elif [ "$ARCH" = "x86_64" ]; then
|
elif [ "$ARCH" = "x86_64" ]; then
|
||||||
SLKCFLAGS="-O2 -fPIC"
|
SLKCFLAGS="-O2 -fPIC"
|
||||||
LIBDIRSUFFIX="64"
|
|
||||||
else
|
else
|
||||||
SLKCFLAGS="-O2"
|
SLKCFLAGS="-O2"
|
||||||
LIBDIRSUFFIX=""
|
|
||||||
fi
|
fi
|
||||||
|
|
||||||
set -e
|
set -e
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="qiv"
|
PRGNAM="qiv"
|
||||||
VERSION="2.3.2"
|
VERSION="2.3.3"
|
||||||
HOMEPAGE="https://spiegl.de/qiv/"
|
HOMEPAGE="https://spiegl.de/qiv/"
|
||||||
DOWNLOAD="https://spiegl.de/qiv/download/qiv-2.3.2.tgz"
|
DOWNLOAD="https://spiegl.de/qiv/download/qiv-2.3.3.tgz"
|
||||||
MD5SUM="e64dd2cbd49f31264f60012e0138549b"
|
MD5SUM="62f7a3adf62b85cdc6244913abf56bac"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="imlib2"
|
REQUIRES="imlib2"
|
||||||
|
|
Loading…
Reference in New Issue