audio/plug: Updated for version 1.4.5.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Antonio Leal 2024-01-20 17:12:56 +00:00 committed by Willy Sudiarto Raharjo
parent f38b4f0a4f
commit 9b65a74ecb
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
3 changed files with 20 additions and 8 deletions

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt 2023-12-03 14:22:05.000000000 +0000
+++ CMakeLists.txt.new 2023-12-04 22:05:56.210467471 +0000
@@ -4,7 +4,7 @@
message(STATUS "~~~ ${PROJECT_NAME} v${PROJECT_VERSION} ~~~")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
-option(PLUG_UNITTEST "Build Unit Tests" ON)
+option(PLUG_UNITTEST "Build Unit Tests" OFF)
message(STATUS "Unit Tests : ${PLUG_UNITTEST}")
option(PLUG_COVERAGE "Enable Coverage" OFF)

9
audio/plug/plug.SlackBuild Normal file → Executable file
View File

@ -2,7 +2,7 @@
# Slackware build script for plug # Slackware build script for plug
# Copyright 2022 Antonio Leal, Lisbon, Portugal # Copyright 2022-2023 Antonio Leal, Porto Salvo, Oeiras, Portugal
# All rights reserved. # All rights reserved.
# #
# Redistribution and use of this script, with or without modification, is # Redistribution and use of this script, with or without modification, is
@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd) cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=plug PRGNAM=plug
VERSION=${VERSION:-1.4.3} VERSION=${VERSION:-1.4.5}
BUILD=${BUILD:-1} BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz} PKGTYPE=${PKGTYPE:-tgz}
@ -79,17 +79,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \; -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch CMakeLists.txt $CWD/CMakeLists.txt.patch
mkdir build mkdir build
cd build cd build
cmake .. cmake ..
make make
make unittest #make unittest
mkdir -p $PKG/usr/bin mkdir -p $PKG/usr/bin
cp $BUILDDIR/build/src/plug $PKG/usr/bin cp $BUILDDIR/build/src/plug $PKG/usr/bin
mkdir -p $PKG/lib/udev/rules.d mkdir -p $PKG/lib/udev/rules.d
cp $BUILDDIR/cmake/50-mustang.rules $PKG/lib/udev/rules.d cp $BUILDDIR/cmake/*.rules $PKG/lib/udev/rules.d
mkdir -p $PKG/usr/share/pixmaps mkdir -p $PKG/usr/share/pixmaps
cp $CWD/plug.png $PKG/usr/share/pixmaps cp $CWD/plug.png $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/share/applications mkdir -p $PKG/usr/share/applications

View File

@ -1,10 +1,10 @@
PRGNAM="plug" PRGNAM="plug"
VERSION="1.4.3" VERSION="1.4.5"
HOMEPAGE="https://github.com/offa/plug" HOMEPAGE="https://github.com/offa/plug"
DOWNLOAD="https://github.com/offa/plug/archive/v1.4.3/plug-1.4.3.tar.gz" DOWNLOAD="https://github.com/offa/plug/archive/v1.4.5/plug-1.4.5.tar.gz"
MD5SUM="69b7dfffaecc0ceec038267ae9981750" MD5SUM="c86d1dc7f4c44a8247199eaf3b6c448b"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""
REQUIRES="gtest" REQUIRES=""
MAINTAINER="Antonio Leal" MAINTAINER="Antonio Leal"
EMAIL="antonioleal@yahoo.com" EMAIL="antonioleal@yahoo.com"