libraries/grantlee-qt5: Updated for version 5.2.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
bab72b8b06
commit
9adf294b48
|
@ -1,40 +0,0 @@
|
||||||
diff -up grantlee-5.1.0/CMakeLists.txt.orig grantlee-5.1.0/CMakeLists.txt
|
|
||||||
--- grantlee-5.1.0/CMakeLists.txt.orig 2016-04-19 01:33:17.000000000 -0500
|
|
||||||
+++ grantlee-5.1.0/CMakeLists.txt 2016-04-19 06:44:06.371122149 -0500
|
|
||||||
@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
|
|
||||||
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
|
|
||||||
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
|
|
||||||
set( BIN_INSTALL_DIR bin )
|
|
||||||
-set( INCLUDE_INSTALL_DIR include )
|
|
||||||
+set( INCLUDE_INSTALL_DIR include/Grantlee5 )
|
|
||||||
set( DATA_INSTALL_DIR share/apps )
|
|
||||||
|
|
||||||
# set up RPATH/install_name_dir
|
|
||||||
diff -up grantlee-5.1.0/templates/lib/CMakeLists.txt.orig grantlee-5.1.0/templates/lib/CMakeLists.txt
|
|
||||||
--- grantlee-5.1.0/templates/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
|
|
||||||
+++ grantlee-5.1.0/templates/lib/CMakeLists.txt 2016-04-19 06:44:55.763336264 -0500
|
|
||||||
@@ -107,6 +107,10 @@ if (Qt5Script_FOUND)
|
|
||||||
|
|
||||||
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
|
|
||||||
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
|
|
||||||
+ target_include_directories(Grantlee_Templates
|
|
||||||
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
|
||||||
+ )
|
|
||||||
+
|
|
||||||
target_link_libraries(Grantlee_Templates
|
|
||||||
LINK_PRIVATE Qt5::Script
|
|
||||||
)
|
|
||||||
diff -up grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig grantlee-5.1.0/textdocument/lib/CMakeLists.txt
|
|
||||||
--- grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
|
|
||||||
+++ grantlee-5.1.0/textdocument/lib/CMakeLists.txt 2016-04-19 06:45:56.268598553 -0500
|
|
||||||
@@ -43,6 +43,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Stud
|
|
||||||
endforeach()
|
|
||||||
endif()
|
|
||||||
|
|
||||||
+target_include_directories(Grantlee_TextDocument
|
|
||||||
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
|
||||||
+)
|
|
||||||
+
|
|
||||||
target_link_libraries(Grantlee_TextDocument
|
|
||||||
LINK_PUBLIC Qt5::Gui
|
|
||||||
)
|
|
|
@ -0,0 +1,79 @@
|
||||||
|
From 9dfa187569e4c9c4e72ace60c051cbfa79434d77 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Troy Dawson <tdawson@redhat.com>
|
||||||
|
Date: Fri, 14 Feb 2020 13:43:27 -0800
|
||||||
|
Subject: [PATCH] install headers into versioned directory
|
||||||
|
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 1 +
|
||||||
|
templates/lib/CMakeLists.txt | 6 ++++--
|
||||||
|
textdocument/lib/CMakeLists.txt | 8 ++++++--
|
||||||
|
3 files changed, 11 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index 20edcdc..8df3dd6 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -80,6 +80,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '6
|
||||||
|
|
||||||
|
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
|
||||||
|
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
|
||||||
|
+set( INCLUDE_INSTALL_DIR include/Grantlee5 )
|
||||||
|
|
||||||
|
# set up RPATH/install_name_dir
|
||||||
|
set( CMAKE_INSTALL_NAME_DIR ${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR})
|
||||||
|
diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
|
||||||
|
index 5058481..c4262f3 100644
|
||||||
|
--- a/templates/lib/CMakeLists.txt
|
||||||
|
+++ b/templates/lib/CMakeLists.txt
|
||||||
|
@@ -106,6 +106,8 @@ if (Qt5Qml_FOUND)
|
||||||
|
)
|
||||||
|
endif()
|
||||||
|
|
||||||
|
+target_include_directories(Grantlee_Templates INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
|
||||||
|
+
|
||||||
|
if (BUILD_TESTS)
|
||||||
|
set(GRANTLEE_TESTS_EXPORT "GRANTLEE_TEMPLATES_EXPORT")
|
||||||
|
endif()
|
||||||
|
@@ -152,10 +154,10 @@ install(FILES
|
||||||
|
token.h
|
||||||
|
util.h
|
||||||
|
variable.h
|
||||||
|
- DESTINATION include/grantlee COMPONENT Templates
|
||||||
|
+ DESTINATION ${INCLUDE_INSTALL_DIR}/grantlee COMPONENT Templates
|
||||||
|
)
|
||||||
|
|
||||||
|
install(FILES
|
||||||
|
grantlee_templates.h
|
||||||
|
- DESTINATION include COMPONENT Templates
|
||||||
|
+ DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Templates
|
||||||
|
)
|
||||||
|
diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
|
||||||
|
index 2c5a96f..bf56052 100644
|
||||||
|
--- a/textdocument/lib/CMakeLists.txt
|
||||||
|
+++ b/textdocument/lib/CMakeLists.txt
|
||||||
|
@@ -35,6 +35,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Studio")
|
||||||
|
endforeach()
|
||||||
|
endif()
|
||||||
|
|
||||||
|
+target_include_directories(Grantlee_TextDocument
|
||||||
|
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
||||||
|
+)
|
||||||
|
+
|
||||||
|
target_link_libraries(Grantlee_TextDocument
|
||||||
|
PUBLIC Qt5::Gui
|
||||||
|
)
|
||||||
|
@@ -59,10 +63,10 @@ install(FILES
|
||||||
|
texthtmlbuilder.h
|
||||||
|
mediawikimarkupbuilder.h
|
||||||
|
${CMAKE_CURRENT_BINARY_DIR}/grantlee_textdocument_export.h
|
||||||
|
- DESTINATION include/grantlee COMPONENT TextDocument
|
||||||
|
+ DESTINATION ${INCLUDE_INSTALL_DIR}/grantlee COMPONENT TextDocument
|
||||||
|
)
|
||||||
|
|
||||||
|
install(FILES
|
||||||
|
grantlee_textdocument.h
|
||||||
|
- DESTINATION include COMPONENT TextDocument
|
||||||
|
+ DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT TextDocument
|
||||||
|
)
|
||||||
|
--
|
||||||
|
2.24.1
|
|
@ -2,7 +2,7 @@
|
||||||
|
|
||||||
# Slackware build script for grantlee-qt5
|
# Slackware build script for grantlee-qt5
|
||||||
|
|
||||||
# Copyright 2016 Larry Hajali <larryhaja[at]gmail[dot]com>
|
# Copyright 2016-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
#
|
#
|
||||||
# Redistribution and use of this script, with or without modification, is
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
@ -24,7 +24,7 @@
|
||||||
|
|
||||||
PRGNAM=grantlee-qt5
|
PRGNAM=grantlee-qt5
|
||||||
SRCNAM=grantlee
|
SRCNAM=grantlee
|
||||||
VERSION=${VERSION:-5.1.0}
|
VERSION=${VERSION:-5.2.0}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -74,7 +74,7 @@ find -L . \
|
||||||
# Install headers into a versioned directory to be parallel-installable
|
# Install headers into a versioned directory to be parallel-installable
|
||||||
# based on:
|
# based on:
|
||||||
# https://github.com/steveire/grantlee/pull/1
|
# https://github.com/steveire/grantlee/pull/1
|
||||||
patch -p1 < $CWD/grantlee-5.1.0-install_headers_into_versioned_directory.patch
|
patch -p1 < $CWD/grantlee-5.2.0-install_headers_into_versioned_directory.patch
|
||||||
|
|
||||||
mkdir build
|
mkdir build
|
||||||
cd build
|
cd build
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="grantlee-qt5"
|
PRGNAM="grantlee-qt5"
|
||||||
VERSION="5.1.0"
|
VERSION="5.2.0"
|
||||||
HOMEPAGE="https://github.com/steveire/grantlee"
|
HOMEPAGE="https://github.com/steveire/grantlee"
|
||||||
DOWNLOAD="https://github.com/steveire/grantlee/archive/v5.1.0/grantlee-5.1.0.tar.gz"
|
DOWNLOAD="https://github.com/steveire/grantlee/archive/v5.2.0/grantlee-5.2.0.tar.gz"
|
||||||
MD5SUM="3ce1e53cca2b5cad27d07ee82880e4c3"
|
MD5SUM="da76560384bb47ddd4e0dce07c0bdd8e"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="qt5"
|
REQUIRES="qt5"
|
||||||
|
|
Loading…
Reference in New Issue