games/briquolo: Added (breakout with 3D based on OpenGL)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
31d9fa9e0f
commit
9a5d642f2e
|
@ -0,0 +1,2 @@
|
|||
This is a 3d view breakout with moving stones, fancy levels and a
|
||||
lot of special effects put in.
|
|
@ -0,0 +1,94 @@
|
|||
#!/bin/sh
|
||||
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
|
||||
# Copyright 2009, 2010, 2011, 2012 Eric Hameleers, Eindhoven, Netherlands
|
||||
|
||||
# Slackware build script for briquolo
|
||||
|
||||
# Written by Ronny Schmatzler <schmatzler@hirnschwund.net>
|
||||
|
||||
# Based on http://slackbuilds.org/template.SlackBuild
|
||||
|
||||
PRGNAM=briquolo
|
||||
VERSION=${VERSION:-0.5.7}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) export ARCH=i486 ;;
|
||||
arm*) export ARCH=arm ;;
|
||||
*) export ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
#Before building, we have to apply a lot of patches. Developer has left his application :(
|
||||
#Fix building with "newer" gcc versions (> 4.3)
|
||||
patch -p1 < $CWD/patches/gcc-fixes.patch
|
||||
#Fix building against newer libpng
|
||||
patch -p1 < $CWD/patches/libpng14.patch
|
||||
#Fix crash on ATI/AMD graphic cards
|
||||
patch -p1 < $CWD/patches/fix_ati_crash.patch
|
||||
#Fix badly written desktop entry
|
||||
patch -p1 < $CWD/patches/desktop-entry.patch
|
||||
#Done! Lets do the rest in standard way now.
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
# Workaround some stupid Makefile problems.
|
||||
sed -i -e's|icondir = $(DESTDIR)|icondir = |' desktop/Makefile
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL DejaVuSans.ttf-LICENSE README \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="briquolo"
|
||||
VERSION="0.5.7"
|
||||
HOMEPAGE="http://briquolo.free.fr"
|
||||
DOWNLOAD="http://briquolo.free.fr/download/briquolo-0.5.7.tar.bz2"
|
||||
MD5SUM="e24d22d2d719d64c231d3d76f9291d6e"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Ronny Schmatzler"
|
||||
EMAIL="schmatzler@hirnschwund.net"
|
||||
APPROVED="dsomero"
|
|
@ -0,0 +1,4 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
|
@ -0,0 +1,34 @@
|
|||
--- briquolo-0.5.7/desktop/briquolo.desktop 2006-03-07 21:31:26.000000000 +0100
|
||||
+++ briquolo.desktop 2012-05-21 23:00:50.000000000 +0200
|
||||
@@ -1,22 +1,12 @@
|
||||
[Desktop Entry]
|
||||
-Version=1.0
|
||||
Encoding=UTF-8
|
||||
Name=Briquolo
|
||||
-Name[fr]=Briquolo
|
||||
-
|
||||
-Comment=An OpenGL breakout
|
||||
-Comment[fr]=Un casse brique OpenGL
|
||||
-
|
||||
-Type=Application
|
||||
-Categories=ArcadeGame;Game;
|
||||
-
|
||||
-TryExec=briquolo
|
||||
-Exec=briquolo
|
||||
-FilePattern=briquolo
|
||||
-
|
||||
-Icon=briquolo.svg
|
||||
+Icon=/usr/share/pixmaps/briquolo.svg
|
||||
+GenericName=An OpenGL breakout clone
|
||||
+GenericName[de_DE]=Ein OpenGL Breakout-Klon
|
||||
+Exec=/usr/bin/briquolo
|
||||
Terminal=false
|
||||
-
|
||||
-GenericName=BreakOut
|
||||
-GenericName[fr]=Casse Briques
|
||||
-Categories=Application;Game;
|
||||
+StartupNotify=false
|
||||
+Type=Application
|
||||
+TryExec=/usr/bin/supertuxkart
|
||||
+Categories=Game;ArcadeGame;
|
||||
\ Kein Zeilenumbruch am Dateiende.
|
|
@ -0,0 +1,22 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 10_fix_ati_crash.dpatch by Bradley Smith <brad@brad-smith.co.uk>
|
||||
##
|
||||
## DP: Fixes crash on ati cards
|
||||
|
||||
@DPATCH@
|
||||
|
||||
diff -Naur briquolo-0.5.7.orig/src/MOGL/MOGL_Fenetre.cpp briquolo-0.5.7/src/MOGL/MOGL_Fenetre.cpp
|
||||
--- briquolo-0.5.7.orig/src/MOGL/MOGL_Fenetre.cpp 2008-03-24 13:23:07.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/MOGL/MOGL_Fenetre.cpp 2008-03-29 19:41:40.000000000 +0000
|
||||
@@ -168,6 +168,11 @@
|
||||
// On recommence donc !
|
||||
_NbBitParPixel = 24;
|
||||
_SurfaceSDL = _CreerFenetre(_NbBitParPixel, flags);
|
||||
+ if(_SurfaceSDL == NULL)
|
||||
+ {
|
||||
+ _NbBitParPixel = 16;
|
||||
+ _SurfaceSDL = _CreerFenetre(_NbBitParPixel, flags);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
if (_SurfaceSDL == NULL)
|
|
@ -0,0 +1,88 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 10_gcc-4.3-fixes.dpatch by <ansgar@43-1.org>
|
||||
## Refreshed by <brad@brad-smith.co.uk>
|
||||
##
|
||||
## DP: Fix compliation with gcc-4.3
|
||||
|
||||
@DPATCH@
|
||||
|
||||
diff -Naur briquolo-0.5.7.orig/src/Constante.cpp briquolo-0.5.7/src/Constante.cpp
|
||||
--- briquolo-0.5.7.orig/src/Constante.cpp 2008-03-22 09:40:33.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/Constante.cpp 2008-03-29 18:47:44.000000000 +0000
|
||||
@@ -20,6 +20,7 @@
|
||||
*
|
||||
*****************************************************************************/
|
||||
#include "Constante.h"
|
||||
+#include <cstdlib>
|
||||
|
||||
#ifdef HAVE_CONFIG_H
|
||||
#include "config.h"
|
||||
diff -Naur briquolo-0.5.7.orig/src/I18n.cpp briquolo-0.5.7/src/I18n.cpp
|
||||
--- briquolo-0.5.7.orig/src/I18n.cpp 2006-03-07 20:31:24.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/I18n.cpp 2008-03-29 18:47:44.000000000 +0000
|
||||
@@ -22,6 +22,7 @@
|
||||
#include "I18n.h"
|
||||
#include <iostream>
|
||||
#include "Constante.h"
|
||||
+#include <cstdlib>
|
||||
|
||||
#ifdef WIN32
|
||||
#include <windows.h>
|
||||
diff -Naur briquolo-0.5.7.orig/src/MOGL/MOGL_EnsembleObjet.cpp briquolo-0.5.7/src/MOGL/MOGL_EnsembleObjet.cpp
|
||||
--- briquolo-0.5.7.orig/src/MOGL/MOGL_EnsembleObjet.cpp 2008-03-24 13:12:36.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/MOGL/MOGL_EnsembleObjet.cpp 2008-03-29 18:47:44.000000000 +0000
|
||||
@@ -24,7 +24,8 @@
|
||||
#include "MOGL_Armature.h"
|
||||
#include "MOGL_Peau.h"
|
||||
//#include
|
||||
-#include <stdio.h>
|
||||
+#include <cstdio>
|
||||
+#include <cstring>
|
||||
|
||||
//#include <mmsystem.h>
|
||||
|
||||
diff -Naur briquolo-0.5.7.orig/src/MOGL/MOGL_GestionnaireObjet.cpp briquolo-0.5.7/src/MOGL/MOGL_GestionnaireObjet.cpp
|
||||
--- briquolo-0.5.7.orig/src/MOGL/MOGL_GestionnaireObjet.cpp 2008-03-24 12:56:13.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/MOGL/MOGL_GestionnaireObjet.cpp 2008-03-29 18:47:44.000000000 +0000
|
||||
@@ -21,6 +21,7 @@
|
||||
*****************************************************************************/
|
||||
#include "../I18n.h"
|
||||
#include "MOGL_GestionnaireObjet.h"
|
||||
+#include <cstring>
|
||||
|
||||
bool MOGL_GestionnaireObjet::ChargerObjetASCTriangle(const char * p_NomFichier, const MOGL_GestionnaireTexture & p_GM,
|
||||
MOGL_Objet & p_Objet)
|
||||
diff -Naur briquolo-0.5.7.orig/src/MOGL/MOGL_GestionnaireObjet.h briquolo-0.5.7/src/MOGL/MOGL_GestionnaireObjet.h
|
||||
--- briquolo-0.5.7.orig/src/MOGL/MOGL_GestionnaireObjet.h 2006-03-07 20:31:24.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/MOGL/MOGL_GestionnaireObjet.h 2008-03-29 18:47:44.000000000 +0000
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
#include <vector>
|
||||
#include <iostream>
|
||||
-#include <stdio.h>
|
||||
+#include <cstdio>
|
||||
|
||||
#include "MOGL_Triangle.h"
|
||||
#include "MOGL_Objet.h"
|
||||
diff -Naur briquolo-0.5.7.orig/src/MOGL/MOGL_Objet.cpp briquolo-0.5.7/src/MOGL/MOGL_Objet.cpp
|
||||
--- briquolo-0.5.7.orig/src/MOGL/MOGL_Objet.cpp 2006-03-07 20:31:24.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/MOGL/MOGL_Objet.cpp 2008-03-29 18:47:44.000000000 +0000
|
||||
@@ -20,6 +20,7 @@
|
||||
*
|
||||
*****************************************************************************/
|
||||
#include "MOGL_Objet.h"
|
||||
+#include <cstdlib>
|
||||
|
||||
//MOGL_Objet::MOGL_Objet(): MOGL_ObjetAbstrait(), MOGL_ElementArbre()
|
||||
MOGL_Objet::MOGL_Objet(): MOGL_Noeud(), _ModifieTriangle(true), _ModifieStrip(true),
|
||||
diff -Naur briquolo-0.5.7.orig/src/MOGL/MOGL_Peau.cpp briquolo-0.5.7/src/MOGL/MOGL_Peau.cpp
|
||||
--- briquolo-0.5.7.orig/src/MOGL/MOGL_Peau.cpp 2006-03-07 20:31:24.000000000 +0000
|
||||
+++ briquolo-0.5.7/src/MOGL/MOGL_Peau.cpp 2008-03-29 18:47:44.000000000 +0000
|
||||
@@ -20,6 +20,7 @@
|
||||
*
|
||||
*****************************************************************************/
|
||||
#include "MOGL_Peau.h"
|
||||
+#include <cstdlib>
|
||||
|
||||
MOGL_Peau::MOGL_Peau(): MOGL_Noeud(), _ModifieTriangle(true)
|
||||
{
|
|
@ -0,0 +1,24 @@
|
|||
# Copyright © José Luis Lara Carrascal 2010-2011 <manualinux@yahoo.es>
|
||||
# <http://manualinux.freehostia.com> <http://manualinux.exofire.net> <http://manualinux.heliohost.org>
|
||||
# Este parche se distribuye bajo la Licencia General GNU
|
||||
|
||||
diff -ruN briquolo-0.5.7/src/MOGL/MOGL_Image.cpp briquolo-0.5.7a/src/MOGL/MOGL_Image.cpp
|
||||
--- briquolo-0.5.7/src/MOGL/MOGL_Image.cpp 2006-03-07 21:53:33.000000000 +0100
|
||||
+++ briquolo-0.5.7a/src/MOGL/MOGL_Image.cpp 2010-07-16 16:27:11.000000000 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
using namespace std;
|
||||
|
||||
#define PNG_BYTES_TO_CHECK 8
|
||||
+#define png_infopp_NULL (png_infopp)NULL
|
||||
|
||||
MOGL_Image::MOGL_Image(bool p_AutoriserTrou)
|
||||
: _Image(NULL), _AutoriserTrou(p_AutoriserTrou), _R(0), _G(0), _B(0), _TypeImage(NON_DEFINI)
|
||||
@@ -235,7 +236,7 @@
|
||||
/* Expand grayscale images to the full 8 bits from 1, 2, or 4 bits/pixel */
|
||||
if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
|
||||
{
|
||||
- png_set_gray_1_2_4_to_8(png_ptr);
|
||||
+ png_set_expand_gray_1_2_4_to_8(png_ptr);
|
||||
}
|
||||
|
||||
/* Expand paletted or RGB images with transparency to full alpha channels
|
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
briquolo: briquolo (breakout with 3D representation based on OpenGL)
|
||||
briquolo:
|
||||
briquolo: This is a 3d view breakout with moving stones, fancy levels and a
|
||||
briquolo: lot of special effects put in.
|
||||
briquolo:
|
||||
briquolo: Homepage: http://briquolo.free.fr
|
||||
briquolo:
|
||||
briquolo:
|
||||
briquolo:
|
||||
briquolo:
|
||||
briquolo:
|
Loading…
Reference in New Issue