games/xmoto: Updated for version 0.5.1
This commit is contained in:
parent
e6c6e9aa4f
commit
98cc6486f8
|
@ -1,18 +1,5 @@
|
||||||
X-Moto is a challenging 2D motocross platform game, where physics play an all
|
X-Moto is a challenging 2D motocross platform game, where physics play an all
|
||||||
important role in the gameplay. You need to control your bike to its limit, if
|
important role in the gameplay. You need to control your bike to its limit, if
|
||||||
you want to have a chance finishing the more difficult of the challenges.
|
you want to have a chance finishing the more difficult of the challenges.
|
||||||
|
|
||||||
IMPORTANT:
|
Requires lua and ode.
|
||||||
X-Moto recently changed its hosting to tuxfamily.org. As a result, for X-Moto
|
|
||||||
to connect to this new server, you have to update the file 'config.dat' located
|
|
||||||
at ~/.xmoto/config.dat. You can open this file and replace all the occurences
|
|
||||||
of xmoto.free.fr with xmoto.tuxfamily.org, or if you don't know how to do that,
|
|
||||||
just replace the file config.dat with the one provided in the X-Moto SlackBuild
|
|
||||||
tar.gz archive (you will lose your configuration, but not your highscores).
|
|
||||||
Moreover, you should remove the file rooms.xml next to this one.
|
|
||||||
This is only necessary if you want to enable X-Moto to be able to connect to
|
|
||||||
the internet. (from http://xmoto.tuxfamily.org)
|
|
||||||
|
|
||||||
Requirements:
|
|
||||||
>=lua-5.1 (available @ SlackBuilds.org)
|
|
||||||
>=ode-0.7 (available @ SlackBuilds.org)
|
|
|
@ -1,11 +0,0 @@
|
||||||
<?xml version="1.0" encoding="utf-8"?>
|
|
||||||
|
|
||||||
<userconfig>
|
|
||||||
<var name="WebHighscoresURL" value="http://xmoto.tuxfamily.org/highscores.xml"/>
|
|
||||||
<var name="WebLevelsURL" value="http://xmoto.tuxfamily.org/levels.xml"/>
|
|
||||||
<var name="WebThemesURL" value="http://xmoto.tuxfamily.org/themes.xml"/>
|
|
||||||
<var name="WebThemesURLBase" value="http://xmoto.tuxfamily.org/sprites"/>
|
|
||||||
<var name="WebRoomsURL" value="http://xmoto.tuxfamily.org/rooms.xml"/>
|
|
||||||
<var name="WebHighscoreUploadURL" value="http://xmoto.tuxfamily.org/tools/UploadReplay.php"/>
|
|
||||||
</userconfig>
|
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
|
|
||||||
if [ -x usr/bin/update-desktop-database ]; then
|
if [ -x /usr/bin/update-desktop-database ]; then
|
||||||
./usr/bin/update-desktop-database ./usr/share/applications >/dev/null 2>&1
|
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
|
@ -0,0 +1,12 @@
|
||||||
|
diff -Naur xmoto-0.5.0.orig/po/Makefile.in.in xmoto-0.5.0/po/Makefile.in.in
|
||||||
|
--- xmoto-0.5.0.orig/po/Makefile.in.in 2008-11-23 09:32:28.000000000 +0000
|
||||||
|
+++ xmoto-0.5.0/po/Makefile.in.in 2009-03-30 20:44:01.000000000 +0000
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
datarootdir = @datarootdir@
|
||||||
|
datadir = @datadir@
|
||||||
|
localedir = @localedir@
|
||||||
|
-gettextsrcdir = $(datadir)/gettext/po
|
||||||
|
+gettextsrcdir = @localedir@/gettext/po
|
||||||
|
|
||||||
|
INSTALL = @INSTALL@
|
||||||
|
INSTALL_DATA = @INSTALL_DATA@
|
|
@ -0,0 +1,30 @@
|
||||||
|
diff -Naur xmoto-0.5.0.orig/configure xmoto-0.5.0/configure
|
||||||
|
--- xmoto-0.5.0.orig/configure 2008-11-23 09:33:21.000000000 +0000
|
||||||
|
+++ xmoto-0.5.0/configure 2009-03-30 20:52:48.000000000 +0000
|
||||||
|
@@ -5104,7 +5104,7 @@
|
||||||
|
cat >>confdefs.h <<_ACEOF
|
||||||
|
#define `echo "HAVE_$ac_header" | $as_tr_cpp` 1
|
||||||
|
_ACEOF
|
||||||
|
- SQLITE_LIBS=-lsqlite3
|
||||||
|
+ SQLITE_LIBS=`pkg-config --static --libs sqlite3`
|
||||||
|
else
|
||||||
|
{ { echo "$as_me:$LINENO: error: \"sqlite3 required\"" >&5
|
||||||
|
echo "$as_me: error: \"sqlite3 required\"" >&2;}
|
||||||
|
@@ -5120,7 +5120,7 @@
|
||||||
|
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||||
|
else
|
||||||
|
ac_check_lib_save_LIBS=$LIBS
|
||||||
|
-LIBS="-lsqlite3 $LIBS"
|
||||||
|
+LIBS="`pkg-config --static --libs sqlite3` $LIBS"
|
||||||
|
cat >conftest.$ac_ext <<_ACEOF
|
||||||
|
/* confdefs.h. */
|
||||||
|
_ACEOF
|
||||||
|
@@ -5174,7 +5174,7 @@
|
||||||
|
#define HAVE_LIBSQLITE3 1
|
||||||
|
_ACEOF
|
||||||
|
|
||||||
|
- LIBS="-lsqlite3 $LIBS"
|
||||||
|
+ LIBS="`pkg-config --static --libs sqlite3` $LIBS"
|
||||||
|
|
||||||
|
else
|
||||||
|
{ { echo "$as_me:$LINENO: error: \"Linking against sqlite3 failed.\"" >&5
|
|
@ -13,7 +13,7 @@ xmoto: playan all important role in the gameplay. You need to control your
|
||||||
xmoto: bike to its limit, if you want to have a chance finishing the more
|
xmoto: bike to its limit, if you want to have a chance finishing the more
|
||||||
xmoto: difficult of the challenges.
|
xmoto: difficult of the challenges.
|
||||||
xmoto:
|
xmoto:
|
||||||
xmoto:
|
xmoto: Homepage: http://xmoto.tuxfamily.org/
|
||||||
xmoto:
|
xmoto:
|
||||||
xmoto:
|
xmoto:
|
||||||
xmoto:
|
xmoto:
|
||||||
|
|
|
@ -8,71 +8,74 @@
|
||||||
## did not write. Thanks.
|
## did not write. Thanks.
|
||||||
|
|
||||||
# Modified by the SlackBuilds.org project
|
# Modified by the SlackBuilds.org project
|
||||||
|
# Updated by Alex Word <alex_word86@yahoo.com>
|
||||||
|
|
||||||
set -e
|
set -e
|
||||||
|
|
||||||
NAME=xmoto
|
PRGNAM=xmoto
|
||||||
VERSION=0.2.4
|
VERSION=0.5.1
|
||||||
ARCH=${ARCH:-i486}
|
ARCH=${ARCH:-i486}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
CWD=$(pwd)
|
CWD=$(pwd)
|
||||||
TMP=${TMP:-/tmp/SBo}
|
TMP=${TMP:-/tmp/SBo}
|
||||||
PKG=${PKG:-$TMP/package-$NAME}
|
PKG=${PKG:-$TMP/package-$PRGNAM}
|
||||||
OUTPUT=${OUTPUT:-/tmp}
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
rm -rf $PKG $TMP/$NAME-$VERSION
|
|
||||||
mkdir -p $TMP $PKG $OUTPUT
|
|
||||||
cd $TMP
|
|
||||||
tar zxvf $CWD/$NAME-$VERSION-src.tar.gz
|
|
||||||
cd $NAME-$VERSION
|
|
||||||
chown -R root:root .
|
|
||||||
chmod -R u+w,go+r-w,a-s .
|
|
||||||
|
|
||||||
if [ "$ARCH" = "i486" ]; then
|
if [ "$ARCH" = "i486" ]; then
|
||||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||||
elif [ "$ARCH" = "i686" ]; then
|
elif [ "$ARCH" = "i686" ]; then
|
||||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||||
|
elif [ "$ARCH" = "x86_64" ]; then
|
||||||
|
SLKCFLAGS="-O2 -fPIC"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
rm -rf $PKG $TMP/$PRGNAM-$VERSION
|
||||||
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
|
cd $TMP
|
||||||
|
tar xvf $CWD/$PRGNAM-$VERSION-src.tar.gz
|
||||||
|
cd $PRGNAM-$VERSION
|
||||||
|
chown -R root:root .
|
||||||
|
chmod -R u+w,go+r-w,a-s .
|
||||||
|
|
||||||
|
patch -p1 < $CWD/patches/sqlite3.diff
|
||||||
|
patch -p1 < $CWD/patches/localedir.diff
|
||||||
|
|
||||||
CFLAGS="$SLKCFLAGS" \
|
CFLAGS="$SLKCFLAGS" \
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
CXXFLAGS="$SLKCFLAGS" \
|
||||||
./configure \
|
./configure \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--exec-prefix=/usr \
|
--localstatedir=/var \
|
||||||
--bindir=/usr/games \
|
--mandir=/usr/man \
|
||||||
--sysconfdir=/etc \
|
--localedir=/usr/share/locale \
|
||||||
--localstatedir=/var \
|
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||||
--libdir=/usr/lib/games \
|
--with-localesdir=/usr/share/locale \
|
||||||
--datadir=/usr/share/games \
|
--disable-dependency-tracking \
|
||||||
--datarootdir=/usr \
|
--enable-threads=posix \
|
||||||
--docdir=/usr/doc/$NAME-$VERSION \
|
--with-enable-zoom=1 \
|
||||||
--enable-threads=posix \
|
--with-renderer-sdlGfx=0 \
|
||||||
--with-enable-www=1 \
|
--with-renderer-openGl=1 \
|
||||||
--with-enable-zoom=1
|
--with-x \
|
||||||
|
--build=$ARCH-slackware-linux
|
||||||
|
|
||||||
make
|
make
|
||||||
make install-strip DESTDIR=$PKG
|
make install-strip DESTDIR=$PKG
|
||||||
|
|
||||||
mkdir -p $PKG/usr/share/{pixmaps,applications}
|
mkdir -p $PKG/usr/share/{pixmaps,applications}
|
||||||
install -m 0644 extra/$NAME.xpm $PKG/usr/share/pixmaps/
|
install -m 0644 extra/$PRGNAM.xpm $PKG/usr/share/pixmaps/
|
||||||
install -m 0644 extra/$NAME.desktop $PKG/usr/share/applications/
|
install -m 0644 extra/$PRGNAM.desktop $PKG/usr/share/applications/
|
||||||
|
|
||||||
# X-Moto doesn't like to honour the locale options that
|
gzip -9 $PKG/usr/man/man?/*.?
|
||||||
# the configure script says it does.
|
|
||||||
mv $PKG/usr/share/games/locale $PKG/usr/share
|
|
||||||
|
|
||||||
# Man pages are already gzipped, but there's one small problem
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
mv $PKG/usr/man/mang $PKG/usr/man/man6
|
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$NAME-$VERSION
|
|
||||||
cp -a ABOUT-NLS AUTHORS COPYING INSTALL NEWS README TODO ChangeLog \
|
cp -a ABOUT-NLS AUTHORS COPYING INSTALL NEWS README TODO ChangeLog \
|
||||||
$PKG/usr/doc/$NAME-$VERSION
|
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
mkdir -p $PKG/install
|
mkdir -p $PKG/install
|
||||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||||
|
|
||||||
cd $PKG
|
cd $PKG
|
||||||
/sbin/makepkg -l y -c n -p $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
|
/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="xmoto"
|
PRGNAM="xmoto"
|
||||||
VERSION="0.2.4"
|
VERSION="0.5.1"
|
||||||
HOMEPAGE="http://xmoto.tuxfamily.org/"
|
HOMEPAGE="http://xmoto.tuxfamily.org/"
|
||||||
DOWNLOAD="http://dl.sourceforge.net/xmoto/xmoto-0.2.4-src.tar.gz"
|
DOWNLOAD="http://download.tuxfamily.org/xmoto/xmoto/0.5.1/xmoto-0.5.1-src.tar.gz"
|
||||||
MD5SUM="78f776695a664b855e3659df25cc6d82"
|
MD5SUM="10cb822ec8c2c7e9466806633e69be1f"
|
||||||
MAINTAINER="hollywoodb"
|
MAINTAINER="Alex Word"
|
||||||
EMAIL="hollywoodb@fastmail.fm"
|
EMAIL="alex_word86@yahoo.com"
|
||||||
APPROVED="rworkman"
|
APPROVED="dsomero"
|
||||||
|
|
Loading…
Reference in New Issue