development/meld3: Updated for version 3.12.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
d06632ca17
commit
97542b79de
|
@ -2,7 +2,7 @@
|
||||||
|
|
||||||
# Slackware build script for meld3
|
# Slackware build script for meld3
|
||||||
|
|
||||||
# Copyright 2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
|
# Copyright 2014-2015 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
#
|
#
|
||||||
# Redistribution and use of this script, with or without modification, is
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
@ -24,8 +24,8 @@
|
||||||
|
|
||||||
PRGNAM=meld3
|
PRGNAM=meld3
|
||||||
SRCNAM=meld
|
SRCNAM=meld
|
||||||
VERSION=${VERSION:-3.12.2}
|
VERSION=${VERSION:-3.12.3}
|
||||||
BUILD=${BUILD:-2}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
if [ -z "$ARCH" ]; then
|
if [ -z "$ARCH" ]; then
|
||||||
|
@ -68,7 +68,6 @@ find -L . \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
patch -p1 < $CWD/utf8.patch
|
|
||||||
python setup.py install --root=$PKG
|
python setup.py install --root=$PKG
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="meld3"
|
PRGNAM="meld3"
|
||||||
VERSION="3.12.2"
|
VERSION="3.12.3"
|
||||||
HOMEPAGE="http://meldmerge.org/"
|
HOMEPAGE="http://meldmerge.org/"
|
||||||
DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/meld/3.12/meld-3.12.2.tar.xz"
|
DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/meld/3.12/meld-3.12.3.tar.xz"
|
||||||
MD5SUM="a11c4abf923d136e410fa9e8217c0bba"
|
MD5SUM="4cb8cf5d1f07b4350d253f325b9c9c20"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="pygobject3 gtksourceview3"
|
REQUIRES="pygobject3 gtksourceview3"
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- a/meld/patchdialog.py
|
|
||||||
+++ b/meld/patchdialog.py
|
|
||||||
@@ -118,6 +118,7 @@
|
|
||||||
filename = self.filediff._get_filename_for_saving(
|
|
||||||
_("Save Patch"))
|
|
||||||
if filename:
|
|
||||||
+ txt = txt.encode('utf-8')
|
|
||||||
self.filediff._save_text_to_filename(filename, txt)
|
|
||||||
break
|
|
||||||
|
|
Loading…
Reference in New Issue