system/linuxconsoletools: Added (joystick utilities)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Roberto Neri 2011-04-08 21:23:05 -05:00 committed by Robby Workman
parent 10792ab804
commit 94be40ff8e
6 changed files with 138 additions and 0 deletions

View File

@ -0,0 +1,2 @@
# Restore any stored calibration for the device
KERNEL=="js*", ACTION=="add", RUN+="/usr/bin/jscal-restore %E{DEVNAME}"

View File

@ -0,0 +1,12 @@
The Linux Console Project evolves from the command-line tools (jscal, jstest,
and jsattach) which were included in Version 1 of the Linux Joystick Driver.
The original set of tools has been expanded and now includes utilities to test
and configure joysticks, connect legacy devices to the kernel's input subsystem
(providing support for serial mice, touchscreens etc.), and test the input event
layer.
* this replaces the "joystick" build that was previously available
* included in this build is a simple udev rule to automatically restore the
joystick configuration(s); see the package README in the documentation
directory for more specific rules

View File

@ -0,0 +1,13 @@
diff -ur linuxconsoletools-1.4rc1.orig//docs/Makefile linuxconsoletools-1.4rc1/docs/Makefile
--- linuxconsoletools-1.4rc1.orig//docs/Makefile 2011-04-04 07:20:32.000000000 +0200
+++ linuxconsoletools-1.4rc1/docs/Makefile 2011-04-06 09:09:39.269000004 +0200
@@ -26,7 +26,7 @@
PREFIX ?= /usr/local
install:
- install -d $(DESTDIR)$(PREFIX)/share/man/man1
- install $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
+ install -d $(DESTDIR)$(PREFIX)/man/man1
+ install $(MANPAGES) $(DESTDIR)$(PREFIX)/man/man1
.PHONY: install

View File

@ -0,0 +1,82 @@
#!/bin/sh
# Slackware build script for linuxconsoletools
# Written by Roberto Neri <rneri@libero.it>
PRGNAM=linuxconsoletools
VERSION=${VERSION:-1.4rc1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Patch to install manpages in /usr/man instead of /usr/share/man
patch -p1 < $CWD/$PRGNAM-$VERSION.diff
# No ./configure provided
make CFLAGS="$SLKCFLAGS" PREFIX=/usr
make install DESTDIR=$PKG PREFIX=/usr
mkdir -p $PKG/lib/udev/rules.d/
install -m 0644 $CWD/90-joystick.rules $PKG/lib/udev/rules.d/90-joystick.rules
mkdir -p $PKG/var/lib/joystick
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $(find $PKG/usr/man -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="linuxconsoletools"
VERSION="1.4rc1"
HOMEPAGE="http://sourceforge.net/projects/linuxconsole/"
DOWNLOAD="http://downloads.sourceforge.net/project/linuxconsole/linuxconsoletools-1.4rc1.tar.bz2"
MD5SUM="cc2bd7359fc949d6f8382593226721f3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Roberto Neri"
EMAIL="rneri@libero.it"
APPROVED="rworkman"

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
linuxconsoletools: linuxconsoletools (test/configuration utilities for joysticks)
linuxconsoletools:
linuxconsoletools: The Linux Console tools include utilities to test and configure
linuxconsoletools: joysticks, connect legacy devices to the kernel's input subsystem
linuxconsoletools: (providing support for serial mice, touchscreens etc.), and test the
linuxconsoletools: input event layer.
linuxconsoletools:
linuxconsoletools: Homepage: http://sourceforge.net/projects/linuxconsole/
linuxconsoletools:
linuxconsoletools:
linuxconsoletools: