desktop/dolphin-megasync: Updated for version 5.2.1.0.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
JW(Shinichi Abe) 2024-05-12 06:41:18 +07:00 committed by Willy Sudiarto Raharjo
parent fa68cb5552
commit 9483ea795e
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
4 changed files with 16 additions and 21 deletions

View File

@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dolphin-megasync
SRCNAM=MEGAsync
VERSION=${VERSION:-4.7.2.0}
VERSION=${VERSION:-5.2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -73,10 +73,9 @@ cd $SRCNAM-${VERSION}_Linux
# prepare source
mkdir -p build
# Apply Arch patch (Thanks to Arch)
patch -p2 -i $CWD/kf5.patch --verbose || extit 1
mv src/MEGAShellExtDolphin/CMakeLists.txt src/MEGAShellExtDolphin/CMakeLists.txt.old
mv src/MEGAShellExtDolphin/CMakeLists_kde5.txt src/MEGAShellExtDolphin/CMakeLists.txt
# fix kf5 INSTALL PATH
cp src/MEGAShellExtDolphin/CMakeLists.txt src/MEGAShellExtDolphin/CMakeLists.txt.old
patch -p1 -i $CWD/kf5_5.2.1.0_Linux.patch --verbose || exit 1
chown -R root:root .
find -L . \

View File

@ -1,10 +1,10 @@
PRGNAM="dolphin-megasync"
VERSION="4.7.2.0"
VERSION="5.2.1.0"
HOMEPAGE="https://github.com/meganz/MEGAsync/"
DOWNLOAD="https://github.com/meganz/MEGAsync/archive/v4.7.2.0_Linux/MEGAsync-4.7.2.0_Linux.tar.gz"
MD5SUM="b1734bf785e279dd0d01d8ff254c7587"
DOWNLOAD="https://github.com/meganz/MEGAsync/archive/v5.2.1.0_Linux/MEGAsync-5.2.1.0_Linux.tar.gz"
MD5SUM="ec6e327ea4d45853455fbf23e1fcd62d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
REQUIRES="MEGAsync"
MAINTAINER="JW(Shinichi Abe)"
EMAIL="shin1.abe@nifty.com"

View File

@ -1,12 +0,0 @@
diff --git a/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt b/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt
@@ -64,4 +64,4 @@ target_link_libraries(${MEGASYNCPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWid
#install(FILES ${CMAKE_CURRENT_BINARY_DIR}/megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
install(FILES megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
-install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${CMAKE_INSTALL_LIBDIR}/qt5/plugins)
+install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${PLUGIN_INSTALL_DIR})
diff --git a/MEGAsync/src/MEGAShellExtDolphin/megasync-plugin.moc b/src/MEGAShellExtDolphin/megasync-plugin.moc
deleted file mode 100644
index e69de29b..00000000

View File

@ -0,0 +1,8 @@
--- MEGAsync-5.2.1.0_Linux/src/MEGAShellExtDolphin/CMakeLists.txt 2024-04-17 20:25:54.000000000 +0900
+++ MEGAsync-5.2.1.0_Linux.New/src/MEGAShellExtDolphin/CMakeLists.txt 2024-05-10 19:38:46.571062863 +0900
@@ -58,4 +58,4 @@
target_link_libraries(${MEGASYNCPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWidgets)
install(FILES megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
-install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${CMAKE_INSTALL_LIBDIR}/qt5/plugins)
+install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${PLUGIN_INSTALL_DIR})