office/keepnote: Added to 13.0 repository
This commit is contained in:
parent
441f146c49
commit
9360204e79
|
@ -0,0 +1,10 @@
|
|||
KeepNote is a note taking application.
|
||||
With KeepNote, you can store your class notes, TODO lists, research notes,
|
||||
journal entries, paper outlines, etc in a simple notebook hierarchy
|
||||
with rich-text formatting, images, and more. Using full-text search,
|
||||
you can retrieve any note for later reference.
|
||||
|
||||
KeepNote is implemented in Python and PyGTK
|
||||
|
||||
To use spell checking (optional) you will need:
|
||||
python-gnome2-extras
|
|
@ -0,0 +1,22 @@
|
|||
--- ./index_ori.py 2009-11-24 17:06:09.000000000 +0100
|
||||
+++ ./index.py 2010-02-01 23:33:13.000000000 +0100
|
||||
@@ -30,7 +30,18 @@
|
||||
import sys
|
||||
import traceback
|
||||
from thread import get_ident
|
||||
-import sqlite3 as sqlite
|
||||
+#import sqlite3 as sqlite
|
||||
+
|
||||
+#modif mcc
|
||||
+try:
|
||||
+ import sqlite3 as sqlite
|
||||
+except ImportError:
|
||||
+ try:
|
||||
+ from pysqlite2 import dbapi2 as sqlite
|
||||
+ except ImportError:
|
||||
+ raise ImportError, "no module sqlite3 or pysqlite2"
|
||||
+
|
||||
+
|
||||
sqlite.enable_shared_cache(True)
|
||||
#sqlite.threadsafety = 0
|
||||
|
|
@ -0,0 +1,9 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
|
@ -0,0 +1,82 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for keepnote
|
||||
# Home Page http://rasm.ods.org/keepnote/
|
||||
|
||||
# (C) 2010 mcc <mccnews@free.fr>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=keepnote
|
||||
VERSION=0.6.1
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
DOCS="CHANGES COPYING INSTALL LICENSE PKG-INFO README README.translations.txt"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e # Exit on most errors
|
||||
|
||||
rm -fr $TMP/$PRGNAM-$VERSION $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root.root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Correction for python without sqlite3
|
||||
patch keepnote/notebook/index.py < $CWD/difsql1.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
||||
# Build
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
# Add documentation
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
# Make package
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="keepnote"
|
||||
VERSION="0.6.1"
|
||||
HOMEPAGE="http://rasm.ods.org/keepnote/"
|
||||
DOWNLOAD="http://rasm.ods.org/keepnote/download/keepnote-0.6.1.tar.gz"
|
||||
MD5SUM="3153159d83c26b26d14e6621fe7d99c1"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="mccnews"
|
||||
EMAIL="mccnews@free.fr"
|
||||
APPROVED="dsomero"
|
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler----------------------------------------------------|
|
||||
keepnote: keepnote (a note taking application)
|
||||
keepnote:
|
||||
keepnote: With KeepNote, you can store your class notes, TODO lists,
|
||||
keepnote: research notes, journal entries, paper outlines, etc in a simple
|
||||
keepnote: notebook hierarchy with rich-text formatting, images, and more.
|
||||
keepnote: Using full-text search, you can retrieve any note
|
||||
keepnote: for later reference.
|
||||
keepnote:
|
||||
keepnote:
|
||||
keepnote: Homepage: http://rasm.ods.org/keepnote/
|
||||
keepnote:
|
Loading…
Reference in New Issue