office/kchmviewer: Updated for version 5.2.

Signed-off-by: Erik Hanson <erik@slackbuilds.org>
This commit is contained in:
Michiel van Wessem 2010-08-14 14:13:44 -05:00 committed by Erik Hanson
parent 0b47c7c5d3
commit 93459515c7
3 changed files with 30 additions and 6 deletions

View File

@ -0,0 +1,20 @@
diff -Naur build-5.2-orig/src/CMakeLists.txt build-5.2/src/CMakeLists.txt
--- build-5.2-orig/src/CMakeLists.txt 2009-12-15 06:27:57.000000000 +0000
+++ build-5.2/src/CMakeLists.txt 2010-08-07 01:05:09.775042811 +0100
@@ -12,6 +12,8 @@
main.cpp
mainwindow.cpp
navigationpanel.cpp
+ toolbareditor.cpp
+ toolbarmanager.cpp
recentfiles.cpp
settings.cpp
tab_bookmarks.cpp
@@ -30,6 +32,7 @@
dialog_about.ui
dialog_setup.ui
dialog_topicselector.ui
+ toolbareditor.ui
mainwindow.ui
navigatorpanel.ui
tab_bookmarks.ui

View File

@ -1,7 +1,7 @@
#!/bin/sh
#
# SlackBuild script for KchmViewer.
# Copyright 2007-2009 Michiel van Wessem, Manchester, United Kingdom
# Copyright 2007-2010 Michiel van Wessem, Manchester, United Kingdom
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@ -24,7 +24,7 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=kchmviewer
VERSION=${VERSION:-5.1}
VERSION=${VERSION:-5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -61,7 +61,7 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
rm -rf $TMP/$PRGNAM-$VERSION
rm -rf $TMP/build-$VERSION
cd $TMP
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
cd build-$VERSION
@ -72,6 +72,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Patch to build kchmviewer properly. Thanks to
# http://bugs.gentoo.org/320191.
patch -p1 < $CWD/kchmviewer-5.2-kde-build.patch
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \

View File

@ -1,8 +1,8 @@
PRGNAM="kchmviewer"
VERSION="5.1"
VERSION="5.2"
HOMEPAGE="http://www.kchmviewer.net"
DOWNLOAD="http://downloads.sourceforge.net/kchmviewer/kchmviewer-5.1.tar.gz"
MD5SUM="9b68c3e233fe3d8e16251ba95526a493"
DOWNLOAD="http://downloads.sourceforge.net/kchmviewer/kchmviewer-5.2.tar.gz"
MD5SUM="9798c7f949d1137949e69a8c226415f9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Michiel van Wessem"