audio/abcde: Updated for version 2.3.99.6

This commit is contained in:
Jim Capozzoli 2010-05-12 17:36:47 +02:00 committed by David Somero
parent 1dcdc943a6
commit 9200a8fd01
7 changed files with 82 additions and 32 deletions

View File

@ -1,6 +1,5 @@
diff -Nur abcde-2.3.3.orig/Makefile abcde-2.3.3/Makefile
--- abcde-2.3.3.orig/Makefile 2005-08-25 17:43:27.000000000 -0500
+++ abcde-2.3.3/Makefile 2007-02-01 10:21:55.000000000 -0600
--- abcde-2.3.99.6.orig/Makefile 2006-08-05 10:10:52.000000000 +1000
+++ abcde-2.3.99.6/Makefile 2008-12-18 21:26:21.000000000 +1100
@@ -4,7 +4,7 @@
# Installation directories
prefix = ${DESTDIR}/usr

View File

@ -1,13 +1,20 @@
abcde is a frontend command-line utility (actually, a shell script)
that grabs tracks off a CD encodes them to Ogg/Vorbis, MP3, FLAC,
OGG/Speex, and/or MPP/MP+(Musepack) format, and tags them, all in one
go.
OGG/Speex, MPP/MP+(Musepack) and/or M4A/AAC format, and tags them
all in one go.
abcde requires cd-discid, which is also available at SlackBuilds.org.
If you want to have mp3 encoding capability, you need to install the
lame package (lame is also available at SlackBuilds.org).
abcde requires cd-discid which can be found on Slackbuilds.org. There
are many features that abcde supports and many of these packages can
be also found on Slackbuilds.org:
There are many more features that abcde supports that you can add on, such as
mkcue and encoding in other various formats, see the man page for more info.
Try running abcde as root (sudo or whatever) if abcde/cd-discid thinks your
favorite audio cd is a data cd.
* faac : for creating m4a/aac files
* id3lib : for manipulating ID3v1 and ID3v2 tags
* id3v2 : for writing id3v2 tags
* lame : for creating mp3 files
* mppenc : for creating MPP/MP+(Musepack) files
* speex : for creating Speex files
* vorbisgain : for adjusting the volume of ogg vorbis files
Try running abcde as root (sudo or whatever) if abcde/cd-discid thinks
your favorite audio cd is a data cd. Please note also that faac needs
to have mp4 support enabled to work correctly with abcde.

View File

@ -0,0 +1,35 @@
# ------------------------------------------------------------------------------------------------ #
# This patch fixes automatic aac and speex tagging in abcde-2.3.99.6
# and is an amalgamation of 2 separate patches from Ubuntu and Fedora:
# http://patches.ubuntu.com/a/abcde/abcde_2.3.99.6-1ubuntu2.patch
# http://cvs.fedoraproject.org/viewvc/rpms/abcde/F-10/abcde-2.3.99.6-speex-comment.patch?view=co
# ------------------------------------------------------------------------------------------------ #
diff -Naur abcde-2.3.99.6.orig/abcde abcde-2.3.99.6/abcde
--- abcde-2.3.99.6.orig/abcde 2006-08-06 05:14:00.000000000 +1000
+++ abcde-2.3.99.6/abcde 2009-03-17 21:07:11.000000000 +1100
@@ -1068,11 +1068,10 @@
*=*) ;;
*) COMMENT="COMMENT=$COMMENT" ;;
esac
- COMMENT="--comment \"$COMMENT\""
fi
- # Quick hack to avoid tagging Ogg/Speex, since there is no other way to tag than inline tagging
- if [ ! "$DOTAG" = "y" ]; then
- $RUN_COMMAND nice $EFFECTIVE_NICE $SPEEXENCODER $SPEEXENCODEROPTS --author "$TRACKARTIST" --title "$TRACKNAME" "$COMMENT" "$IN" "$OUT"
+ # Tag the file at encode time, as it can't be done after encoding.
+ if [ "$DOTAG" = "y" ]; then
+ $RUN_COMMAND nice $EFFECTIVE_NICE $SPEEXENCODER $SPEEXENCODEROPTS --author "$TRACKARTIST" --title "$TRACKNAME" ${COMMENT:+--comment "$COMMENT"} "$IN" "$OUT"
else
$RUN_COMMAND nice $EFFECTIVE_NICE $SPEEXENCODER $SPEEXENCODEROPTS "$IN" "$OUT"
fi
@@ -1087,8 +1086,8 @@
$RUN_COMMAND nice $EFFECTIVE_NICE $MPPENCODER $MPPENCODEROPTS --artist "$TRACKARTIST" --album "$DALBUM" --title "$TRACKNAME" --track "$1" --genre "$CDGENRE" --year "$CDYEAR" --comment "$COMMENT" "$IN" "$OUT"
;;
m4a)
- # Quick hack to avoid tagging Ogg/Speex, since there is no other way to tag than inline tagging
- if [ ! "$DOTAG" = "y" ]; then
+ # Tag the file at encode time, as it can't be done after encoding.
+ if [ "$DOTAG" = "y" ]; then
$RUN_COMMAND nice $EFFECTIVE_NICE $AACENCODER $AACENCODEROPTS --artist "$TRACKARTIST" --album "$DALBUM" --title "$TRACKNAME" --track "$1" --genre "$CDGENRE" --year "$CDYEAR" --comment "$COMMENT" -o "$OUT" "$IN"
else

View File

@ -23,25 +23,26 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by the SlackBuilds.org project
set -e
# Modified by Andrew Strong
PRGNAM=abcde
VERSION=2.3.3
VERSION=2.3.99.6
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
rm -rf $TMP/$PRGNAM-$VERSION
cd $TMP
tar -xzvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
tar xvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
@ -56,16 +57,24 @@ chmod -R u+w,go+r-w,a-s .
# --rworkman
patch -p1 < $CWD/Makefile.diff
# An amalgamated patch from Ubuntu and Fedora which allows automatic tagging
# of both m4a/aac and speex files, broken in this version of abcde. Normally
# this should be submitted upstream rather than placed in a SlackBuild script
# but unfortunately there is no upstream at the moment :-).
# For what its worth I have also submitted to the final resting place of abcde:
# http://code.google.com/p/abcde/issues/detail?id=7
patch -p1 < $CWD/aac_speex_tagging.diff
make
make install DESTDIR=$PKG || exit
make install DESTDIR=$PKG
# Let's not overwrite the config file if it already exists
mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING FAQ README TODO changelog examples $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
( cd $PKG/usr/man || exit
find . -type f -exec gzip -9 {} \;

View File

@ -1,8 +1,8 @@
PRGNAM="abcde"
VERSION="2.3.3"
HOMEPAGE="http://www.hispalinux.es/~data/abcde.php"
DOWNLOAD="http://www.hispalinux.es/~data/files/abcde_2.3.3.orig.tar.gz"
MD5SUM="94877d1e410ae420630b1048e82907d3"
VERSION="2.3.99.6"
HOMEPAGE="http://freshmeat.net/projects/abcde/"
DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/a/abcde/abcde_2.3.99.6.orig.tar.gz"
MD5SUM="ac9be20f3098b0943212168171d33ffa"
MAINTAINER="Jim Capozzoli"
EMAIL="saltmiser@gmail.com"
APPROVED="rworkman,BP{k}"
APPROVED="dsomero"

View File

@ -1,10 +1,10 @@
config() {
NEW="$1"
OLD="`dirname $NEW`/`basename $NEW .new`"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
# If there's no config file by that name, mv it over:
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "`cat $OLD | md5sum`" = "`cat $NEW | md5sum`" ]; then
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
# toss the redundant copy
rm $NEW
fi

View File

@ -9,11 +9,11 @@
abcde: abcde (shell script to encode CD's)
abcde:
abcde: abcde is a frontend command-line utility (actually, a shell script)
abcde: that grabs tracks off a CD, encodes them to Ogg/Vorbis, MP3, FLAC,
abcde: OGG/Speex and/or MPP/MP+(Musepack) format, and tags them, all in one
abcde: go.
abcde:
abcde:
abcde: that grabs tracks from a CD, encodes them to Ogg/Vorbis, MP3, FLAC,
abcde: OGG/Speex, MPP/MP+(Musepack) and/or M4A/AAC format, and tags them,
abcde: all in one go.
abcde:
abcde: Homepage: http://freshmeat.net/projects/abcde/
abcde:
abcde:
abcde: