audio/vamp-plugin-sdk: Added (audio plugin api)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Luis Henrique 2010-06-29 20:59:13 -05:00 committed by Robby Workman
parent f161518537
commit 8ddac80dd6
6 changed files with 155 additions and 0 deletions

View File

@ -0,0 +1,5 @@
Vamp is an API for C and C++ plugins that process sampled audio data
to produce descriptive output (measurements or semantic observations).
Pass PRG_BUILD=no to the script if you don't wan't the example programs
to be installed.

View File

@ -0,0 +1,11 @@
--- examples/FixedTempoEstimator.cpp.orig 2010-06-21 17:34:12.000000000 -0300
+++ examples/FixedTempoEstimator.cpp 2010-06-21 17:34:34.000000000 -0300
@@ -44,7 +44,7 @@
using Vamp::RealTime;
#include <cmath>
-
+#include <cstdio>
class FixedTempoEstimator::D
// this class just avoids us having to declare any data members in the header

View File

@ -0,0 +1,23 @@
diff -Nur vamp-plugin-sdk-2.1.orig//Makefile.in vamp-plugin-sdk-2.1/Makefile.in
--- vamp-plugin-sdk-2.1.orig//Makefile.in 2009-09-24 07:05:26.000000000 -0500
+++ vamp-plugin-sdk-2.1/Makefile.in 2010-06-29 20:55:29.742160342 -0500
@@ -71,8 +71,8 @@
INSTALL_API_HEADERS = $(INSTALL_PREFIX)/include/vamp
INSTALL_SDK_HEADERS = $(INSTALL_PREFIX)/include/vamp-sdk
INSTALL_HOSTSDK_HEADERS = $(INSTALL_PREFIX)/include/vamp-hostsdk
-INSTALL_SDK_LIBS = $(INSTALL_PREFIX)/lib
-INSTALL_PLUGINS = $(INSTALL_PREFIX)/lib/vamp
+INSTALL_SDK_LIBS = $(INSTALL_PREFIX)/lib64
+INSTALL_PLUGINS = $(INSTALL_PREFIX)/lib64/vamp
INSTALL_BINARIES = $(INSTALL_PREFIX)/bin
INSTALL_SDK_LIBNAME = libvamp-sdk.so.2.1.0
@@ -87,7 +87,7 @@
INSTALL_HOSTSDK_STATIC = libvamp-hostsdk.a
INSTALL_HOSTSDK_LA = libvamp-hostsdk.la
-INSTALL_PKGCONFIG = $(INSTALL_PREFIX)/lib/pkgconfig
+INSTALL_PKGCONFIG = $(INSTALL_PREFIX)/lib64/pkgconfig
# Flags required to tell the compiler to create a dynamically loadable object
#

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
vamp-plugin-sdk: vamp-plugin-sdk (audio analysis API)
vamp-plugin-sdk:
vamp-plugin-sdk: Vamp is an API for C and C++ plugins that process sampled audio data
vamp-plugin-sdk: to produce descriptive output (measurements or semantic observations).
vamp-plugin-sdk:
vamp-plugin-sdk: Homepage: http://www.vamp-plugins.org
vamp-plugin-sdk:
vamp-plugin-sdk:
vamp-plugin-sdk:
vamp-plugin-sdk:
vamp-plugin-sdk:

View File

@ -0,0 +1,87 @@
#!/bin/sh
# Slackware build script for vamp
# Written by Luis Henrique <lmello.009@gmail.com>
PRGNAM=vamp-plugin-sdk
VERSION=${VERSION:-2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
# Enable building of example host and RDF generator:
PRG_BUILD=${PRG_BUILD:-yes}
set -e # Exit on most errors
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Include <cstdio>, for God's sake!
patch -p0 < $CWD/cstdio.diff
# Fix libdir on x86_64
[ "$ARCH" = "x86_64" ] && patch -p1 < $CWD/libdir_x86_64.diff
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--enable-programs=$PRG_BUILD \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
CHANGELOG COPYING INSTALL README README.compat \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="vamp-plugin-sdk"
VERSION="2.1"
HOMEPAGE="http://www.vamp-plugins.org"
DOWNLOAD="http://downloads.sourceforge.net/project/vamp/vamp-plugin-sdk/2.1/vamp-plugin-sdk-2.1.tar.gz"
MD5SUM="13252077a73987dae72a9174e529b6b9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Luis Henrique"
EMAIL="lmello.009@gmail.com"
APPROVED="rworkman"