network/gmapcatcher: Updated for version 0.7.7.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
9149fe3147
commit
8cf6f4066d
|
@ -1,8 +1,6 @@
|
|||
GMapCatcher is an offline maps viewer. It downloads tiles automatically
|
||||
from many providers such as: CloudMade, OpenStreetMap, Yahoo Maps,
|
||||
Google Map. It displays them using a custom GUI. User can view the
|
||||
maps while offline. GMapCatcher doesn't depend on the map's JavaScript so it
|
||||
should work even if they change them. It also provides a downloading tool.
|
||||
|
||||
GMapCatcher is written in Python 2.6, can run on Linux, Windows and
|
||||
Mac OSX.
|
||||
maps while offline. GMapCatcher doesn't depend on google-map's java
|
||||
scripts so it should work even if google changes them. It also provides
|
||||
a downloading tool.
|
||||
|
|
|
@ -5,16 +5,14 @@
|
|||
# Written by Pablo Santamaria (pablosantamaria)
|
||||
|
||||
PRGNAM=gmapcatcher
|
||||
VERSION=${VERSION:-0.7.5.0}
|
||||
VERSION=${VERSION:-0.7.7.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -53,6 +51,9 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Patch setup.py for include tilesRepo
|
||||
patch -p1 < $CWD/patch-setup.diff
|
||||
|
||||
# Prepare files for install
|
||||
rm -rf WindowsMobile
|
||||
mv maps.py mapcatcher
|
||||
|
@ -63,6 +64,7 @@ cp images/map.png images/mapcatcher.png
|
|||
chmod a-x gmapcatcher.desktop
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
( cd $PKG/usr/bin ; ln -s mapcatcher gmapcatcher )
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
@ -74,7 +76,6 @@ mv $PKG/usr/share/man $PKG/usr
|
|||
mkdir -p $PKG/usr/doc
|
||||
mv $PKG/usr/share/doc/mapcatcher $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rmdir $PKG/usr/share/doc
|
||||
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="gmapcatcher"
|
||||
VERSION="0.7.5.0"
|
||||
VERSION="0.7.7.2"
|
||||
HOMEPAGE="http://code.google.com/p/gmapcatcher/"
|
||||
DOWNLOAD="http://gmapcatcher.googlecode.com/files/GMapCatcher-0.7.5.0.tar.gz"
|
||||
MD5SUM="f011f0016f8be4898a4efbf32173994f"
|
||||
DOWNLOAD="http://gmapcatcher.googlecode.com/files/GMapCatcher-0.7.7.2.tar.gz"
|
||||
MD5SUM="02c243c8e5b0ea36f8389bedc5c3ffef"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Pablo Santamaria"
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
diff -ru GMapCatcher-0.7.7.2/setup.py GMapCatcher-0.7.7.2.new/setup.py
|
||||
--- GMapCatcher-0.7.7.2/setup.py 2012-04-28 10:35:10.000000000 -0300
|
||||
+++ GMapCatcher-0.7.7.2.new/setup.py 2012-07-09 11:06:37.054422933 -0300
|
||||
@@ -24,7 +24,7 @@
|
||||
scripts = ['mapcatcher', 'mapdownloader'],
|
||||
packages = ['gmapcatcher', 'gmapcatcher.mapServers',
|
||||
'gmapcatcher.pyGPSD', 'gmapcatcher.pyGPSD.nmea',
|
||||
- 'gmapcatcher.pyGPSD.nmea.serial']
|
||||
+ 'gmapcatcher.pyGPSD.nmea.serial', 'gmapcatcher.tilesRepo']
|
||||
)
|
||||
else:
|
||||
import py2exe
|
|
@ -11,9 +11,9 @@ gmapcatcher:
|
|||
gmapcatcher: GMapCatcher is an offline maps viewer. It downloads tiles
|
||||
gmapcatcher: automatically from many providers such as: CloudMade, OpenStreetMap,
|
||||
gmapcatcher: Yahoo Maps, Google Map. It displays them using a custom GUI. User can
|
||||
gmapcatcher: view the maps while offline. GMapCatcher doesn't depend on the map's
|
||||
gmapcatcher: Javascript so it should work even if they change them.
|
||||
gmapcatcher: It also provides a downloading tool.
|
||||
gmapcatcher: view the maps while offline. GMapCatcher doesn't depend on maps's
|
||||
gmapcatcher: JavaScript so it should work even if they change them. It also
|
||||
gmapcatcher: provides a downloading tool.
|
||||
gmapcatcher:
|
||||
gmapcatcher:
|
||||
gmapcatcher:
|
||||
|
|
Loading…
Reference in New Issue