audio/pulseaudio: Removed (Included in Slackware 14.2)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Robby Workman 2016-01-06 15:35:34 -06:00 committed by Willy Sudiarto Raharjo
parent fefbc567a7
commit 8b1655bd97
8 changed files with 0 additions and 351 deletions

View File

@ -1,22 +0,0 @@
--- src/Makefile.am.orig 2014-02-14 23:45:45.000000000 +1000
+++ src/Makefile.am 2014-10-26 21:59:33.220234317 +1000
@@ -19,6 +19,8 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
+.NOTPARALLEL:
+
###################################
# Extra directories #
###################################
--- Makefile.am.orig 2014-01-24 04:57:55.000000000 +1000
+++ Makefile.am 2014-10-26 21:58:47.090622189 +1000
@@ -15,6 +15,8 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
+.NOTPARALLEL:
+
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \

View File

@ -1,91 +0,0 @@
--- shell-completion/bash/pulseaudio.orig 2015-02-13 00:10:35.000000000 +1000
+++ shell-completion/bash/pulseaudio 2015-09-12 11:09:36.948222926 +1000
@@ -1,39 +1,45 @@
#!/bin/bash
__cards () {
+ (pactl list cards short 2> /dev/null) |\
while IFS=$'\t' read idx name _; do
printf "%s %s\n" "$idx" "$name"
- done < <(pactl list cards short 2> /dev/null)
+ done
}
__sinks () {
+ (pactl list sinks short 2> /dev/null) |\
while IFS=$'\t' read _ name _ _ _; do
printf "%s\n" "$name"
- done < <(pactl list sinks short 2> /dev/null)
+ done
}
__sinks_idx () {
+ (pactl list sinks short 2> /dev/null) |\
while IFS=$'\t' read idx _ _ _ _; do
printf "%s\n" "$idx"
- done < <(pactl list sinks short 2> /dev/null)
+ done
}
__sources () {
+ (pactl list sources short 2> /dev/null) |\
while IFS=$'\t' read _ name _ _ _; do
printf "%s\n" "$name"
- done < <(pactl list sources short 2> /dev/null)
+ done
}
__sink_inputs () {
+ (pactl list sink-inputs short 2> /dev/null) |\
while IFS=$'\t' read idx _ _ _ _; do
printf "%s\n" "$idx"
- done < <(pactl list sink-inputs short 2> /dev/null)
+ done
}
__source_outputs () {
+ (pactl list source-outputs short 2> /dev/null) |\
while IFS=$'\t' read idx _ _ _ _; do
printf "%s\n" "$idx"
- done < <(pactl list source-outputs short 2> /dev/null)
+ done
}
__ports () {
@@ -77,28 +83,32 @@
}
__all_modules () {
+ (pulseaudio --dump-modules 2> /dev/null) |\
while read name; do
name=${name%% *}
printf "%s\n" "$name"
- done < <(pulseaudio --dump-modules 2> /dev/null)
+ done
}
__loaded_modules () {
+ (pactl list modules short 2> /dev/null) |\
while IFS=$'\t' read idx name _; do
printf "%s %s\n" "$idx" "$name"
- done < <(pactl list modules short 2> /dev/null)
+ done
}
__resample_methods () {
+ (pulseaudio --dump-resample-methods 2> /dev/null) |\
while read name; do
printf "%s\n" "$name"
- done < <(pulseaudio --dump-resample-methods 2> /dev/null)
+ done
}
_pacat_file_formats () {
+ (pacat --list-file-formats 2> /dev/null) |\
while IFS=$'\t' read name _; do
printf "%s\n" "$name"
- done < <(pacat --list-file-formats 2> /dev/null)
+ done
}
in_array() {

View File

@ -1,27 +0,0 @@
pulseaudio is a networked sound server for Unix-like operating systems
and Microsoft Windows. It is intended to be an improved drop-in replacement
for the Enlightened Sound Daemon (ESOUND).
Optional deps: sbc, jack-audio-connection-kit, avahi, lirc, libasyncns, orc
Bluetooth support requires the optional sbc package (in addition to the
standard bluez package).
USAGE:
In almost all cases, pulseaudio should be run as a normal user daemon
i.e. NOT a system wide daemon. It will be usually started by the desktop
environment (KDE, XFCE, MATE) when the user logs in. In general, there is
nothing more the user needs to do (configuration for particular devices or
circumstances notwithstanding).
If necessary, pulseaudio may be started manually with:
/usr/bin/start-pulseaudio-x11
In the EXTREMELY RARE case that pulseaudio needs to run as a system wide
daemon, the /etc/rc.d/rc.pulseaudio script is provided. It is not used at all
in the usual case, as above, in which pulseaudio runs as a normal user daemon.
Additionally, in the system wide daemon mode only, pulseaudio will need a
pulse group/user to run as. This may be done with:
groupadd -g 216 pulse
useradd -u 216 -g pulse -d /var/run/pulse -m pulse
See http://slackbuilds.org/uid_gid.txt for details on the uid/gid assignments.

View File

@ -1,27 +0,0 @@
config() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
# If there's no config file by that name, mv it over:
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
# toss the redundant copy
rm $NEW
fi
# Otherwise, we leave the .new copy for the admin to consider...
}
preserve_perms() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
if [ -e $OLD ]; then
cp -a $OLD ${NEW}.incoming
cat $NEW > ${NEW}.incoming
mv ${NEW}.incoming $NEW
fi
config $NEW
}
config etc/pulse/client.conf.new
config etc/pulse/daemon.conf.new
config etc/pulse/default.pa.new
config etc/pulse/system.pa.new
preserve_perms etc/rc.d/rc.pulseaudio.new

View File

@ -1,112 +0,0 @@
#!/bin/sh
# Slackware build script for pulseaudio
# Written by crocket (crockabiscuit@gmail.com)
# Maintained 2013-2015 by Christoph Willing <chris.willing@linux.com>
PRGNAM=pulseaudio
VERSION=${VERSION:-7.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
patch -p0 < $CWD/020_no-parallel-make.diff
patch -p0 < $CWD/030_posix-completion.diff
sed -i -e '/@PA_BINARY@/ imkdir -p \$HOME/.config/pulse' src/daemon/start-pulseaudio-x11.in
echo "X-MATE-Autostart-Phase=Initialization" >>src/daemon/pulseaudio.desktop.in
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
if pkg-config --exists orc-0.4 ; then
ORC=yes
else
ORC=no
fi
if pkg-config --exists bash-completion ; then
BASHCOMPLETIONDIR=$(pkg-config --variable=completionsdir bash-completion)
else
echo "Setting completions directory manually."
BASHCOMPLETIONDIR=/usr/share/bash-completion/completions
fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./bootstrap.sh \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--disable-tcpwrap \
--enable-orc=${ORC} \
--disable-static \
--enable-hal-compat \
--with-system-user=pulse \
--with-system-group=pulse \
--with-access-group=audio \
--with-bash-completion-dir=$BASHCOMPLETIONDIR \
--build=$ARCH-slackware-linux
make check
make -j1
make install-strip DESTDIR=$PKG
for f in $( find $PKG/etc/pulse/ -type f ) ; do mv $f $f.new ; done
mkdir -p $PKG/etc/rc.d
cp $CWD/rc.pulseaudio $PKG/etc/rc.d/rc.pulseaudio.new
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *GPL LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -1,10 +0,0 @@
PRGNAM="pulseaudio"
VERSION="7.0"
HOMEPAGE="http://www.pulseaudio.org"
DOWNLOAD="http://freedesktop.org/software/pulseaudio/releases/pulseaudio-7.0.tar.xz"
MD5SUM="09668b660ffb32f2639cfd6fdc9d3b37"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="json-c speex"
MAINTAINER="Christoph Willing"
EMAIL="chris.willing@linux.com"

View File

@ -1,43 +0,0 @@
#!/bin/sh
start()
{
if /usr/bin/sudo -u pulse /usr/bin/pulseaudio --check; then
echo "pulseaudio is running."
else
echo "Starting pulseaudio..."
/usr/bin/sudo -u pulse /usr/bin/pulseaudio --start --use-pid-file=yes
fi
}
stop()
{
if /usr/bin/sudo -u pulse /usr/bin/pulseaudio --check; then
printf "Stopping pulseaudio..."
/usr/bin/sudo -u pulse /usr/bin/pulseaudio --kill
while /usr/bin/sudo -u pulse /usr/bin/pulseaudio --check; do
printf "."
sleep 1
done
echo "Done"
else
echo "pulseaudio is not running."
fi
}
status()
{
if /usr/bin/sudo -u pulse /usr/bin/pulseaudio --check; then
echo "pulseaudio is running."
else
echo "pulseaudio is not running."
fi
}
case "$1" in
'start')start;;
'stop')stop;;
'restart')stop;start;;
'status')status;;
*)echo "$0 start|stop|restart|status"
esac

View File

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
pulseaudio: pulseaudio (PulseAudio Sound Server)
pulseaudio:
pulseaudio: pulseaudio is a networked sound server for Linux and other
pulseaudio: Unix like operating systems and Microsoft Windows. It is
pulseaudio: intended to be an improved drop-in replacement for the
pulseaudio: Enlightened Sound Daemon (ESOUND).
pulseaudio:
pulseaudio: Website : http://www.pulseaudio.org
pulseaudio:
pulseaudio:
pulseaudio: