system/isomd5sum: Updated for version 1.1.0, add Python 3 support.

This commit is contained in:
B. Watson 2016-08-03 01:37:03 -04:00 committed by Willy Sudiarto Raharjo
parent 56ecb23094
commit 88ce2ba0cb
No known key found for this signature in database
GPG Key ID: 887B8374D7333381
4 changed files with 27 additions and 31 deletions

View File

@ -4,5 +4,6 @@ iso given nothing more than the iso itself.
A checksum is implanted in an image using the implantisomd5 utility,
and the corresponding checkisomd5 utility can be used to verify burned
CDs are error-free. Also included is a Python extension for performing
these tasks.
CDs are error-free. Also included is a Python 2 extension for performing
these tasks. If Python 3 is installed, a Python 3 extension will also
be included.

View File

@ -1,19 +0,0 @@
diff -Naur isomd5sum-1.0.7/Makefile isomd5sum-1.0.7.patched//Makefile
--- isomd5sum-1.0.7/Makefile 2011-04-08 04:43:01.000000000 -0400
+++ isomd5sum-1.0.7.patched//Makefile 2011-07-15 01:43:55.000000000 -0400
@@ -29,9 +29,13 @@
checkisomd5: checkisomd5.o libcheckisomd5.a
$(CC) -lpopt $(CFLAGS) checkisomd5.o libcheckisomd5.a -o checkisomd5
-libimplantisomd5.a: libimplantisomd5.a(libimplantisomd5.o md5.o)
+libimplantisomd5.a: libimplantisomd5.o md5.o
+ ar rc libimplantisomd5.a libimplantisomd5.o md5.o
+ ranlib libimplantisomd5.a
-libcheckisomd5.a: libcheckisomd5.a(libcheckisomd5.o md5.o)
+libcheckisomd5.a: libcheckisomd5.o md5.o
+ ar rc libcheckisomd5.a libcheckisomd5.o md5.o
+ ranlib libcheckisomd5.a
pyisomd5sum.so: $(PYOBJS)
$(CC) -shared -g -o pyisomd5sum.so -fpic $(PYOBJS) $(LDFLAGS)

View File

@ -9,7 +9,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=isomd5sum
VERSION=${VERSION:-1.0.12}
VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -45,7 +45,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@ -54,13 +54,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/fix_makefile.diff
sed -i 's,/usr/share/man,/usr/man,' Makefile
sed -i -e 's/-Werror/ /' Makefile
make RPM_OPT_FLAGS="$SLKCFLAGS"
make install DESTDIR=$PKG
# Build & install binaries, libs, and python2 support:
make -j1 \
RPM_OPT_FLAGS="$SLKCFLAGS" \
PYTHON=python2 \
DESTDIR=$PKG \
all install
# If python3 is installed, build support for it.
# Slack's python 2.x package has a python2-config command, but SBo's
# python 3.x doesn't have python3-config (only e.g. python3.3-config).
# The readlink/which stuff avoids hard-coding 3.3 in this script:
if python3 --version >/dev/null 2>&1; then
make -j1 \
RPM_OPT_FLAGS="$SLKCFLAGS" \
PYTHON=$( readlink $( which python3 ) ) \
DESTDIR=$PKG \
clean all install-python
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

View File

@ -1,8 +1,8 @@
PRGNAM="isomd5sum"
VERSION="1.0.12"
HOMEPAGE="https://git.fedorahosted.org/git/isomd5sum.git"
DOWNLOAD="https://git.fedorahosted.org/cgit/isomd5sum.git/snapshot/isomd5sum-1.0.12.tar.gz"
MD5SUM="b96215095cb918e3900d0e586bd5f7ab"
VERSION="1.1.0"
HOMEPAGE="https://github.com/rhinstaller/isomd5sum/"
DOWNLOAD="https://github.com/rhinstaller/isomd5sum/archive/1.1.0.tar.gz"
MD5SUM="eac79ba8ecc16034339a8675a989833e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""