python/python3: Updated for version 3.5.1.

Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
This commit is contained in:
Audrius Kažukauskas 2015-12-14 22:27:59 +02:00 committed by Willy Sudiarto Raharjo
parent 6ae61baf66
commit 87c3ea0a1d
4 changed files with 37 additions and 40 deletions

View File

@ -1,7 +1,7 @@
diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
--- Python-3.5.0.orig/Makefile.pre.in 2015-09-13 14:41:23.000000000 +0300
+++ Python-3.5.0/Makefile.pre.in 2015-10-25 16:33:56.191130269 +0200
@@ -549,7 +549,7 @@
diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
--- Python-3.5.1.orig/Makefile.pre.in 2015-12-07 03:39:09.000000000 +0200
+++ Python-3.5.1/Makefile.pre.in 2015-12-14 21:25:22.103542432 +0200
@@ -564,7 +564,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@ -10,7 +10,7 @@ diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
@@ -584,18 +584,6 @@
@@ -599,18 +599,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@ -29,7 +29,7 @@ diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
@@ -685,7 +673,7 @@
@@ -700,7 +688,7 @@
echo "-----------------------------------------------"; \
fi
@ -38,7 +38,7 @@ diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
@@ -1357,18 +1345,6 @@
@@ -1372,18 +1360,6 @@
else true; \
fi; \
done

View File

@ -1,6 +1,6 @@
diff -uar Python-3.5.0.orig/Lib/distutils/command/install.py Python-3.5.0/Lib/distutils/command/install.py
--- Python-3.5.0.orig/Lib/distutils/command/install.py 2015-09-13 14:41:20.000000000 +0300
+++ Python-3.5.0/Lib/distutils/command/install.py 2015-10-25 16:59:00.429539487 +0200
diff -uar Python-3.5.1.orig/Lib/distutils/command/install.py Python-3.5.1/Lib/distutils/command/install.py
--- Python-3.5.1.orig/Lib/distutils/command/install.py 2015-12-07 03:39:07.000000000 +0200
+++ Python-3.5.1/Lib/distutils/command/install.py 2015-12-14 21:27:46.083400395 +0200
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@ -21,9 +21,9 @@ diff -uar Python-3.5.0.orig/Lib/distutils/command/install.py Python-3.5.0/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
diff -uar Python-3.5.0.orig/Lib/distutils/sysconfig.py Python-3.5.0/Lib/distutils/sysconfig.py
--- Python-3.5.0.orig/Lib/distutils/sysconfig.py 2015-09-13 14:41:21.000000000 +0300
+++ Python-3.5.0/Lib/distutils/sysconfig.py 2015-10-25 16:59:52.157272388 +0200
diff -uar Python-3.5.1.orig/Lib/distutils/sysconfig.py Python-3.5.1/Lib/distutils/sysconfig.py
--- Python-3.5.1.orig/Lib/distutils/sysconfig.py 2015-12-07 03:39:07.000000000 +0200
+++ Python-3.5.1/Lib/distutils/sysconfig.py 2015-12-14 21:27:46.083400395 +0200
@@ -133,7 +133,7 @@
if os.name == "posix":
@ -33,9 +33,9 @@ diff -uar Python-3.5.0.orig/Lib/distutils/sysconfig.py Python-3.5.0/Lib/distutil
if standard_lib:
return libpython
else:
diff -uar Python-3.5.0.orig/Lib/site.py Python-3.5.0/Lib/site.py
--- Python-3.5.0.orig/Lib/site.py 2015-09-13 14:41:21.000000000 +0300
+++ Python-3.5.0/Lib/site.py 2015-10-25 17:02:49.632218047 +0200
diff -uar Python-3.5.1.orig/Lib/site.py Python-3.5.1/Lib/site.py
--- Python-3.5.1.orig/Lib/site.py 2015-12-07 03:39:08.000000000 +0200
+++ Python-3.5.1/Lib/site.py 2015-12-14 21:27:46.083400395 +0200
@@ -303,7 +303,7 @@
seen.add(prefix)
@ -45,9 +45,9 @@ diff -uar Python-3.5.0.orig/Lib/site.py Python-3.5.0/Lib/site.py
"python" + sys.version[:3],
"site-packages"))
else:
diff -uar Python-3.5.0.orig/Lib/sysconfig.py Python-3.5.0/Lib/sysconfig.py
--- Python-3.5.0.orig/Lib/sysconfig.py 2015-09-13 14:41:21.000000000 +0300
+++ Python-3.5.0/Lib/sysconfig.py 2015-10-25 17:06:31.664656808 +0200
diff -uar Python-3.5.1.orig/Lib/sysconfig.py Python-3.5.1/Lib/sysconfig.py
--- Python-3.5.1.orig/Lib/sysconfig.py 2015-12-07 03:39:08.000000000 +0200
+++ Python-3.5.1/Lib/sysconfig.py 2015-12-14 21:27:46.084400429 +0200
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@ -93,10 +93,10 @@ diff -uar Python-3.5.0.orig/Lib/sysconfig.py Python-3.5.0/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
--- Python-3.5.0.orig/Makefile.pre.in 2015-09-13 14:41:23.000000000 +0300
+++ Python-3.5.0/Makefile.pre.in 2015-10-25 17:08:01.439664654 +0200
@@ -120,7 +120,7 @@
diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
--- Python-3.5.1.orig/Makefile.pre.in 2015-12-07 03:39:09.000000000 +0200
+++ Python-3.5.1/Makefile.pre.in 2015-12-14 21:27:46.084400429 +0200
@@ -125,7 +125,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@ -105,9 +105,9 @@ diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
diff -uar Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/Modules/getpath.c
--- Python-3.5.0.orig/Modules/getpath.c 2015-09-13 14:41:24.000000000 +0300
+++ Python-3.5.0/Modules/getpath.c 2015-10-25 17:10:58.101583759 +0200
diff -uar Python-3.5.1.orig/Modules/getpath.c Python-3.5.1/Modules/getpath.c
--- Python-3.5.1.orig/Modules/getpath.c 2015-12-07 03:39:10.000000000 +0200
+++ Python-3.5.1/Modules/getpath.c 2015-12-14 21:27:46.085400463 +0200
@@ -118,8 +118,8 @@
#endif
@ -146,10 +146,10 @@ diff -uar Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
diff -uar Python-3.5.0.orig/configure Python-3.5.0/configure
--- Python-3.5.0.orig/configure 2015-09-13 14:41:26.000000000 +0300
+++ Python-3.5.0/configure 2015-10-25 17:24:00.325783290 +0200
@@ -14384,7 +14384,7 @@
diff -uar Python-3.5.1.orig/configure Python-3.5.1/configure
--- Python-3.5.1.orig/configure 2015-12-07 03:39:11.000000000 +0200
+++ Python-3.5.1/configure 2015-12-14 21:27:46.089400598 +0200
@@ -14464,7 +14464,7 @@
$as_echo "$LDVERSION" >&6; }
@ -158,9 +158,9 @@ diff -uar Python-3.5.0.orig/configure Python-3.5.0/configure
# Check whether right shifting a negative integer extends the sign bit
diff -uar Python-3.5.0.orig/setup.py Python-3.5.0/setup.py
--- Python-3.5.0.orig/setup.py 2015-09-13 14:41:26.000000000 +0300
+++ Python-3.5.0/setup.py 2015-10-25 17:35:30.926901801 +0200
diff -uar Python-3.5.1.orig/setup.py Python-3.5.1/setup.py
--- Python-3.5.1.orig/setup.py 2015-12-07 03:39:11.000000000 +0200
+++ Python-3.5.1/setup.py 2015-12-14 21:27:46.090400632 +0200
@@ -469,7 +469,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.

View File

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3
VERSION=${VERSION:-3.5.0}
VERSION=${VERSION:-3.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -84,9 +84,6 @@ sed -i '1s|^#.*/usr/local/bin/python|#!/usr/bin/python3|' Lib/cgi.py
# install pip anyway.
sed -i 's|\("install",\)|\1 "--ignore-installed",|' Lib/ensurepip/__init__.py
# Fix the SO for --extension-suffix in python3-config.
sed -i 's|@SO@|@EXT_SUFFIX@|' Misc/python-config.sh.in
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \

View File

@ -1,8 +1,8 @@
PRGNAM="python3"
VERSION="3.5.0"
VERSION="3.5.1"
HOMEPAGE="https://www.python.org/"
DOWNLOAD="https://www.python.org/ftp/python/3.5.0/Python-3.5.0.tar.xz"
MD5SUM="d149d2812f10cbe04c042232e7964171"
DOWNLOAD="https://www.python.org/ftp/python/3.5.1/Python-3.5.1.tar.xz"
MD5SUM="e9ea6f2623fffcdd871b7b19113fde80"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""