network/netsurf: Updated for version 3.0.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Ruben Schuller 2013-10-27 00:27:57 -05:00 committed by Robby Workman
parent 060251d26d
commit 84e70a7704
7 changed files with 53 additions and 43 deletions

View File

@ -2,7 +2,3 @@ NetSurf is a free, open source web browser. It is written in C and released
under the GNU Public Licence version 2. NetSurf has its own layout and
rendering engine entirely written from scratch. It is small and capable of
handling many of the web standards in use today.
Building and additional dependencys:
If you want to change the build options you can do this in the ns-config
file. For webp support libwebp must be installed.

View File

@ -2,7 +2,7 @@
# Slackware build script for netsurf
# Copyright 2012 Ruben Schuller
# Copyright 2012, 2013 Ruben Schuller
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,14 +23,16 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netsurf
VERSION=${VERSION:-2.9}
VERSION=${VERSION:-3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@ -54,14 +56,14 @@ else
LIBDIRSUFFIX=""
fi
set -e
set -e # Exit on most errors
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-full-src.tar.gz
cd $PRGNAM-$VERSION
cd $PRGNAM-full-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -69,22 +71,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Apply the configuration
cat $CWD/ns-config > $PRGNAM-$VERSION/Makefile.config
# apply patches from git to compile with bison 2.7.1
# http://git.netsurf-browser.org/nsgenbind.git/patch/?id=51bd18034c510a6d4711823e08b69af2f7aa063e
patch -d src/nsgenbind-0.0.1/src < $CWD/nsgenbind-lexer.l.patch
patch -d src/nsgenbind-0.0.1/src < $CWD/webidl-lexer.l.patch
make TARGET=gtk
make install DESTDIR=$PKG PREFIX=/usr TARGET=gtk
cp -v -R -L $PRGNAM-$VERSION/gtk/res/* $PKG/usr/share/netsurf
make install DESTDIR=$PKG PREFIX=/usr
mkdir $PKG/usr/share/pixmaps
cp $PRGNAM-$VERSION/gtk/res/netsurf.xpm $PKG/usr/share/pixmaps
cp src/netsurf-3.0/gtk/res/netsurf.png $PKG/usr/share/pixmaps
cp src/netsurf-3.0/gtk/res/netsurf.xpm $PKG/usr/share/pixmaps
mkdir $PKG/usr/share/applications
mkdir -p $PKG/usr/share/applications
cp $CWD/netsurf.desktop $PKG/usr/share/applications
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/ns-config > $PKG/usr/doc/$PRGNAM-$VERSION/ns-config
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View File

@ -1,5 +1,4 @@
[Desktop Entry]
Encoding=UTF-8
Type=Application
Name=Netsurf
GenericName=Web Browser
@ -8,5 +7,5 @@ Exec=netsurf %U
Icon=netsurf
Terminal=false
StartupNotify=false
Categories=Application;Network;
Categories=Network;
MimeType=text/html;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/geo;

View File

@ -1,8 +1,8 @@
PRGNAM="netsurf"
VERSION="2.9"
VERSION="3.0"
HOMEPAGE="http://www.netsurf-browser.org"
DOWNLOAD="http://download.netsurf-browser.org/netsurf/releases/source-full/netsurf-2.9-full-src.tar.gz"
MD5SUM="cfc2789997b356f2ea9d9f7694c4c909"
DOWNLOAD="http://download.netsurf-browser.org/netsurf/releases/source-full/netsurf-3.0-full-src.tar.gz"
MD5SUM="51b13676d5f012409e0aefc6404938f6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View File

@ -1,21 +0,0 @@
# sane defaults
NETSURF_USE_BMP := YES
NETSURF_USE_GIF := YES
NETSURF_USE_JPEG := YES
NETSURF_USE_PNG := YES
NETSURF_USE_MNG := NO
# webp images, libwebp needed
NETSURF_USE_WEBP := NO
# video playback with gstreamer
NETSURF_USE_VIDEO := NO
# experimental javascript support, spidermonkey needed
NETSURF_USE_JS := NO
# pdf export and printing with haru
# http://libharu.org (unfortunately there is no SlackBuild for haru)
NETSURF_USE_HARU_PDF := NO
NETSURF_GTK_RESOURCES := /usr/share/netsurf/

View File

@ -0,0 +1,18 @@
index b257c83..8189a72 100644
--- a/src/nsgenbind-lexer.l
+++ b/src/nsgenbind-lexer.l
@@ -19,6 +19,16 @@
yylloc->first_column = yylloc->last_column + 1; \
yylloc->last_column += yyleng;
+
+/* Ensure compatability with bison 2.6 and later */
+#if ! defined YYSTYPE && ! defined YYSTYPE_IS_DECLARED && defined NSGENBIND_STYPE_IS_DECLARED
+#define YYSTYPE NSGENBIND_STYPE
+#endif
+
+#if ! defined YYLTYPE && ! defined YYLTYPE_IS_DECLARED && defined NSGENBIND_LTYPE_IS_DECLARED
+#define YYLTYPE NSGENBIND_LTYPE
+#endif
+
%}

View File

@ -0,0 +1,17 @@
index 5369d99..74b9bb8 100644
--- a/src/webidl-lexer.l
+++ b/src/webidl-lexer.l
@@ -27,6 +27,15 @@
yylloc->first_column = yylloc->last_column + 1; \
yylloc->last_column += yyleng;
+/* Ensure compatability with bison 2.6 and later */
+#if ! defined YYSTYPE && ! defined YYSTYPE_IS_DECLARED && defined WEBIDL_STYPE_IS_DECLARED
+#define YYSTYPE WEBIDL_STYPE
+#endif
+
+#if ! defined YYLTYPE && ! defined YYLTYPE_IS_DECLARED && defined WEBIDL_LTYPE_IS_DECLARED
+#define YYLTYPE WEBIDL_LTYPE
+#endif
+
%}