libraries/RxCpp: Updated for version 4.0.0.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Andre Barboza 2017-03-24 20:22:24 +07:00 committed by Willy Sudiarto Raharjo
parent bac8c0678e
commit 84dece812f
3 changed files with 9 additions and 11 deletions

View File

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=RxCpp
VERSION=${VERSION:-3.0.0}
VERSION=${VERSION:-4.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

View File

@ -1,8 +1,8 @@
PRGNAM="RxCpp"
VERSION="3.0.0"
VERSION="4.0.0"
HOMEPAGE="https://github.com/Reactive-Extensions/RxCpp"
DOWNLOAD="https://github.com/Reactive-Extensions/RxCpp/archive/v3.0.0/RxCpp-3.0.0.tar.gz"
MD5SUM="fe37d9e730ab98d5e7c1fb9edb6625cf"
DOWNLOAD="https://github.com/Reactive-Extensions/RxCpp/archive/v4.0.0/RxCpp-4.0.0.tar.gz"
MD5SUM="feb89934f465bb5ac513c9adce8d3b1b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View File

@ -1,6 +1,6 @@
diff -ur RxCpp-3.0.0.old/projects/CMake/CMakeLists.txt RxCpp-3.0.0/projects/CMake/CMakeLists.txt
--- RxCpp-3.0.0.old/projects/CMake/CMakeLists.txt 2016-11-25 17:51:43.000000000 -0200
+++ RxCpp-3.0.0/projects/CMake/CMakeLists.txt 2017-01-06 14:25:44.185727167 -0200
diff -ur RxCpp-4.0.0.old/projects/CMake/CMakeLists.txt RxCpp-4.0.0/projects/CMake/CMakeLists.txt
--- RxCpp-4.0.0.old/projects/CMake/CMakeLists.txt 2017-03-22 23:13:15.000000000 -0300
+++ RxCpp-4.0.0/projects/CMake/CMakeLists.txt 2017-03-23 20:16:59.520017863 -0300
@@ -11,18 +11,18 @@
MESSAGE( STATUS "RXCPP_DIR: " ${RXCPP_DIR} )
@ -28,13 +28,11 @@ diff -ur RxCpp-3.0.0.old/projects/CMake/CMakeLists.txt RxCpp-3.0.0/projects/CMak
# The list of RxCpp source files. Please add every new file to this list
set(RX_SOURCES
@@ -131,5 +131,6 @@
@@ -133,5 +133,6 @@
set(CMAKE_SKIP_INSTALL_ALL_DEPENDENCY TRUE CACHE BOOL "Don't require all projects to be built in order to install" FORCE)
-install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION rxcpp
- FILES_MATCHING PATTERN "*.hpp")
\ No newline at end of file
+install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION include/rxcpp
+ FILES_MATCHING PATTERN "*.hpp")
FILES_MATCHING PATTERN "*.hpp")
+install(TARGETS RxCpp DESTINATION lib${LIB_SUFFIX})