libraries/BTF: Updated for version 1.1.2.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
ed8022166c
commit
84058ff570
|
@ -4,7 +4,7 @@
|
|||
# Written by Kyle Guinn <elyk03@gmail.com>
|
||||
|
||||
PRGNAM=BTF
|
||||
VERSION=${VERSION:-1.1.1}
|
||||
VERSION=${VERSION:-1.1.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -37,6 +37,9 @@ else
|
|||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
# Recommended by SuiteSparse
|
||||
SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
|
@ -52,14 +55,16 @@ patch -p1 < $CWD/autotoolize.diff
|
|||
autoreconf -vif
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="BTF"
|
||||
VERSION="1.1.1"
|
||||
VERSION="1.1.2"
|
||||
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/btf/"
|
||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/btf/BTF-1.1.1.tar.gz"
|
||||
MD5SUM="dc7127df9d208ffd10cafcbbb343ab0c"
|
||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/btf/BTF-1.1.2.tar.gz"
|
||||
MD5SUM="5ec8a33199518eb30d0ef8ad4b589e9e"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Kyle Guinn"
|
||||
|
|
|
@ -1,17 +1,26 @@
|
|||
diff --git a/Include/Makefile.am b/Include/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Include/Makefile.am
|
||||
@@ -0,0 +1,2 @@
|
||||
+pkgincludedir = $(includedir)/btf
|
||||
+pkginclude_HEADERS = btf.h btf_internal.h
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,3 @@
|
||||
+SUBDIRS = Source
|
||||
@@ -0,0 +1,5 @@
|
||||
+SUBDIRS = Include Source
|
||||
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/lesser.txt
|
||||
+include_HEADERS = Include/btf.h Include/btf_internal.h
|
||||
+
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = btf.pc
|
||||
diff --git a/Source/Makefile.am b/Source/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Source/Makefile.am
|
||||
@@ -0,0 +1,18 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+
|
||||
+BTFSRC = \
|
||||
+ btf_maxtrans.c \
|
||||
|
@ -28,14 +37,30 @@ new file mode 100644
|
|||
+
|
||||
+libbtf_la_SOURCES =
|
||||
+libbtf_la_LIBADD = libbtfi.la libbtfl.la
|
||||
+libbtf_la_LDFLAGS = -no-undefined -version-info 2:1:1
|
||||
+libbtf_la_LDFLAGS = -no-undefined -version-info 2:2:1
|
||||
diff --git a/btf.pc.in b/btf.pc.in
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/btf.pc.in
|
||||
@@ -0,0 +1,11 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: @PACKAGE_NAME@
|
||||
+Description: Permutation to block triangular form
|
||||
+Version: @PACKAGE_VERSION@
|
||||
+Requires.private: ufconfig
|
||||
+Libs: -L${libdir} -lbtf
|
||||
+Cflags: -I${includedir}/btf
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/configure.ac
|
||||
@@ -0,0 +1,16 @@
|
||||
+AC_PREREQ([2.65])
|
||||
+AC_INIT([BTF], [1.1.1], [davis@cise.ufl.edu])
|
||||
@@ -0,0 +1,21 @@
|
||||
+AC_PREREQ([2.68])
|
||||
+AC_INIT([BTF],[1.1.2],[davis@cise.ufl.edu])
|
||||
+AC_CONFIG_SRCDIR([Source/btf_order.c])
|
||||
+AC_CONFIG_HEADER([config.h])
|
||||
+AM_INIT_AUTOMAKE([foreign])
|
||||
|
@ -44,9 +69,14 @@ new file mode 100644
|
|||
+AC_PROG_INSTALL
|
||||
+AC_PROG_CC
|
||||
+
|
||||
+AC_CHECK_HEADERS([UFconfig.h])
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find ufconfig])])
|
||||
+
|
||||
+AC_CONFIG_FILES([
|
||||
+ btf.pc
|
||||
+ Makefile
|
||||
+ Include/Makefile
|
||||
+ Source/Makefile])
|
||||
+AC_OUTPUT
|
||||
|
|
Loading…
Reference in New Issue