python/python3: Updated for version 3.2.2.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Audrius Kažukauskas 2011-09-21 22:44:36 -05:00 committed by Niels Horn
parent 210f874c36
commit 80dce55df2
3 changed files with 29 additions and 29 deletions

View File

@ -1,7 +1,7 @@
diff -uar Python-3.2.1.orig/Lib/distutils/command/install.py Python-3.2.1/Lib/distutils/command/install.py
--- Python-3.2.1.orig/Lib/distutils/command/install.py 2011-07-09 09:58:46.000000000 +0300
+++ Python-3.2.1/Lib/distutils/command/install.py 2011-07-11 13:24:36.929183098 +0300
@@ -46,15 +46,15 @@
diff -uar Python-3.2.2.orig/Lib/distutils/command/install.py Python-3.2.2/Lib/distutils/command/install.py
--- Python-3.2.2.orig/Lib/distutils/command/install.py 2011-09-03 19:16:40.000000000 +0300
+++ Python-3.2.2/Lib/distutils/command/install.py 2011-09-05 23:16:30.986061070 +0300
@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
'unix_prefix': {
@ -21,10 +21,10 @@ diff -uar Python-3.2.1.orig/Lib/distutils/command/install.py Python-3.2.1/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
diff -uar Python-3.2.1.orig/Lib/distutils/sysconfig.py Python-3.2.1/Lib/distutils/sysconfig.py
--- Python-3.2.1.orig/Lib/distutils/sysconfig.py 2011-07-09 09:58:47.000000000 +0300
+++ Python-3.2.1/Lib/distutils/sysconfig.py 2011-07-11 13:24:36.929183098 +0300
@@ -125,7 +125,7 @@
diff -uar Python-3.2.2.orig/Lib/distutils/sysconfig.py Python-3.2.2/Lib/distutils/sysconfig.py
--- Python-3.2.2.orig/Lib/distutils/sysconfig.py 2011-09-03 19:16:40.000000000 +0300
+++ Python-3.2.2/Lib/distutils/sysconfig.py 2011-09-05 23:16:30.986061070 +0300
@@ -123,7 +123,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@ -33,9 +33,9 @@ diff -uar Python-3.2.1.orig/Lib/distutils/sysconfig.py Python-3.2.1/Lib/distutil
if standard_lib:
return libpython
else:
diff -uar Python-3.2.1.orig/Lib/site.py Python-3.2.1/Lib/site.py
--- Python-3.2.1.orig/Lib/site.py 2011-07-09 09:58:49.000000000 +0300
+++ Python-3.2.1/Lib/site.py 2011-07-11 13:24:36.930183090 +0300
diff -uar Python-3.2.2.orig/Lib/site.py Python-3.2.2/Lib/site.py
--- Python-3.2.2.orig/Lib/site.py 2011-09-03 19:16:42.000000000 +0300
+++ Python-3.2.2/Lib/site.py 2011-09-05 23:16:30.986061070 +0300
@@ -285,13 +285,13 @@
if sys.platform in ('os2emx', 'riscos'):
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
@ -52,9 +52,9 @@ diff -uar Python-3.2.1.orig/Lib/site.py Python-3.2.1/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
diff -uar Python-3.2.1.orig/Lib/sysconfig.py Python-3.2.1/Lib/sysconfig.py
--- Python-3.2.1.orig/Lib/sysconfig.py 2011-07-09 09:58:49.000000000 +0300
+++ Python-3.2.1/Lib/sysconfig.py 2011-07-11 13:24:36.930183090 +0300
diff -uar Python-3.2.2.orig/Lib/sysconfig.py Python-3.2.2/Lib/sysconfig.py
--- Python-3.2.2.orig/Lib/sysconfig.py 2011-09-03 19:16:42.000000000 +0300
+++ Python-3.2.2/Lib/sysconfig.py 2011-09-05 23:16:30.994061003 +0300
@@ -21,10 +21,10 @@
_INSTALL_SCHEMES = {
@ -100,9 +100,9 @@ diff -uar Python-3.2.1.orig/Lib/sysconfig.py Python-3.2.1/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data' : '{userbase}',
diff -uar Python-3.2.1.orig/Makefile.pre.in Python-3.2.1/Makefile.pre.in
--- Python-3.2.1.orig/Makefile.pre.in 2011-07-09 09:58:52.000000000 +0300
+++ Python-3.2.1/Makefile.pre.in 2011-07-11 13:24:36.931183082 +0300
diff -uar Python-3.2.2.orig/Makefile.pre.in Python-3.2.2/Makefile.pre.in
--- Python-3.2.2.orig/Makefile.pre.in 2011-09-03 19:16:45.000000000 +0300
+++ Python-3.2.2/Makefile.pre.in 2011-09-05 23:16:30.994061003 +0300
@@ -106,7 +106,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@ -112,9 +112,9 @@ diff -uar Python-3.2.1.orig/Makefile.pre.in Python-3.2.1/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
diff -uar Python-3.2.1.orig/Modules/getpath.c Python-3.2.1/Modules/getpath.c
--- Python-3.2.1.orig/Modules/getpath.c 2011-07-09 09:58:54.000000000 +0300
+++ Python-3.2.1/Modules/getpath.c 2011-07-11 13:24:36.931183082 +0300
diff -uar Python-3.2.2.orig/Modules/getpath.c Python-3.2.2/Modules/getpath.c
--- Python-3.2.2.orig/Modules/getpath.c 2011-09-03 19:16:46.000000000 +0300
+++ Python-3.2.2/Modules/getpath.c 2011-09-05 23:16:30.995060994 +0300
@@ -122,8 +122,8 @@
#endif
@ -153,9 +153,9 @@ diff -uar Python-3.2.1.orig/Modules/getpath.c Python-3.2.1/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
diff -uar Python-3.2.1.orig/setup.py Python-3.2.1/setup.py
--- Python-3.2.1.orig/setup.py 2011-07-09 09:58:56.000000000 +0300
+++ Python-3.2.1/setup.py 2011-07-11 13:24:36.932183074 +0300
diff -uar Python-3.2.2.orig/setup.py Python-3.2.2/setup.py
--- Python-3.2.2.orig/setup.py 2011-09-03 19:16:50.000000000 +0300
+++ Python-3.2.2/setup.py 2011-09-05 23:16:30.995060994 +0300
@@ -396,7 +396,7 @@
# Ensure that /usr/local is always used, but the local build
# directories (i.e. '.' and 'Include') must be first. See issue

View File

@ -5,7 +5,7 @@
# Based on Patrick Volkerding's official build script for python
PRGNAM=python3
VERSION=${VERSION:-3.2.1}
VERSION=${VERSION:-3.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

View File

@ -1,10 +1,10 @@
PRGNAM="python3"
VERSION="3.2.1"
VERSION="3.2.2"
HOMEPAGE="http://python.org/"
DOWNLOAD="http://python.org/ftp/python/3.2.1/Python-3.2.1.tar.xz \
http://python.org/ftp/python/doc/3.2.1/python-3.2.1-docs-html.tar.bz2"
MD5SUM="2cf014296afc18897daa7b79414ad773 \
1d6c21614e6957040b9fe6cd93af13f2"
DOWNLOAD="http://python.org/ftp/python/3.2.2/Python-3.2.2.tar.xz \
http://python.org/ftp/python/doc/3.2.2/python-3.2.2-docs-html.tar.bz2"
MD5SUM="3720ce9460597e49264bbb63b48b946d \
55af06e320f35920ea9fed1f143e1286"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Audrius Kažukauskas"