graphics/ART: Updated for version 1.18.1.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
4a54f090de
commit
7e50990349
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for ART
|
||||
|
||||
# Copyright 2022 Daniel Prosser, Lexington Park, MD
|
||||
# Copyright 2023 Daniel Prosser, Lexington Park, MD
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,7 +25,7 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=ART
|
||||
VERSION=${VERSION:-1.17.2}
|
||||
VERSION=${VERSION:-1.18.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -76,6 +76,10 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# lensfun-0.3.95 segfaults with mimalloc. Version 0.3.3 solves the issue, but
|
||||
# we need to wait until Slackware-15.1 for that.
|
||||
patch -p0 < $CWD/disable_mimalloc.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="ART"
|
||||
VERSION="1.17.2"
|
||||
VERSION="1.18.1"
|
||||
HOMEPAGE="https://bitbucket.org/agriggio/art/wiki/Home"
|
||||
DOWNLOAD="https://bitbucket.org/agriggio/art/downloads/ART-1.17.2.tar.xz"
|
||||
MD5SUM="65d9d859a9bc113960827b6e83c88090"
|
||||
DOWNLOAD="https://bitbucket.org/agriggio/art/downloads/ART-1.18.1.tar.xz"
|
||||
MD5SUM="59040eb1a35639ec09404fe1085c77b2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- CMakeLists.txt 2023-01-16 02:54:14.000000000 -0500
|
||||
+++ CMakeLists.txt.new 2023-02-10 23:26:49.042916996 -0500
|
||||
@@ -606,8 +606,6 @@
|
||||
add_definitions(-DWITH_MIMALLOC)
|
||||
set(ART_MIMALLOC_VERSION_INFO "V${mimalloc_VERSION}")
|
||||
endif()
|
||||
-else()
|
||||
- message(FATAL_ERROR "ART requires the mimalloc library. Please install it (see https://microsoft.github.io/mimalloc/)")
|
||||
endif()
|
||||
|
||||
if(ENABLE_LIBRAW)
|
Loading…
Reference in New Issue