libraries/libkexiv2: Removed (this is part of kdegraphics)
Oops; my mistake. Thanks to Erik and others for cluebats. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
124f1a8e94
commit
7dca5bcde1
|
@ -1,6 +0,0 @@
|
|||
Libkexiv2 is a wrapper around Exiv2 library to manipulate picture metadata
|
||||
as EXIF/IPTC and XMP. This library is used by kipi-plugins, digiKam, and
|
||||
other kipi host programs.
|
||||
|
||||
This build script uses a svn snapshot that was downloaded and hosted by
|
||||
the script maintainer.
|
|
@ -1,102 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for libkexiv2
|
||||
|
||||
# Copyright 2010 by Giovanne Castro, Campinas, Sao Paulo, Brazil <giovannefc@ig.com.br>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=libkexiv2
|
||||
VERSION=${VERSION:-svn_20100824}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e # Exit on most errors
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Apply patch
|
||||
# What's the purpose? FIXME --rworkman
|
||||
patch < $CWD/libkexiv2cmake.diff
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
|
||||
-DMAN_INSTALL_DIR=/usr/man \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
AUTHORS COPYING ChangeLog NEWS README TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="libkexiv2"
|
||||
VERSION="svn_20100824"
|
||||
HOMEPAGE="http://www.kipi-plugins.org/"
|
||||
DOWNLOAD="http://www.ginoepri.com/linux/libkexiv2-svn_20100824.tar.gz"
|
||||
MD5SUM="c85f90fbb9b0eb1321e7c7eb0ae46af3"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Giovanne Castro"
|
||||
EMAIL="giovannefc@ig.com.br"
|
||||
APPROVED="rworkman"
|
|
@ -1,24 +0,0 @@
|
|||
Index: CMakeLists.txt
|
||||
===================================================================
|
||||
--- CMakeLists.txt (Revision 1117624)
|
||||
+++ CMakeLists.txt (Arbeitskopie)
|
||||
@@ -1,5 +1,20 @@
|
||||
PROJECT(libkexiv2)
|
||||
|
||||
+FIND_PACKAGE(KDE4 REQUIRED)
|
||||
+INCLUDE(KDE4Defaults)
|
||||
+INCLUDE(MacroLibrary)
|
||||
+INCLUDE(MacroOptionalAddSubdirectory)
|
||||
+INCLUDE(FindPackageHandleStandardArgs)
|
||||
+
|
||||
+ADD_DEFINITIONS (${QT_DEFINITIONS} ${QT_QTDBUS_DEFINITIONS} ${KDE4_DEFINITIONS})
|
||||
+INCLUDE_DIRECTORIES (${QDBUS_INCLUDE_DIRS} ${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${KDE4_INCLUDES})
|
||||
+
|
||||
+# Preview acess was added in Exiv2 0.18
|
||||
+# IMPORTANT : Several fixes done in 0.19. Set as default version when KDE 4.4 will be released
|
||||
+set(EXIV2_MIN_VERSION "0.18")
|
||||
+macro_optional_find_package(Exiv2)
|
||||
+macro_log_feature(EXIV2_FOUND "Exiv2" "A library to access image metadata" "http://www.exiv2.org" FALSE ${EXIV2_MIN_VERSION} "Required to build libkexiv2 and gwenview.")
|
||||
+
|
||||
# =======================================================
|
||||
# Information to update before to release this library.
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also customary
|
||||
# to leave one space after the ':'.
|
||||
|
||||
|----handy-ruler-----------------------------------------------------|
|
||||
libkexiv2: libkexiv2 (EXIV2 program interface for KDE)
|
||||
libkexiv2:
|
||||
libkexiv2: Libkexiv2 is a wrapper around Exiv2 library to manipulate picture
|
||||
libkexiv2: metadata as EXIF/IPTC and XMP.
|
||||
libkexiv2:
|
||||
libkexiv2: This library is used by kipi-plugins, digiKam, and other kipi host
|
||||
libkexiv2: programs.
|
||||
libkexiv2:
|
||||
libkexiv2:
|
||||
libkexiv2:
|
||||
libkexiv2:
|
Loading…
Reference in New Issue