network/xombrero: Fix icon.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Erik Falor 2014-04-19 15:13:54 +07:00 committed by Willy Sudiarto Raharjo
parent 26a3ef5de4
commit 7d45fef156
2 changed files with 12 additions and 51 deletions

View File

@ -1,36 +0,0 @@
--- Makefile 2013-07-11 11:05:15.000000000 -0600
+++ Makefile.new 2013-09-04 22:10:27.708971431 -0600
@@ -25,6 +25,7 @@
APPDIR?= $(PREFIX)/share/applications
MANDIR?= $(PREFIX)/share/man
RESDIR?= $(PREFIX)/share/xombrero
+ICODIR?= $(PREFIX)/share/icons/hicolor/apps
SRCS= $(shell ls ../*.c)
SRCS+= linux.c
@@ -63,15 +64,20 @@
install -m 755 -d $(DESTDIR)$(MANDIR)/man1
install -m 755 -d $(DESTDIR)$(RESDIR)
install -m 755 -d $(DESTDIR)$(APPDIR)
+ install -m 755 -d $(DESTDIR)$(ICODIR)/16x16
+ install -m 755 -d $(DESTDIR)$(ICODIR)/32x32
+ install -m 755 -d $(DESTDIR)$(ICODIR)/48x48
+ install -m 755 -d $(DESTDIR)$(ICODIR)/64x64
+ install -m 755 -d $(DESTDIR)$(ICODIR)/128x128
install -m 755 xombrero $(DESTDIR)$(BINDIR)
install -m 644 ../xombrero.1 $(DESTDIR)$(MANDIR)/man1/xombrero.1
install -m 644 ../xombrero.css $(DESTDIR)$(RESDIR)
install -m 644 ../xombrero.desktop $(DESTDIR)$(APPDIR)
- install -m 644 ../xombreroicon16.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon32.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon48.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon64.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon128.png $(DESTDIR)$(RESDIR)
+ install -m 644 ../xombreroicon16.png $(DESTDIR)$(ICODIR)/16x16
+ install -m 644 ../xombreroicon32.png $(DESTDIR)$(ICODIR)/32x32
+ install -m 644 ../xombreroicon48.png $(DESTDIR)$(ICODIR)/48x48
+ install -m 644 ../xombreroicon64.png $(DESTDIR)$(ICODIR)/64x64
+ install -m 644 ../xombreroicon128.png $(DESTDIR)$(ICODIR)/128x128
install -m 644 ../tld-rules $(DESTDIR)$(RESDIR)
install -m 644 ../style.css $(DESTDIR)$(RESDIR)
install -m 644 ../hsts-preload $(DESTDIR)$(RESDIR)

View File

@ -2,7 +2,7 @@
# Slackware build script for xombrero
# Copyright 2013 Erik Falor, Utah, USA
# Copyright 2014 Erik Falor, Utah, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -24,7 +24,7 @@
PRGNAM=xombrero
VERSION=${VERSION:-1.6.3}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -36,9 +36,9 @@ if [ -z "$ARCH" ]; then
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@ -64,20 +64,18 @@ tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch xombrero.h to not expect resources in /usr/local/share/xombrero
# https://opensource.conformal.com/flyspray/index.php?do=details&task_id=372
patch -i $CWD/xombrero.h.patch
# Hack Makefile so xombrero installs its icons and .desktop files in the right places
# https://opensource.conformal.com/flyspray/index.php?do=details&task_id=410
patch -d linux -i $CWD/Makefile.patch
sed -i 's|https://www.cyphertite.com|http://www.slackware.com|' xombrero.{c,conf,h}
sed -i 's|/etc/ssl/cert.pem|/etc/ssl/certs/ca-certificates.crt|' xombrero.conf
# Compile the application and install it into the $PKG directory
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
PREFIX=/usr \
@ -91,9 +89,8 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# Copy the .desktop file into usr/share/applications/,
# massaging its icon property to match our desktop theme
mkdir -p $PKG/usr/share/applications
mkdir -p $PKG/usr/share/pixmaps/
cp $PKG/usr/share/xombrero/xombreroicon64.png $PKG/usr/share/pixmaps/xombrero.png
sed -i -e s/xombreroicon64.png/xombrero/ $PKG/usr/share/applications/xombrero.desktop
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION