graphics/gmic: Updated for version 2.9.4.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2020-12-25 20:32:10 +01:00 committed by Robby Workman
parent ec7589e0c1
commit 7ca69c1e61
3 changed files with 11 additions and 75 deletions

View File

@ -21,8 +21,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gmic
VERSION=${VERSION:-2.7.5}
COMMUNITYVERSION=${COMMUNITYVERSION:-5a9aefc05e9585c1198c1d68f4b47ee32ff68ae2}
VERSION=${VERSION:-2.9.4}
COMMUNITYVERSION=${COMMUNITYVERSION:-6e9a20ef40e1db99c9b761853ad493ee7439e1b7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -46,7 +46,7 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O0 -march=i686 -mtune=i686 -fno-fast-math"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O3 -fPIC"
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O0 -fno-fast-math"
@ -78,16 +78,11 @@ sed -i -e "s|LIB = lib|LIB = lib$LIBDIRSUFFIX|g" \
-e "s|/etc/bash_completion.d|/usr/share/bash-completion/completions|g" \
-e "s|pkg-config opencv|pkg-config opencv4|" \
-e "s|qmake|qmake-qt5|g" \
src/Makefile
src/Makefile || exit 1
sed -i -e "s|-Ofast|-O2 -fno-fast-math --std=c++11|g" \
gmic-qt/gmic_qt.pro
gmic-qt/gmic_qt.pro || exit 1
# fix build with openCV 4.x
cd zart
patch -p1 -i $CWD/zart-opencv4.patch
cd -
make -C src cli lib libc WGET=/bin/true LIBS=${LDFLAGS} OPT_CFLAGS="$SLKCFLAGS " -j1
make -C src cli lib libc WGET=/bin/true LIBS=${LDFLAGS} OPT_CFLAGS="$SLKCFLAGS "
cd gmic-qt
qmake-qt5 GMIC_PATH=../src GMIC_DYNAMIC_LINKING=on HOST=none

View File

@ -1,10 +1,10 @@
PRGNAM="gmic"
VERSION="2.7.5"
VERSION="2.9.4"
HOMEPAGE="https://gmic.eu"
DOWNLOAD="https://gmic.eu/files/source/gmic_2.7.5.tar.gz \
https://github.com/dtschump/gmic-community/archive/5a9aefc05e9585c1198c1d68f4b47ee32ff68ae2.zip"
MD5SUM="d1c9baba2726b8ce8421804c91406a34 \
a54fa39b205e6dd712f42a2f3c1f45ae"
DOWNLOAD="https://gmic.eu/files/source/gmic_2.9.4.tar.gz \
https://github.com/dtschump/gmic-community/archive/6e9a20ef40e1db99c9b761853ad493ee7439e1b7.zip"
MD5SUM="e0d396ab6406c9baeb4929c1dd6a0d6a \
75f88fa1423f253714e84905a05f37da"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="qt5 opencv"

View File

@ -1,59 +0,0 @@
diff --git a/include/VideoFileSource.h b/include/VideoFileSource.h
index 0fda14e..8c15178 100644
--- a/include/VideoFileSource.h
+++ b/include/VideoFileSource.h
@@ -50,5 +50,7 @@
#include <QString>
#include <opencv2/opencv.hpp>
+#include <opencv2/videoio.hpp>
+#include <opencv2/videoio/videoio_c.h>
#include "ImageSource.h"
class VideoFileSource : public ImageSource {
diff --git a/include/WebcamSource.h b/include/WebcamSource.h
index 8c1911a..9194385 100644
--- a/include/WebcamSource.h
+++ b/include/WebcamSource.h
@@ -53,6 +53,8 @@
#include <QString>
#include <QVector>
#include <opencv2/opencv.hpp>
+#include <opencv2/videoio.hpp>
+#include <opencv2/videoio/videoio_c.h>
#include "ImageSource.h"
class QSplashScreen;
diff --git a/zart.pro b/zart.pro
index d98a192..ddb2d3b 100644
--- a/zart.pro
+++ b/zart.pro
@@ -19,7 +19,7 @@
CONFIG += warn_on
QT_CONFIG -= no-pkg-config
CONFIG += link_pkgconfig
-PKGCONFIG += opencv fftw3 zlib
+PKGCONFIG += opencv4 fftw3 zlib
# LIBS += -lfftw3_threads
DEFINES += cimg_use_fftw3 cimg_use_zlib
diff --git a/src/ImageConverter.cpp b/src/ImageConverter.cpp
--- a/src/ImageConverter.cpp
+++ b/src/ImageConverter.cpp
@@ -70,7 +70,7 @@
cv::Mat tmp(in->cols, in->rows, in->depth());
- cvtColor(*in, tmp, (in->channels() == 1) ? CV_GRAY2RGB : CV_BGR2RGB);
+ cvtColor(*in, tmp, (in->channels() == 1) ? cv::COLOR_GRAY2RGB : cv::COLOR_BGR2RGB);
const unsigned int w3 = 3 * tmp.cols;
unsigned char * src = reinterpret_cast<unsigned char *>(tmp.ptr());
@@ -106,7 +106,7 @@
dst += step;
}
}
- cvtColor(**out, **out, CV_BGR2RGB);
+ cvtColor(**out, **out, cv::COLOR_BGR2RGB);
}
void ImageConverter::convert(const cimg_library::CImg<float> & in, QImage * out)