gis/proj: Updated for version 9.0.1.

- remove mandir patch since it was merged upstream
- add TESTBUILD option to build and run tests (off by default)
- fix /usr/share/doc path in package (bug in CMake definitions)

Signed-off-by: ArTourter <artourter@gmail.com>
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
ArTourter 2022-06-17 11:25:52 +01:00 committed by Willy Sudiarto Raharjo
parent c3bf33755e
commit 79eac0f28f
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
4 changed files with 23 additions and 25 deletions

View File

@ -1,7 +1,10 @@
proj is a generic coordinate transformation software, that
transforms coordinates from one coordinate reference system (CRS) to
another. This includes cartographic projections as well as geodetic
transformations.
proj is a generic coordinate transformation software, that transforms
coordinates from one coordinate reference system (CRS) to another. This
includes cartographic projections as well as geodetic transformations.
For datum grids, install the proj-data package. Without this package,
proj can fetch required grids from the internet as needed.
By default, the script does not build nor run the tests. You can use the
option TESTBUILD=YES to build and run the tests before the make install
part.

View File

@ -1,9 +0,0 @@
diff -Naur proj-9.0.0/man/CMakeLists.txt proj-9.0.0-new/man/CMakeLists.txt
--- proj-9.0.0/man/CMakeLists.txt 2022-02-23 18:51:04.000000000 +0000
+++ proj-9.0.0-new/man/CMakeLists.txt 2022-03-02 16:22:14.979350892 +0000
@@ -6,4 +6,4 @@
man1/gie.1
man1/projinfo.1
man1/projsync.1
- DESTINATION share/man/man1)
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)

View File

@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=proj
VERSION=${VERSION:-9.0.0}
VERSION=${VERSION:-9.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -66,6 +66,10 @@ fi
set -e
if [[ ${TESTBUILD:='NO'} == 'NO' ]]; then
TESTBUILDFLAGS='-DBUILD_TESTING=OFF'
fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@ -79,8 +83,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/fix_mandir.patch
mkdir -p build
( cd build
cmake \
@ -88,22 +90,24 @@ mkdir -p build
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
-DCMAKE_INSTALL_MANDIR=/usr/man \
-DCMAKE_INSTALL_MANDIR=man \
-DCMAKE_INSTALL_DOCDIR=doc/$PRGNAM-$VERSION \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=off \
$TESTBUILDFLAGS \
..
make
[[ $TESTBUILD == "YES" ]] && make test
make install/strip DESTDIR=$PKG
)
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
mkdir $PKG/usr/doc
mv $PKG/usr/share/doc/proj $PKG/usr/doc/$PRGNAM-$VERSION
rm -rf $PKG/usr/share/doc
cp -a \
AUTHORS CITATION COPYING ChangeLog INSTALL NEWS README README.md\
AUTHORS CITATION COPYING ChangeLog NEWS README README.md\
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View File

@ -1,8 +1,8 @@
PRGNAM="proj"
VERSION="9.0.0"
VERSION="9.0.1"
HOMEPAGE="https://www.osgeo.org/projects/proj/"
DOWNLOAD="https://github.com/OSGeo/PROJ/releases/download/9.0.0/proj-9.0.0.tar.gz"
MD5SUM="180f9c60f74526690d059219fc7871e0"
DOWNLOAD="https://github.com/OSGeo/PROJ/releases/download/9.0.1/proj-9.0.1.tar.gz"
MD5SUM="d4eca355288bbfe35caaedbd595787dc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""