libraries/matplotlib: Updated for version 1.1.0.

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
Serban Udrea 2011-11-04 21:35:48 -02:00 committed by Niels Horn
parent 5a4f77a6c2
commit 79254b4b6f
4 changed files with 11 additions and 24 deletions

View File

@ -1,12 +0,0 @@
diff -Naur matplotlib-0.99.1.1-orig/src/_png.cpp matplotlib-0.99.1.1/src/_png.cpp
--- matplotlib-0.99.1.1-orig/src/_png.cpp 2010-01-25 01:42:32.000000000 -0500
+++ matplotlib-0.99.1.1/src/_png.cpp 2010-01-25 01:43:17.000000000 -0500
@@ -290,7 +290,7 @@
//free the png memory
png_read_end(png_ptr, info_ptr);
- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
fclose(fp);
for (row = 0; row < height; row++)
delete [] row_pointers[row];

View File

@ -5,20 +5,19 @@
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
# Patch for libpng borrowed from Arch Linux
# Updated for version 1.1.0 by Serban Udrea <S.Udrea@gsi.de>
PRGNAM=matplotlib
VERSION=${VERSION:-0.99.1.2}
VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
TARBALL_VERSION=0.99.1.1 # Tarball dir has wrong version number
TARBALL_VERSION=1.1.0 # Tarball sometimes has a wrong version number
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@ -43,7 +42,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
patch -p1 < $CWD/libpng-1.4.patch
# patch -p1 < $CWD/libpng-1.4.patch # Does not seem to be needed anymore
# Use setup.cfg to tell setup.py not to install pytz and dateutil
mv setup.cfg.template setup.cfg
@ -57,7 +56,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS README.txt TODO \
CHANGELOG INSTALL README.txt TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View File

@ -1,10 +1,10 @@
PRGNAM="matplotlib"
VERSION="0.99.1.2"
VERSION="1.1.0"
HOMEPAGE="http://matplotlib.sourceforge.net/"
DOWNLOAD="http://downloads.sourceforge.net/matplotlib/matplotlib-0.99.1.2.tar.gz"
MD5SUM="952e2c992e4a762b8538171f51c9140a"
DOWNLOAD="http://kent.dl.sourceforge.net/project/matplotlib/matplotlib/matplotlib-1.1.0/matplotlib-1.1.0.tar.gz"
MD5SUM="57a627f30b3b27821f808659889514c2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Serban Udrea"
EMAIL="S.Udrea@gsi.de"
APPROVED="pprkut"
APPROVED="pprkut,Niels Horn"

View File

@ -5,14 +5,14 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler--------------------------------------------------|
|-----handy-ruler------------------------------------------------------|
matplotlib: matplotlib (a Python 2D plotting library)
matplotlib:
matplotlib: Matplotlib is a plotting library for Python which uses
matplotlib: syntax similar to MATLAB. Matplotlib produces publication
matplotlib: quality figures in a variety of hardcopy formats and
matplotlib: interactive environments across platforms.
matplotlib:
matplotlib:
matplotlib: Homepage: http://matplotlib.sourceforge.net/
matplotlib:
matplotlib: