academic/cblas: Updated for version 3.9.1.
Signed-off-by: Kyle Guinn <elyk03@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ceb3f5693a
commit
781938c9ee
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for CBLAS
|
||||
|
||||
# Copyright 2016-2020 Kyle Guinn <elyk03@gmail.com>
|
||||
# Copyright 2016-2021 Kyle Guinn <elyk03@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=cblas
|
||||
SRCNAM=lapack
|
||||
VERSION=${VERSION:-3.9.0}
|
||||
VERSION=${VERSION:-3.9.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="cblas"
|
||||
VERSION="3.9.0"
|
||||
VERSION="3.9.1"
|
||||
HOMEPAGE="https://www.netlib.org/blas/"
|
||||
DOWNLOAD="https://github.com/Reference-LAPACK/lapack/archive/v3.9.0/lapack-3.9.0.tar.gz"
|
||||
MD5SUM="0b251e2a8d5f949f99b50dd5e2200ee2"
|
||||
DOWNLOAD="https://github.com/Reference-LAPACK/lapack/archive/v3.9.1/lapack-3.9.1.tar.gz"
|
||||
MD5SUM="47ab2d11652045145df37ddbe2a32d71"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="blas"
|
||||
|
|
|
@ -5,25 +5,25 @@ diff --git a/CBLAS/CMakeLists.txt b/CBLAS/CMakeLists.txt
|
|||
message(STATUS "CBLAS enable")
|
||||
enable_language(C)
|
||||
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME cblas-targets)
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME ${CBLASLIB}-targets)
|
||||
-
|
||||
# Create a header file cblas.h for the routines called in my C programs
|
||||
include(FortranCInterface)
|
||||
## Ensure that the fortran compiler and c compiler specified are compatible
|
||||
@@ -41,54 +39,8 @@
|
||||
@@ -45,54 +43,8 @@
|
||||
add_subdirectory(examples)
|
||||
endif()
|
||||
|
||||
-if(NOT BLAS_FOUND)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} blas)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} ${BLASLIB})
|
||||
-endif()
|
||||
-
|
||||
-# Export cblas targets from the
|
||||
-# install tree, if any.
|
||||
-set(_cblas_config_install_guard_target "")
|
||||
-if(ALL_TARGETS)
|
||||
- install(EXPORT cblas-targets
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/cblas-${LAPACK_VERSION}
|
||||
- install(EXPORT ${CBLASLIB}-targets
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${CBLASLIB}-${LAPACK_VERSION}
|
||||
- COMPONENT Development
|
||||
- )
|
||||
- # Choose one of the cblas targets to use as a guard for
|
||||
|
@ -34,7 +34,7 @@ diff --git a/CBLAS/CMakeLists.txt b/CBLAS/CMakeLists.txt
|
|||
-# Export cblas targets from the build tree, if any.
|
||||
-set(_cblas_config_build_guard_target "")
|
||||
-if(ALL_TARGETS)
|
||||
- export(TARGETS ${ALL_TARGETS} FILE cblas-targets.cmake)
|
||||
- export(TARGETS ${ALL_TARGETS} FILE ${CBLASLIB}-targets.cmake)
|
||||
-
|
||||
- # Choose one of the cblas targets to use as a guard
|
||||
- # for cblas-config.cmake to load targets from the build tree.
|
||||
|
@ -42,27 +42,27 @@ diff --git a/CBLAS/CMakeLists.txt b/CBLAS/CMakeLists.txt
|
|||
-endif()
|
||||
-
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/cblas-config-version.cmake.in
|
||||
- ${LAPACK_BINARY_DIR}/cblas-config-version.cmake @ONLY)
|
||||
- ${LAPACK_BINARY_DIR}/${CBLASLIB}-config-version.cmake @ONLY)
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/cblas-config-build.cmake.in
|
||||
- ${LAPACK_BINARY_DIR}/cblas-config.cmake @ONLY)
|
||||
- ${LAPACK_BINARY_DIR}/${CBLASLIB}-config.cmake @ONLY)
|
||||
-
|
||||
-
|
||||
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cblas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/cblas.pc @ONLY)
|
||||
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cblas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${CBLASLIB}.pc @ONLY)
|
||||
install(FILES
|
||||
${CMAKE_CURRENT_BINARY_DIR}/cblas.pc
|
||||
${CMAKE_CURRENT_BINARY_DIR}/${CBLASLIB}.pc
|
||||
DESTINATION ${PKG_CONFIG_DIR}
|
||||
)
|
||||
-
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/cblas-config-install.cmake.in
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/cblas-config.cmake @ONLY)
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/${CBLASLIB}-config.cmake @ONLY)
|
||||
-install(FILES
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/cblas-config.cmake
|
||||
- ${LAPACK_BINARY_DIR}/cblas-config-version.cmake
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/cblas-${LAPACK_VERSION}
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/${CBLASLIB}-config.cmake
|
||||
- ${LAPACK_BINARY_DIR}/${CBLASLIB}-config-version.cmake
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${CBLASLIB}-${LAPACK_VERSION}
|
||||
- )
|
||||
-
|
||||
-#install(EXPORT cblas-targets
|
||||
-# DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/cblas-${LAPACK_VERSION}
|
||||
-#install(EXPORT ${CBLASLIB}-targets
|
||||
-# DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${CBLASLIB}-${LAPACK_VERSION}
|
||||
-# COMPONENT Development
|
||||
-# )
|
||||
diff --git a/CBLAS/cmake/cblas-config-build.cmake.in b/CBLAS/cmake/cblas-config-build.cmake.in
|
||||
|
@ -76,14 +76,14 @@ deleted file mode 100644
|
|||
-
|
||||
-# Load lapack targets from the build tree, including lapacke targets.
|
||||
-if(NOT TARGET lapacke)
|
||||
- include("@LAPACK_BINARY_DIR@/lapack-targets.cmake")
|
||||
- include("@LAPACK_BINARY_DIR@/@LAPACKLIB@-targets.cmake")
|
||||
-endif()
|
||||
-
|
||||
-# Report cblas header search locations from build tree.
|
||||
-set(CBLAS_INCLUDE_DIRS "@LAPACK_BINARY_DIR@/include")
|
||||
-
|
||||
-# Report cblas libraries.
|
||||
-set(CBLAS_LIBRARIES cblas)
|
||||
-set(CBLAS_LIBRARIES @CBLASLIB@)
|
||||
diff --git a/CBLAS/cmake/cblas-config-install.cmake.in b/CBLAS/cmake/cblas-config-install.cmake.in
|
||||
deleted file mode 100644
|
||||
--- a/CBLAS/cmake/cblas-config-install.cmake.in
|
||||
|
@ -96,19 +96,19 @@ deleted file mode 100644
|
|||
-get_filename_component(_CBLAS_PREFIX "${_CBLAS_PREFIX}" PATH)
|
||||
-
|
||||
-# Load the LAPACK package with which we were built.
|
||||
-set(LAPACK_DIR "${_CBLAS_PREFIX}/@CMAKE_INSTALL_LIBDIR@/cmake/lapack-@LAPACK_VERSION@")
|
||||
-set(LAPACK_DIR "${_CBLAS_PREFIX}/@CMAKE_INSTALL_LIBDIR@/cmake/@LAPACKLIB@-@LAPACK_VERSION@")
|
||||
-find_package(LAPACK NO_MODULE)
|
||||
-
|
||||
-# Load lapacke targets from the install tree.
|
||||
-if(NOT TARGET cblas)
|
||||
- include(${_CBLAS_SELF_DIR}/cblas-targets.cmake)
|
||||
-if(NOT TARGET @CBLASLIB@)
|
||||
- include(${_CBLAS_SELF_DIR}/@CBLASLIB@-targets.cmake)
|
||||
-endif()
|
||||
-
|
||||
-# Report lapacke header search locations.
|
||||
-set(CBLAS_INCLUDE_DIRS ${_CBLAS_PREFIX}/include)
|
||||
-
|
||||
-# Report lapacke libraries.
|
||||
-set(CBLAS_LIBRARIES cblas)
|
||||
-set(CBLAS_LIBRARIES @CBLASLIB@)
|
||||
-
|
||||
-unset(_CBLAS_PREFIX)
|
||||
-unset(_CBLAS_SELF_DIR)
|
||||
|
@ -128,16 +128,16 @@ deleted file mode 100644
|
|||
diff --git a/CBLAS/src/CMakeLists.txt b/CBLAS/src/CMakeLists.txt
|
||||
--- a/CBLAS/src/CMakeLists.txt
|
||||
+++ b/CBLAS/src/CMakeLists.txt
|
||||
@@ -120,9 +120,5 @@
|
||||
VERSION ${LAPACK_VERSION}
|
||||
SOVERSION ${LAPACK_MAJOR_VERSION}
|
||||
)
|
||||
-target_include_directories(cblas PUBLIC
|
||||
@@ -123,9 +123,5 @@
|
||||
if(HAS_ATTRIBUTE_WEAK_SUPPORT)
|
||||
target_compile_definitions(${CBLASLIB} PRIVATE HAS_ATTRIBUTE_WEAK_SUPPORT)
|
||||
endif()
|
||||
-target_include_directories(${CBLASLIB} PUBLIC
|
||||
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/../include>
|
||||
- $<INSTALL_INTERFACE:include>
|
||||
-)
|
||||
target_link_libraries(cblas PRIVATE ${BLAS_LIBRARIES})
|
||||
lapack_install_library(cblas)
|
||||
target_link_libraries(${CBLASLIB} PRIVATE ${BLAS_LIBRARIES})
|
||||
lapack_install_library(${CBLASLIB})
|
||||
diff --git a/CMAKE/lapack-config-build.cmake.in b/CMAKE/lapack-config-build.cmake.in
|
||||
deleted file mode 100644
|
||||
--- a/CMAKE/lapack-config-build.cmake.in
|
||||
|
@ -146,7 +146,7 @@ deleted file mode 100644
|
|||
-# Load lapack targets from the build tree if necessary.
|
||||
-set(_LAPACK_TARGET "@_lapack_config_build_guard_target@")
|
||||
-if(_LAPACK_TARGET AND NOT TARGET "${_LAPACK_TARGET}")
|
||||
- include("@LAPACK_BINARY_DIR@/lapack-targets.cmake")
|
||||
- include("@LAPACK_BINARY_DIR@/@LAPACKLIB@-targets.cmake")
|
||||
-endif()
|
||||
-unset(_LAPACK_TARGET)
|
||||
-
|
||||
|
@ -168,7 +168,7 @@ deleted file mode 100644
|
|||
-# Load lapack targets from the install tree if necessary.
|
||||
-set(_LAPACK_TARGET "@_lapack_config_install_guard_target@")
|
||||
-if(_LAPACK_TARGET AND NOT TARGET "${_LAPACK_TARGET}")
|
||||
- include("${_LAPACK_SELF_DIR}/lapack-targets.cmake")
|
||||
- include("${_LAPACK_SELF_DIR}/@LAPACKLIB@-targets.cmake")
|
||||
-endif()
|
||||
-unset(_LAPACK_TARGET)
|
||||
-
|
||||
|
@ -184,11 +184,11 @@ deleted file mode 100644
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -112,11 +112,8 @@
|
||||
@@ -160,11 +160,8 @@
|
||||
|
||||
|
||||
# --------------------------------------------------
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME lapack-targets)
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME ${LAPACKLIB}-targets)
|
||||
-
|
||||
macro(lapack_install_library lib)
|
||||
install(TARGETS ${lib}
|
||||
|
@ -196,7 +196,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Development
|
||||
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries
|
||||
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT RuntimeLibraries
|
||||
@@ -155,21 +152,6 @@
|
||||
@@ -204,21 +201,6 @@
|
||||
include(CheckLAPACKCompilerFlags)
|
||||
CheckLAPACKCompilerFlags()
|
||||
|
||||
|
@ -204,7 +204,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
-# Check second function
|
||||
-
|
||||
-include(CheckTimeFunction)
|
||||
-set(TIME_FUNC NONE ${TIME_FUNC})
|
||||
-set(NONE ${TIME_FUNC})
|
||||
-CHECK_TIME_FUNCTION(NONE TIME_FUNC)
|
||||
-CHECK_TIME_FUNCTION(INT_CPU_TIME TIME_FUNC)
|
||||
-CHECK_TIME_FUNCTION(EXT_ETIME TIME_FUNC)
|
||||
|
@ -218,7 +218,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
# deprecated LAPACK and LAPACKE routines
|
||||
option(BUILD_DEPRECATED "Build deprecated routines" OFF)
|
||||
message(STATUS "Build deprecated routines: ${BUILD_DEPRECATED}")
|
||||
@@ -193,8 +175,9 @@
|
||||
@@ -242,8 +224,9 @@
|
||||
endif()
|
||||
|
||||
# --------------------------------------------------
|
||||
|
@ -229,7 +229,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
|
||||
# Check the usage of the user provided BLAS libraries
|
||||
if(BLAS_LIBRARIES)
|
||||
@@ -205,113 +188,108 @@
|
||||
@@ -254,113 +237,108 @@
|
||||
if(BLAS_FOUND)
|
||||
message(STATUS "--> BLAS supplied by user is WORKING, will use ${BLAS_LIBRARIES}.")
|
||||
else()
|
||||
|
@ -250,7 +250,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
- message(STATUS "Using supplied NETLIB BLAS implementation")
|
||||
- add_subdirectory(BLAS)
|
||||
+elseif(BUILD_BLAS)
|
||||
set(BLAS_LIBRARIES blas)
|
||||
set(BLAS_LIBRARIES ${BLASLIB})
|
||||
-else()
|
||||
- set(CMAKE_EXE_LINKER_FLAGS
|
||||
- "${CMAKE_EXE_LINKER_FLAGS} ${BLAS_LINKER_FLAGS}"
|
||||
|
@ -326,14 +326,14 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
+ find_package(LAPACK)
|
||||
+
|
||||
+elseif(BUILD_LAPACK)
|
||||
set(LAPACK_LIBRARIES lapack)
|
||||
set(LAPACK_LIBRARIES ${LAPACKLIB})
|
||||
+ set(LAPACK_FOUND TRUE)
|
||||
+
|
||||
+ set(NEED_BLAS TRUE)
|
||||
+
|
||||
+ # Check second function
|
||||
+ include(CheckTimeFunction)
|
||||
+ set(TIME_FUNC NONE ${TIME_FUNC})
|
||||
+ set(NONE ${TIME_FUNC})
|
||||
+ CHECK_TIME_FUNCTION(NONE TIME_FUNC)
|
||||
+ CHECK_TIME_FUNCTION(INT_CPU_TIME TIME_FUNC)
|
||||
+ CHECK_TIME_FUNCTION(EXT_ETIME TIME_FUNC)
|
||||
|
@ -363,9 +363,9 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
+ add_subdirectory(TESTING)
|
||||
+ endif()
|
||||
+
|
||||
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc @ONLY)
|
||||
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${LAPACKLIB}.pc @ONLY)
|
||||
+ install(FILES
|
||||
+ ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc
|
||||
+ ${CMAKE_CURRENT_BINARY_DIR}/${LAPACKLIB}.pc
|
||||
+ DESTINATION ${PKG_CONFIG_DIR}
|
||||
+ COMPONENT Development
|
||||
+ )
|
||||
|
@ -393,8 +393,8 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
add_subdirectory(LAPACKE)
|
||||
endif()
|
||||
|
||||
@@ -338,109 +316,12 @@
|
||||
_display_cpp_implementation_msg("LAPACK")
|
||||
@@ -414,111 +392,16 @@
|
||||
ExternalProject_Add_StepDependencies(lapackpp build blaspp ${BLAS_LIBRARIES} ${LAPACK_LIBRARIES})
|
||||
endif()
|
||||
|
||||
-# --------------------------------------------------
|
||||
|
@ -430,23 +430,23 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
-# --------------------------------------------------
|
||||
-
|
||||
-if(NOT BLAS_FOUND)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} blas)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} ${BLASLIB})
|
||||
-endif()
|
||||
-
|
||||
-if(NOT LATESTLAPACK_FOUND)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} lapack)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} ${LAPACKLIB})
|
||||
-endif()
|
||||
-
|
||||
-if(BUILD_TESTING OR LAPACKE_WITH_TMG)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} tmglib)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} ${TMGLIB})
|
||||
-endif()
|
||||
-
|
||||
-# Export lapack targets, not including lapacke, from the
|
||||
-# install tree, if any.
|
||||
-set(_lapack_config_install_guard_target "")
|
||||
-if(ALL_TARGETS)
|
||||
- install(EXPORT lapack-targets
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/lapack-${LAPACK_VERSION}
|
||||
- install(EXPORT ${LAPACKLIB}-targets
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${LAPACKLIB}-${LAPACK_VERSION}
|
||||
- COMPONENT Development
|
||||
- )
|
||||
-
|
||||
|
@ -457,12 +457,12 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
-
|
||||
-# Include cblas in targets exported from the build tree.
|
||||
-if(CBLAS)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} cblas)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} ${CBLASLIB})
|
||||
-endif()
|
||||
-
|
||||
-# Include lapacke in targets exported from the build tree.
|
||||
-if(LAPACKE)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} lapacke)
|
||||
- set(ALL_TARGETS ${ALL_TARGETS} ${LAPACKELIB})
|
||||
+# Neither user specified or optimized BLAS libraries can be used
|
||||
+if(NEED_BLAS AND NOT BLAS_FOUND)
|
||||
+ message(FATAL_ERROR "--> No BLAS library found. Specify BLAS_LIBRARIES or enable USE_OPTIMIZED_BLAS or BUILD_BLAS.")
|
||||
|
@ -471,7 +471,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
-# Export lapack and lapacke targets from the build tree, if any.
|
||||
-set(_lapack_config_build_guard_target "")
|
||||
-if(ALL_TARGETS)
|
||||
- export(TARGETS ${ALL_TARGETS} FILE lapack-targets.cmake)
|
||||
- export(TARGETS ${ALL_TARGETS} FILE ${LAPACKLIB}-targets.cmake)
|
||||
-
|
||||
- # Choose one of the lapack or lapacke targets to use as a guard
|
||||
- # for lapack-config.cmake to load targets from the build tree.
|
||||
|
@ -480,36 +480,37 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|||
+if(NEED_LAPACK AND NOT LAPACK_FOUND)
|
||||
+ message(FATAL_ERROR "--> No LAPACK library found. Specify LAPACK_LIBRARIES or enable USE_OPTIMIZED_LAPACK or BUILD_LAPACK.")
|
||||
endif()
|
||||
-
|
||||
|
||||
-configure_file(${LAPACK_SOURCE_DIR}/CMAKE/lapack-config-build.cmake.in
|
||||
- ${LAPACK_BINARY_DIR}/lapack-config.cmake @ONLY)
|
||||
- ${LAPACK_BINARY_DIR}/${LAPACKLIB}-config.cmake @ONLY)
|
||||
-
|
||||
-
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc @ONLY)
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${LAPACKLIB}.pc @ONLY)
|
||||
- install(FILES
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/${LAPACKLIB}.pc
|
||||
- DESTINATION ${PKG_CONFIG_DIR}
|
||||
- COMPONENT Development
|
||||
- )
|
||||
-
|
||||
-configure_file(${LAPACK_SOURCE_DIR}/CMAKE/lapack-config-install.cmake.in
|
||||
- ${LAPACK_BINARY_DIR}/CMakeFiles/lapack-config.cmake @ONLY)
|
||||
- ${LAPACK_BINARY_DIR}/CMakeFiles/${LAPACKLIB}-config.cmake @ONLY)
|
||||
-
|
||||
-include(CMakePackageConfigHelpers)
|
||||
-write_basic_package_version_file(
|
||||
- ${LAPACK_BINARY_DIR}/lapack-config-version.cmake
|
||||
- ${LAPACK_BINARY_DIR}/${LAPACKLIB}-config-version.cmake
|
||||
- VERSION ${LAPACK_VERSION}
|
||||
- COMPATIBILITY SameMajorVersion
|
||||
- )
|
||||
-
|
||||
-install(FILES
|
||||
- ${LAPACK_BINARY_DIR}/CMakeFiles/lapack-config.cmake
|
||||
- ${LAPACK_BINARY_DIR}/lapack-config-version.cmake
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/lapack-${LAPACK_VERSION}
|
||||
- ${LAPACK_BINARY_DIR}/CMakeFiles/${LAPACKLIB}-config.cmake
|
||||
- ${LAPACK_BINARY_DIR}/${LAPACKLIB}-config-version.cmake
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${LAPACKLIB}-${LAPACK_VERSION}
|
||||
- COMPONENT Development
|
||||
- )
|
||||
-
|
||||
\ No newline at end of file
|
||||
if (LAPACK++)
|
||||
install(
|
||||
DIRECTORY "${LAPACK_BINARY_DIR}/lib/"
|
||||
diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
|
||||
--- a/LAPACKE/CMakeLists.txt
|
||||
+++ b/LAPACKE/CMakeLists.txt
|
||||
|
@ -517,7 +518,7 @@ diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
|
|||
message(STATUS "LAPACKE enable")
|
||||
enable_language(C)
|
||||
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME lapacke-targets)
|
||||
-set(LAPACK_INSTALL_EXPORT_NAME ${LAPACKELIB}-targets)
|
||||
-
|
||||
# Create a header file lapacke_mangling.h for the routines called in my C programs
|
||||
include(FortranCInterface)
|
||||
|
@ -526,38 +527,38 @@ diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
|
|||
VERSION ${LAPACK_VERSION}
|
||||
SOVERSION ${LAPACK_MAJOR_VERSION}
|
||||
)
|
||||
-target_include_directories(lapacke PUBLIC
|
||||
-target_include_directories(${LAPACKELIB} PUBLIC
|
||||
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
|
||||
- $<INSTALL_INTERFACE:include>
|
||||
-)
|
||||
-if(WIN32 AND NOT UNIX)
|
||||
- target_compile_definitions(lapacke PUBLIC HAVE_LAPACK_CONFIG_H LAPACK_COMPLEX_STRUCTURE)
|
||||
- target_compile_definitions(${LAPACKELIB} PUBLIC HAVE_LAPACK_CONFIG_H LAPACK_COMPLEX_STRUCTURE)
|
||||
- message(STATUS "Windows BUILD")
|
||||
-endif()
|
||||
|
||||
if(LAPACKE_WITH_TMG)
|
||||
target_link_libraries(lapacke PRIVATE tmglib)
|
||||
target_link_libraries(${LAPACKELIB} PRIVATE ${TMGLIB})
|
||||
@@ -111,22 +101,3 @@
|
||||
DESTINATION ${PKG_CONFIG_DIR}
|
||||
COMPONENT Development
|
||||
)
|
||||
-
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/lapacke-config-version.cmake.in
|
||||
- ${LAPACK_BINARY_DIR}/lapacke-config-version.cmake @ONLY)
|
||||
- ${LAPACK_BINARY_DIR}/${LAPACKELIB}-config-version.cmake @ONLY)
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/lapacke-config-build.cmake.in
|
||||
- ${LAPACK_BINARY_DIR}/lapacke-config.cmake @ONLY)
|
||||
- ${LAPACK_BINARY_DIR}/${LAPACKELIB}-config.cmake @ONLY)
|
||||
-
|
||||
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/lapacke-config-install.cmake.in
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/lapacke-config.cmake @ONLY)
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/${LAPACKELIB}-config.cmake @ONLY)
|
||||
-install(FILES
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/lapacke-config.cmake
|
||||
- ${LAPACK_BINARY_DIR}/lapacke-config-version.cmake
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/lapacke-${LAPACK_VERSION}
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/${LAPACKELIB}-config.cmake
|
||||
- ${LAPACK_BINARY_DIR}/${LAPACKELIB}-config-version.cmake
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${LAPACKELIB}-${LAPACK_VERSION}
|
||||
- COMPONENT Development
|
||||
- )
|
||||
-
|
||||
-install(EXPORT lapacke-targets
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/lapacke-${LAPACK_VERSION}
|
||||
-install(EXPORT ${LAPACKELIB}-targets
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/${LAPACKELIB}-${LAPACK_VERSION}
|
||||
- COMPONENT Development
|
||||
- )
|
||||
diff --git a/LAPACKE/cmake/lapacke-config-build.cmake.in b/LAPACKE/cmake/lapacke-config-build.cmake.in
|
||||
|
@ -570,8 +571,8 @@ deleted file mode 100644
|
|||
-find_package(LAPACK NO_MODULE)
|
||||
-
|
||||
-# Load lapack targets from the build tree, including lapacke targets.
|
||||
-if(NOT TARGET lapacke)
|
||||
- include("@LAPACK_BINARY_DIR@/lapack-targets.cmake")
|
||||
-if(NOT TARGET @LAPACKELIB@)
|
||||
- include("@LAPACK_BINARY_DIR@/@LAPACKLIB@-targets.cmake")
|
||||
-endif()
|
||||
-
|
||||
-# Hint for project building against lapack
|
||||
|
@ -581,7 +582,7 @@ deleted file mode 100644
|
|||
-set(LAPACKE_INCLUDE_DIRS "@LAPACK_BINARY_DIR@/include")
|
||||
-
|
||||
-# Report lapacke libraries.
|
||||
-set(LAPACKE_LIBRARIES lapacke ${LAPACK_LIBRARIES})
|
||||
-set(LAPACKE_LIBRARIES @LAPACKELIB@ ${LAPACK_LIBRARIES})
|
||||
diff --git a/LAPACKE/cmake/lapacke-config-install.cmake.in b/LAPACKE/cmake/lapacke-config-install.cmake.in
|
||||
deleted file mode 100644
|
||||
--- a/LAPACKE/cmake/lapacke-config-install.cmake.in
|
||||
|
@ -594,12 +595,12 @@ deleted file mode 100644
|
|||
-get_filename_component(_LAPACKE_PREFIX "${_LAPACKE_PREFIX}" PATH)
|
||||
-
|
||||
-# Load the LAPACK package with which we were built.
|
||||
-set(LAPACK_DIR "${_LAPACKE_PREFIX}/@CMAKE_INSTALL_LIBDIR@/cmake/lapack-@LAPACK_VERSION@")
|
||||
-set(LAPACK_DIR "${_LAPACKE_PREFIX}/@CMAKE_INSTALL_LIBDIR@/cmake/@LAPACK@-@LAPACK_VERSION@")
|
||||
-find_package(LAPACK NO_MODULE)
|
||||
-
|
||||
-# Load lapacke targets from the install tree.
|
||||
-if(NOT TARGET lapacke)
|
||||
- include(${_LAPACKE_SELF_DIR}/lapacke-targets.cmake)
|
||||
-if(NOT TARGET @LAPACKELIB@)
|
||||
- include(${_LAPACKE_SELF_DIR}/@LAPACKELIB@-targets.cmake)
|
||||
-endif()
|
||||
-
|
||||
-# Hint for project building against lapack
|
||||
|
@ -609,7 +610,7 @@ deleted file mode 100644
|
|||
-set(LAPACKE_INCLUDE_DIRS ${_LAPACKE_PREFIX}/include)
|
||||
-
|
||||
-# Report lapacke libraries.
|
||||
-set(LAPACKE_LIBRARIES lapacke ${LAPACK_LIBRARIES})
|
||||
-set(LAPACKE_LIBRARIES @LAPACKELIB@ ${LAPACK_LIBRARIES})
|
||||
-
|
||||
-unset(_LAPACKE_PREFIX)
|
||||
-unset(_LAPACKE_SELF_DIR)
|
||||
|
|
Loading…
Reference in New Issue