misc/fribid: Updated for version 0.3.0.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
3af205dd98
commit
7323fe1372
|
@ -3,3 +3,18 @@ identification) with BankID. With free means that the source code is
|
|||
availible for everyone to study, copy and/or improve. FriBID is cross
|
||||
plattform and works on plattforms thats not supported by the official
|
||||
client.
|
||||
|
||||
If you need PKCS#11 smartcard support then you need to use the PKCS11
|
||||
variable.
|
||||
|
||||
The options are:
|
||||
PKCS11=yes
|
||||
PKCS11=runtime
|
||||
yes needs opensc installed.
|
||||
runtime adds runtime support and doesn't need opensc installed it
|
||||
can be installed later and fribid checks for opensc when started.
|
||||
Or leave it alone for disabled.
|
||||
|
||||
Optional dependencies:
|
||||
opensc Adds PKCS#11 smartcard support if your reader is supported
|
||||
by opensc.
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for fribid
|
||||
|
||||
# Copyright 2010 Niklas "Nille" Åkerström
|
||||
# Copyright 2010 Niklas "Nille" Åkerström
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -24,9 +24,11 @@
|
|||
|
||||
|
||||
PRGNAM=fribid
|
||||
VERSION=${VERSION:-0.1.3}
|
||||
VERSION=${VERSION:-0.3.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
# Should we build PKCS#11 smartcard support YES RUNTIME or nothing.
|
||||
PKCS11=$(echo $PKCS11 | tr 'a-z' 'A-Z')
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -43,6 +45,14 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$PKCS11" = "YES" ]; then
|
||||
PKCS="--enable-pkcs11"
|
||||
elif [ "$PKCS11" = "RUNTIME" ]; then
|
||||
PKCS="--optional-pkcs11"
|
||||
else
|
||||
PKCS="--disable-pkcs11"
|
||||
fi
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
|
@ -72,14 +82,13 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# patch to compile against system nss
|
||||
patch -p1 < $CWD/seamonkey-nss_compile_fix.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--plugin-path=/usr/lib${LIBDIRSUFFIX}/mozilla/plugins \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX}
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
$PKCS
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
@ -87,6 +96,8 @@ make install DESTDIR=$PKG
|
|||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/man
|
||||
mv $PKG/usr/share/man $PKG/usr
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="fribid"
|
||||
VERSION="0.1.3"
|
||||
VERSION="0.3.0"
|
||||
HOMEPAGE="http://www.fribid.se"
|
||||
DOWNLOAD="http://www.fribid.se/releases/source/fribid-0.1.3.tar.bz2"
|
||||
MD5SUM="19b5d0db9ba6d11972bc7c8f34ea75fa"
|
||||
DOWNLOAD="http://www.fribid.se/releases/source/fribid-0.3.0.tar.bz2"
|
||||
MD5SUM="18657422f71f7a35f2e2d35d5bcdabcd"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Niklas 'Nille' Åkerström"
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
diff -ur fribid-0.1.2.orig/client/Makefile fribid-0.1.2/client/Makefile
|
||||
--- fribid-0.1.2.orig/client/Makefile 2010-03-24 00:32:27.000000000 +0100
|
||||
+++ fribid-0.1.2/client/Makefile 2010-04-07 21:24:16.000000000 +0200
|
||||
@@ -22,10 +22,10 @@
|
||||
|
||||
CFLAGS ?= -O2 -g
|
||||
COMMONCFLAGS=$(CFLAGS) -Wall -Wextra -std=c99 -pedantic -Wno-unused-parameter
|
||||
-CCFLAGS=$(COMMONCFLAGS) -I../npapi/include `pkg-config --cflags 'gtk+-2.0 >= 2.12' glib-2.0 'nss >= 3.10' nspr` -DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1
|
||||
+CCFLAGS=$(COMMONCFLAGS) -I../npapi/include `pkg-config --cflags 'gtk+-2.0 >= 2.12' glib-2.0 'nss >= 2.0' nspr` -DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1
|
||||
# You may have to add -lpthread after $(LDFLAGS) on OpenBSD
|
||||
LINKFLAGS=$(CFLAGS) $(LDFLAGS) -Wl,--as-needed
|
||||
-LIBS=`pkg-config --libs 'gtk+-2.0 >= 2.12' glib-2.0 'nss >= 3.10' nspr`
|
||||
+LIBS=`pkg-config --libs 'gtk+-2.0 >= 2.12' glib-2.0 'nss >= 2.0' nspr`
|
||||
|
||||
# Files to be installed
|
||||
LIB_PATH=`../configure --internal--get-define=LIB_PATH`
|
||||
Endast i fribid-0.1.2/common: config.h
|
||||
diff -ur fribid-0.1.2.orig/configure fribid-0.1.2/configure
|
||||
--- fribid-0.1.2.orig/configure 2010-03-24 00:32:27.000000000 +0100
|
||||
+++ fribid-0.1.2/configure 2010-04-07 21:25:17.000000000 +0200
|
||||
@@ -171,7 +171,7 @@
|
||||
|
||||
oldifs=IFS
|
||||
IFS=";"
|
||||
-pkgconfigDeps="gtk+-2.0 >= 2.12;glib-2.0;nss >= 3.10;nspr;x11"
|
||||
+pkgconfigDeps="gtk+-2.0 >= 2.12;glib-2.0;nss >= 2.0;nspr;x11"
|
||||
|
||||
if ! pkg-config --exists $pkgconfigDeps; then
|
||||
echo "Error: Unsatisfied dependencies: " >&2
|
||||
Endast i fribid-0.1.2/: configure~
|
Loading…
Reference in New Issue