libraries/SFML: Updated for version 2.1 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
23d542cf23
commit
72fd212d6e
|
@ -1,5 +1,4 @@
|
|||
SFML is a portable and easy to use multimedia API written in C++. You can
|
||||
see it as a modern, object-oriented alternative to SDL. SFML is composed
|
||||
of several packages to perfectly suit your needs. You can use SFML as a
|
||||
minimal windowing system to interface with OpenGL, or as a fully-featured
|
||||
multimedia library for building games or interactive programs.'
|
||||
SFML is a simple, fast, cross-platform and object-oriented multimedia API.
|
||||
It provides access to windowing, graphics, audio and network.
|
||||
It is written in C++, and has bindings for various languages such as C,
|
||||
.Net, Ruby, Python.
|
||||
|
|
|
@ -1,12 +1,31 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for SFML (Simple and Fast Multimedia Library)
|
||||
# Slackware build script for SFML
|
||||
|
||||
# Written by Pawel Standowicz (standek@gmail.com)
|
||||
# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=SFML
|
||||
VERSION=${VERSION:-1.6}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-2.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -22,9 +41,6 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
# Archive package name suffixes are different depending on system architecture.
|
||||
ARCHIVESUFFIX=${ARCHIVESUFFIX:-32} # Default for 32bit systems
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
|
@ -34,7 +50,6 @@ elif [ "$ARCH" = "i686" ]; then
|
|||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
ARCHIVESUFFIX="64" # For 64bit systems
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
|
@ -46,32 +61,35 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION-sdk-linux-$ARCHIVESUFFIX.tar.gz
|
||||
unzip $CWD/$PRGNAM-$VERSION-sources.zip
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Patch Makefile so that it respects CFLAGS
|
||||
sed -i "s/CFLAGS\ .*=/CFLAGS +=/" src/SFML/Makefile
|
||||
|
||||
# Patch Makefile to put libs in correct place
|
||||
sed -i "s|(DESTDIR)/lib|(DESTDIR)/lib$LIBDIRSUFFIX|" src/SFML/Makefile
|
||||
|
||||
# Add a big patch for gcc-4.7.x
|
||||
patch -p1 < $CWD/gcc47.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG/usr
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
rm -rf $PKG/usr/share
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -ar \
|
||||
doc/* \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a license.txt readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="SFML"
|
||||
VERSION="1.6"
|
||||
VERSION="2.1"
|
||||
HOMEPAGE="http://www.sfml-dev.org"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/sfml/SFML-1.6-sdk-linux-32.tar.gz"
|
||||
MD5SUM="acc678933c19558587aad8332ea6f459"
|
||||
DOWNLOAD_x86_64="http://downloads.sourceforge.net/sfml/SFML-1.6-sdk-linux-64.tar.gz"
|
||||
MD5SUM_x86_64="7a9b3a1ef6d14cd25090e440ccdbb3a8"
|
||||
DOWNLOAD="http://www.sfml-dev.org/download/sfml/2.1/SFML-2.1-sources.zip"
|
||||
MD5SUM="2de81448733f3f46964f23f41cd42e92"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="OpenAL"
|
||||
MAINTAINER="Pawel Standowicz"
|
||||
EMAIL="standek@gmail.com"
|
||||
MAINTAINER="Dimitris Zlatanidis"
|
||||
EMAIL="d.zlatanidis@gmail.com"
|
||||
|
|
|
@ -1,180 +0,0 @@
|
|||
Written by ponce@slackbuilds.org trying to build and fixing wherever necessary
|
||||
|
||||
diff -Naur SFML-1.6.orig/include/SFML/System/ResourcePtr.inl SFML-1.6/include/SFML/System/ResourcePtr.inl
|
||||
--- SFML-1.6.orig/include/SFML/System/ResourcePtr.inl 2010-01-27 14:53:54.000000000 +0100
|
||||
+++ SFML-1.6/include/SFML/System/ResourcePtr.inl 2012-09-23 19:19:33.736300968 +0200
|
||||
@@ -22,6 +22,7 @@
|
||||
//
|
||||
////////////////////////////////////////////////////////////
|
||||
|
||||
+#include <unistd.h>
|
||||
|
||||
////////////////////////////////////////////////////////////
|
||||
/// Default constructor
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Audio/Listener.cpp SFML-1.6/src/SFML/Audio/Listener.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Audio/Listener.cpp 2010-01-27 15:00:19.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Audio/Listener.cpp 2012-09-23 19:23:25.645300966 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Audio/Listener.hpp>
|
||||
#include <SFML/Audio/OpenAL.hpp>
|
||||
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Audio/Music.cpp SFML-1.6/src/SFML/Audio/Music.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Audio/Music.cpp 2010-01-27 15:00:19.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Audio/Music.cpp 2012-09-23 19:33:23.931300967 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Audio/Music.hpp>
|
||||
#include <SFML/Audio/OpenAL.hpp>
|
||||
#include <SFML/Audio/SoundFile.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Audio/Sound.cpp SFML-1.6/src/SFML/Audio/Sound.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Audio/Sound.cpp 2010-01-27 15:00:19.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Audio/Sound.cpp 2012-09-23 19:26:57.001300967 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Audio/Sound.hpp>
|
||||
#include <SFML/Audio/SoundBuffer.hpp>
|
||||
#include <SFML/Audio/OpenAL.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Audio/SoundBuffer.cpp SFML-1.6/src/SFML/Audio/SoundBuffer.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Audio/SoundBuffer.cpp 2010-01-27 15:00:19.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Audio/SoundBuffer.cpp 2012-09-23 19:29:59.239300967 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Audio/SoundBuffer.hpp>
|
||||
#include <SFML/Audio/SoundFile.hpp>
|
||||
#include <SFML/Audio/Sound.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Audio/SoundBufferRecorder.cpp SFML-1.6/src/SFML/Audio/SoundBufferRecorder.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Audio/SoundBufferRecorder.cpp 2010-01-27 15:00:19.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Audio/SoundBufferRecorder.cpp 2012-09-23 19:26:17.856300966 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Audio/SoundBufferRecorder.hpp>
|
||||
#include <algorithm>
|
||||
#include <iterator>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Audio/SoundStream.cpp SFML-1.6/src/SFML/Audio/SoundStream.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Audio/SoundStream.cpp 2010-03-18 14:14:46.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Audio/SoundStream.cpp 2012-09-23 19:34:43.477300968 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Audio/SoundStream.hpp>
|
||||
#include <SFML/Audio/AudioDevice.hpp>
|
||||
#include <SFML/Audio/OpenAL.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Graphics/Font.cpp SFML-1.6/src/SFML/Graphics/Font.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Graphics/Font.cpp 2010-03-18 14:14:41.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Graphics/Font.cpp 2012-09-23 19:32:06.580300966 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Graphics/Font.hpp>
|
||||
#include <SFML/Graphics/FontLoader.hpp>
|
||||
#include <iostream>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Graphics/Image.cpp SFML-1.6/src/SFML/Graphics/Image.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Graphics/Image.cpp 2010-01-27 15:00:05.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Graphics/Image.cpp 2012-09-23 19:22:22.316300968 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Graphics/Image.hpp>
|
||||
#include <SFML/Graphics/ImageLoader.hpp>
|
||||
#include <SFML/Graphics/RenderWindow.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Graphics/PostFX.cpp SFML-1.6/src/SFML/Graphics/PostFX.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Graphics/PostFX.cpp 2010-01-27 15:00:05.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Graphics/PostFX.cpp 2012-09-23 19:25:25.505300968 +0200
|
||||
@@ -26,6 +26,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Graphics/PostFX.hpp>
|
||||
#include <SFML/Graphics/RenderWindow.hpp>
|
||||
#include <SFML/Graphics/GraphicsContext.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Graphics/RenderTarget.cpp SFML-1.6/src/SFML/Graphics/RenderTarget.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Graphics/RenderTarget.cpp 2010-01-27 15:00:05.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Graphics/RenderTarget.cpp 2012-09-23 19:24:35.953300966 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Graphics/RenderTarget.hpp>
|
||||
#include <SFML/Graphics/Drawable.hpp>
|
||||
#include <SFML/Graphics/GraphicsContext.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Graphics/RenderWindow.cpp SFML-1.6/src/SFML/Graphics/RenderWindow.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Graphics/RenderWindow.cpp 2010-01-27 15:00:05.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Graphics/RenderWindow.cpp 2012-09-23 19:28:40.236300966 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Graphics/RenderWindow.hpp>
|
||||
#include <SFML/Graphics/Drawable.hpp>
|
||||
#include <SFML/Graphics/Image.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Graphics/Sprite.cpp SFML-1.6/src/SFML/Graphics/Sprite.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Graphics/Sprite.cpp 2010-01-27 15:00:05.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Graphics/Sprite.cpp 2012-09-23 19:27:41.924300968 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Graphics/Sprite.hpp>
|
||||
#include <SFML/Graphics/Image.hpp>
|
||||
#include <SFML/Graphics/GraphicsContext.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Graphics/String.cpp SFML-1.6/src/SFML/Graphics/String.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Graphics/String.cpp 2010-01-27 15:00:05.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Graphics/String.cpp 2012-09-23 19:31:08.332300966 +0200
|
||||
@@ -25,6 +25,8 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
// Headers
|
||||
////////////////////////////////////////////////////////////
|
||||
+#include <unistd.h>
|
||||
+#include <stddef.h>
|
||||
#include <SFML/Graphics/String.hpp>
|
||||
#include <SFML/Graphics/Image.hpp>
|
||||
#include <SFML/Graphics/GraphicsContext.hpp>
|
||||
diff -Naur SFML-1.6.orig/src/SFML/Window/Linux/Joystick.cpp SFML-1.6/src/SFML/Window/Linux/Joystick.cpp
|
||||
--- SFML-1.6.orig/src/SFML/Window/Linux/Joystick.cpp 2010-01-27 15:00:27.000000000 +0100
|
||||
+++ SFML-1.6/src/SFML/Window/Linux/Joystick.cpp 2012-09-23 19:12:09.461300157 +0200
|
||||
@@ -27,6 +27,7 @@
|
||||
////////////////////////////////////////////////////////////
|
||||
#include <SFML/Window/Joystick.hpp>
|
||||
#include <sstream>
|
||||
+#include <unistd.h>
|
||||
|
||||
|
||||
namespace sf
|
|
@ -8,12 +8,12 @@
|
|||
|-----handy-ruler------------------------------------------------------|
|
||||
SFML: SFML (Simple and Fast Multimedia Library)
|
||||
SFML:
|
||||
SFML: SFML is a portable and easy to use multimedia API written in C++.
|
||||
SFML: You can see it as a modern, object-oriented alternative to SDL.
|
||||
SFML: SFML is composed of several packages to perfectly suit your needs.
|
||||
SFML: You can use SFML as a minimal windowing system to interface with
|
||||
SFML: OpenGL, or as a fully-featured multimedia library for building games
|
||||
SFML: or interactive programs.
|
||||
SFML: SFML is a simple, fast, cross-platform and object-oriented multimedia
|
||||
SFML: API. It provides access to windowing, graphics, audio and network.
|
||||
SFML: It is written in C++, and has bindings for various languages such as
|
||||
SFML: C, .Net, Ruby, Python.
|
||||
SFML:
|
||||
SFML: Homepage: http://www.sfml-dev.org
|
||||
SFML:
|
||||
SFML:
|
||||
SFML: For more info visit: http://www.sfml-dev.org/
|
||||
SFML:
|
||||
|
|
Loading…
Reference in New Issue