academic/vcftools: Updated for version 0.1.14_2_g78add55.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Petar Petrov 2015-11-11 23:12:27 +07:00 committed by Willy Sudiarto Raharjo
parent c61d2947f7
commit 72a5c0c201
4 changed files with 24 additions and 63 deletions

View File

@ -15,5 +15,5 @@ vcftools: VCF files: validating, merging, comparing and calculate some
vcftools: basic population genetic statistics.
vcftools:
vcftools: Home: http://vcftools.sourceforge.net/
vcftools: References: /usr/doc/vcftools-0.1.12b/References
vcftools: References: /usr/doc/vcftools-0.1.14_2_g78add55/References
vcftools:

View File

@ -1,40 +0,0 @@
Author: Andreas Tille <tille@debian.org>
Date: Sat, 12 May 2012 09:31:58 +0200
Description: Enable propagation of hardening flags
Index: vcftools_0.1.11/cpp/Makefile
===================================================================
--- vcftools_0.1.11.orig/cpp/Makefile 2013-06-13 16:40:54.000000000 +0200
+++ vcftools_0.1.11/cpp/Makefile 2013-06-27 19:54:45.000000000 +0200
@@ -12,9 +12,9 @@
VCFTOOLS_PCA = 0
endif
# Compiler flags
-CFLAGS = -O2 -m64
+CFLAGS += -O2
#CFLAGS = -Wall -O2 -pg -m64
-CPPFLAGS = -O2 -D_FILE_OFFSET_BITS=64
+CPPFLAGS += -O2 -D_FILE_OFFSET_BITS=64
#CPPFLAGS = -O2 -Wall -pg -D_FILE_OFFSET_BITS=64
# Included libraries (zlib)
LIB = -lz
@@ -38,7 +38,7 @@
endif
vcftools: $(OBJS)
- $(CPP) $(CPPFLAGS) $(OBJS) -o vcftools $(LIB)
+ $(CPP) $(CPPFLAGS) $(OBJS) $(LDFLAGS) -o vcftools $(LIB)
ifdef BINDIR
cp $(CURDIR)/$@ $(BINDIR)/$@
endif
@@ -50,8 +50,8 @@
-include $(OBJS:.o=.d)
%.o: %.cpp
- $(CPP) -c $(CPPFLAGS) $*.cpp -o $*.o
- $(CPP) -MM $(CPPFLAGS) $*.cpp > $*.d
+ $(CPP) -c $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $*.cpp -o $*.o
+ $(CPP) -MM $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $*.cpp > $*.d
# remove compilation products
clean:

View File

@ -23,10 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vcftools
VERSION=${VERSION:-0.1.12b}
VERSION=${VERSION:-0.1.14_2_g78add55}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCVER=v0.1.14-2-g78add55
GITVER=78add55
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
@ -59,9 +62,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf ${PRGNAM}_${VERSION}
tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
cd ${PRGNAM}_${VERSION}
rm -rf ${PRGNAM}-${PRGNAM}-${SRCVER}
tar xvf $CWD/${PRGNAM}-${PRGNAM}-${SRCVER}.tar.gz
cd ${PRGNAM}-${PRGNAM}-${GITVER}
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@ -69,21 +72,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Thanks to Debian for the patch
patch -p1 -i $CWD/use-dpkg-buildflags.patch
# Set the proper, architecture-specific path
sed -i "s:/lib/perl5/site_perl:/lib${LIBDIRSUFFIX}/perl5:g" Makefile
./autogen.sh
CFLAGS="$SLKCFLAGS" \
CPPFLAGS="$SLKCFLAGS" \
PREFIX=$PKG/usr \
make install
# Remove this and copy the man page to its proper place
rm -rf $PKG/usr/bin/man1
mkdir -p $PKG//usr/man/man1
cp cpp/vcftools.1 $PKG/usr/man/man1
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
make
make DESTDIR=$PKG install
# Copy examples
mkdir -p $PKG/usr/share/$PRGNAM
@ -96,7 +97,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.txt perl/ChangeLog website/*.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.md src/perl/ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References

View File

@ -1,8 +1,8 @@
PRGNAM="vcftools"
VERSION="0.1.12b"
HOMEPAGE="http://vcftools.sourceforge.net/"
DOWNLOAD="http://sourceforge.net/projects/vcftools/files/vcftools_0.1.12b.tar.gz"
MD5SUM="662758d1139c138cf5a0239ed99f12c2"
VERSION="0.1.14_2_g78add55"
HOMEPAGE="https://vcftools.github.io/"
DOWNLOAD="https://github.com/vcftools/vcftools/tarball/master/vcftools-vcftools-v0.1.14-2-g78add55.tar.gz"
MD5SUM="e5fbb773ef13d567606067351501ac13"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="tabix"