python/boto: Updated for version 2.4.1.

Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
Larry Hajali 2012-06-25 21:42:57 -04:00 committed by dsomero
parent 24372e8909
commit 6fa27fc507
4 changed files with 11 additions and 25 deletions

View File

@ -1,3 +1,8 @@
Boto is a Python package that provides interfaces to Amazon Web Services.
Boto requires filechunkio and distribute.
The goal of boto is to support the full breadth and depth of Amazon Web
Services. In addition, boto provides support for other public services such as
Google Storage in addition to private cloud systems like Eucalyptus, OpenStack
and Open Nebula.
Boto requires filechunkio and pysetuptools/distribute.

View File

@ -1,16 +0,0 @@
diff -Naur boto-2.2.2.orig/setup.py boto-2.2.2/setup.py
--- boto-2.2.2.orig/setup.py 2012-02-15 03:17:52.000000000 +0000
+++ boto-2.2.2/setup.py 2012-05-07 02:23:28.885052767 +0000
@@ -59,11 +59,7 @@
"boto.mturk", "boto.mturk.test", "boto.pyami",
"boto.pyami.installers", "boto.pyami.installers.ubuntu",
"boto.mashups", "boto.contrib", "boto.manage",
- "tests", "tests.autoscale", "tests.cloudfront",
- "tests.devpay", "tests.db", "tests.dynamodb",
- "tests.ec2", "tests.ec2.cloudwatch", "tests.ec2.elb",
- "tests.s3", "tests.sdb", "tests.sqs", "tests.sts",
- "tests.utils", "boto.services", "boto.cloudfront",
+ "boto.services", "boto.cloudfront",
"boto.roboto", "boto.rds", "boto.vpc", "boto.fps",
"boto.fps.test", "boto.emr", "boto.emr.tests", "boto.sns",
"boto.ecs", "boto.iam", "boto.route53", "boto.ses",

View File

@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=boto
VERSION=${VERSION:-2.2.2}
VERSION=${VERSION:-2.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -37,16 +37,13 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Don't install test files.
patch -p1 < $CWD/boto-2.2.2-no-install-tests.patch
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Changelog.rst PKG-INFO README.markdown $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Changelog.rst PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README.$PRGNAM > $PKG/usr/doc/$PRGNAM-$VERSION/README.$PRGNAM
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View File

@ -1,8 +1,8 @@
PRGNAM="boto"
VERSION="2.2.2"
VERSION="2.4.1"
HOMEPAGE="https://github.com/boto/boto"
DOWNLOAD="http://pypi.python.org/packages/source/b/boto/boto-2.2.2.tar.gz"
MD5SUM="b23b9137abd7286615236ed03929d282"
DOWNLOAD="http://pypi.python.org/packages/source/b/boto/boto-2.4.1.tar.gz"
MD5SUM="6fb90c1aa8c8ce6d967f2b0e06deda5b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"