system/bleachbit: Added to 12.2 repository

This commit is contained in:
Pierre Cazenave 2010-05-12 23:33:20 +02:00 committed by David Somero
parent 29e232356b
commit 6f4c956671
7 changed files with 152 additions and 0 deletions

10
system/bleachbit/README Normal file
View File

@ -0,0 +1,10 @@
BleachBit deletes unnecessary files to free valuable disk space, maintain
privacy, and remove junk. Rid your system of old clutter including cache,
cookies, Internet history, localizations, logs, temporary files, and broken
shortcuts. Designed for Linux systems, it wipes clean Adobe Reader, APT,
Bash, Beagle, Chromium, Epiphany, Firefox, Flash, GIMP, Google Earth,
Java, KDE, OpenOffice.org, Opera, RealPlayer, Second Life viewer, Skype,
VIM, XChat, Yum, and more.
As with all automated "cleaning" programs, exercise caution and review
the output before committing any changes to disk.

View File

@ -0,0 +1,72 @@
#!/bin/sh
# SlackBuild script for bleachbit.
#
# Copyright 2009 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=bleachbit
VERSION=${VERSION:-0.4.1}
ARCH=${ARCH:-noarch}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
# Ignore the Slackware package manager's directories
# Thanks to Andrew Ziew upstream for the quick response
patch -p1 < $CWD/patches/bleachbit-0.4.1-Unix.py.diff
# Make a launcher using this debian patch
patch -p1 < $CWD/patches/bleachbit-0.4.1-launcher.diff
# Fix the icon in the .desktop file
sed -i -e 's|Icon=bleachbit.png|Icon=bleachbit|g' bleachbit.desktop
python setup.py install --root $PKG
make -C po install DESTDIR=$PKG
# Make the launcher executable by all
chmod 755 $PKG/usr/bin/bleachbit
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING PKG-INFO README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

View File

@ -0,0 +1,8 @@
PRGNAM="bleachbit"
VERSION="0.4.1"
HOMEPAGE="http://bleachbit.sourceforge.net/"
DOWNLOAD="http://downloads.sourceforge.net/bleachbit/bleachbit-0.4.1.tar.bz2"
MD5SUM="b211c60a198ddf8023c7a460538bd031"
MAINTAINER="Pierre Cazenave"
EMAIL="pwcazenave <at> gmail {dot} com"
APPROVED="dsomero,rworkman"

View File

@ -0,0 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications &> /dev/null
fi

View File

@ -0,0 +1,13 @@
--- trunk/bleachbit/Unix.py 2009/02/08 20:08:26 274
+++ trunk/bleachbit/Unix.py 2009/05/08 02:27:54 346
@@ -447,7 +447,9 @@
regex = '-[0-9]{8}$'
globpaths = ( '/var/log/*-*', '/var/log/*/*-*' )
for path in FileUtilities.globex(globpaths, regex):
- yield path
+ whitelist_re = '^/var/log/(removed_)?(packages|scripts)'
+ if None == re.match(whitelist_re, path): # for Slackware, Launchpad #367575
+ yield path
def wine_to_linux_path(wineprefix, windows_pathname):

View File

@ -0,0 +1,27 @@
Implement and install a launcher to start the GUI.
Index: bleachbit-0.2.1/bin/bleachbit
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ bleachbit-0.2.1/bin/bleachbit 2009-01-29 22:10:20.641192983 +0100
@@ -0,0 +1,8 @@
+#!/usr/bin/env python
+
+import bleachbit.GUI
+import gtk
+
+if __name__ == '__main__':
+ gui = bleachbit.GUI.GUI()
+ gtk.main()
Index: bleachbit-0.2.1/setup.py
===================================================================
--- bleachbit-0.2.1.orig/setup.py 2009-01-29 22:10:13.625194708 +0100
+++ bleachbit-0.2.1/setup.py 2009-01-29 22:10:20.641192983 +0100
@@ -25,6 +25,7 @@
data_files = []
data_files.append(('/usr/share/applications', ['./bleachbit.desktop']))
data_files.append(('/usr/share/pixmaps/', ['./bleachbit.png']))
+data_files.append(('/usr/bin', ['bin/bleachbit']))
setup(name='bleachbit',
version='0.4.1',

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
bleachbit: bleachbit (deletes unnecessary files to free valuable disk space)
bleachbit:
bleachbit: BleachBit deletes unnecessary files to free valuable disk space,
bleachbit: maintain privacy, and remove junk. Rid your system of old clutter
bleachbit: including cache, cookies, Internet history, localizations, logs,
bleachbit: temporary files, and broken shortcuts. Designed for Linux systems, it
bleachbit: wipes clean Adobe Reader, APT, Bash, Beagle, Chromium, Epiphany,
bleachbit: Firefox, Flash, GIMP, Google Earth, Java, KDE, OpenOffice.org, Opera,
bleachbit: RealPlayer, Second Life viewer, Skype, VIM, XChat, Yum, and more.
bleachbit:
bleachbit: http://bleachbit.sourceforge.net/