network/nagios: Updated for version 3.3.1.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
ec410d942c
commit
6e963dbb9a
|
@ -1,18 +1,18 @@
|
|||
Nagios is a powerful monitoring system that enables organizations to identify
|
||||
and resolve IT infrastructure problems before they affect critical business
|
||||
processes.
|
||||
Nagios is a powerful monitoring system that enables organizations to
|
||||
identify and resolve IT infrastructure problems before they affect critical
|
||||
business processes.
|
||||
|
||||
Nagios requires a "nagios" user and group; create these before running the
|
||||
Nagios requires a "nagios" user and group; create these before running the
|
||||
SlackBuild script. Examples:
|
||||
|
||||
# groupadd -g 213 nagios
|
||||
# useradd -u 213 -d /dev/null -s /bin/false -g nagios nagios
|
||||
|
||||
For some scripts to work, it is necessary to include the 'apache' user in
|
||||
For some scripts to work, it is necessary to include the 'apache' user in
|
||||
the nagios group.
|
||||
|
||||
For some functions (most notably the "map" function), you need to have X
|
||||
installed on your server. You do not have to start X though, nagios just
|
||||
For some functions (most notably the "map" function), you need to have X
|
||||
installed on your server. You do not have to start X though, nagios just
|
||||
needs some of the libraries and fonts.
|
||||
|
||||
This SlackBuild installs the basic nagios system in /var/www/htdocs/
|
||||
|
@ -21,9 +21,9 @@ To change the location, set the DOCROOT variable:
|
|||
|
||||
For a useful setup, you will want to have nagios-plugins installed.
|
||||
|
||||
To configure nagios, some knowledge of httpd is required. Check the included
|
||||
'README.SLACKWARE' file for some basic setup instructions. The include file
|
||||
for httpd is installed as /etc/httpd/extra/nagios.conf
|
||||
To configure nagios, some knowledge of httpd is required. Check the
|
||||
included 'README.SLACKWARE' file for some basic setup instructions. The
|
||||
include file for httpd is installed as /etc/httpd/extra/nagios.conf
|
||||
|
||||
Lots of information is available in the included documentation, and even more
|
||||
can be found on the nagios site and wiki <http://wiki.nagios.org>.
|
||||
Lots of information is available in the included documentation, and even
|
||||
more can be found on the nagios site and wiki <http://wiki.nagios.org>.
|
||||
|
|
|
@ -3,11 +3,30 @@
|
|||
# Slackware build script for nagios:
|
||||
# IT infrastructure monitoring system
|
||||
|
||||
# Written by Niels Horn <niels.horn@gmail.com>
|
||||
# revision date 2010/10/06
|
||||
# Copyright 2009-2011 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# revision date 2011/07/26
|
||||
|
||||
PRGNAM=nagios
|
||||
VERSION=${VERSION:-3.2.3}
|
||||
VERSION=${VERSION:-3.3.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -64,14 +83,18 @@ if [ "$(grep ^nagios /etc/passwd)" = "" -o "$(grep ^nagios /etc/group)" = "" ] ;
|
|||
exit 1
|
||||
fi
|
||||
|
||||
rm -rf $TMP/$PRGNAM-$VERSION $PKG
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
cd $PRGNAM
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
#Solve a silly bug in the Makefile
|
||||
patch -p1 < $CWD/nagios_makeinstall.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
|
@ -91,13 +114,25 @@ CFLAGS="$SLKCFLAGS" \
|
|||
make all
|
||||
|
||||
export DESTDIR=$PKG
|
||||
echo "*** make install ***"
|
||||
make install
|
||||
echo "*** make install-init ***"
|
||||
make install-init
|
||||
echo "*** make install-commandmode ***"
|
||||
make install-commandmode
|
||||
echo "*** make install-config ***"
|
||||
make install-config
|
||||
# Need to create the $PKG/etc/httpd/extra directory (this is a bug in Makefile.in)
|
||||
mkdir -p $PKG/etc/httpd/extra
|
||||
echo "*** make install-webconf ***"
|
||||
make install-webconf
|
||||
# Following upstream, the "exfoliation" theme is now the default...
|
||||
echo "*** make install-exfoliation ***"
|
||||
make install-exfoliation
|
||||
# ...but, if you prefer the "classic" theme, uncomment the next two lines, as they
|
||||
# will overwrite the new theme:
|
||||
#echo "*** make install-classicui ***"
|
||||
#make install-classicui
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
@ -121,16 +156,11 @@ cp -a \
|
|||
Changelog INSTALLING LEGAL LICENSE README THANKS UPGRADING contrib \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mv $PKG/$DOCROOT/$PRGNAM/docs $PKG/usr/doc/$PRGNAM-$VERSION/html
|
||||
cd $PKG/$DOCROOT/$PRGNAM
|
||||
ln -sf ../$RELPATH/usr/doc/$PRGNAM-$VERSION/html docs
|
||||
cd -
|
||||
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
|
||||
|
||||
# Fixup some ownership and permission issues
|
||||
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/html
|
||||
chmod 0755 $PKG/usr/doc/$PRGNAM-$VERSION/html{,/images}
|
||||
chown root:root $PKG/usr/sbin
|
||||
chown -R root:nagios $PKG/usr/sbin/$PRGNAM
|
||||
chmod -R 0754 $PKG/usr/sbin/$PRGNAM
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="nagios"
|
||||
VERSION="3.2.3"
|
||||
VERSION="3.3.1"
|
||||
HOMEPAGE="http://www.nagios.org/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/nagios/nagios-3.2.3.tar.gz"
|
||||
MD5SUM="fe1be46e6976a52acdb021a782b5d04b"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/nagios/nagios-3.3.1.tar.gz"
|
||||
MD5SUM="c935354ce0d78a63bfabc3055fa77ad5"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Niels Horn"
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- nagios/html/Makefile.in 2011-07-24 14:53:52.000000000 -0300
|
||||
+++ nagios_patched/html/Makefile.in 2011-07-26 20:56:28.000000000 -0300
|
||||
@@ -75,7 +75,7 @@
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images/logos; done
|
||||
for file in includes/*.*; \
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes; done
|
||||
- for file in includes/rss/*; \
|
||||
+ for file in $$(find includes/rss -type f -maxdepth 1); \
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss; done
|
||||
for file in includes/rss/extlib/*; \
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss/extlib; done
|
Loading…
Reference in New Issue