network/torsocks: Fix lib path in torsocks.
Added a patch to fix a symbol warning. Thanks to crumb on irc for the report. Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
6e6831c724
commit
6e90b14cc1
|
@ -0,0 +1,16 @@
|
|||
--- src/tsocks.c 2011-10-25 17:49:50.000000000 -0400
|
||||
+++ src/tsocks.c 2012-02-21 11:09:20.000000000 -0500
|
||||
@@ -175,9 +175,9 @@
|
||||
#define LOAD_ERROR(s,l) { \
|
||||
char *error; \
|
||||
error = dlerror(); \
|
||||
- show_msg(l, "The symbol %s() was not found in any shared " \
|
||||
- "library. The error reported was: %s!\n", s, \
|
||||
- (error)?error:"not found"); \
|
||||
+ if (error) \
|
||||
+ show_msg(l, "The symbol %s() was not found in any shared " \
|
||||
+ "library. The error reported was: %s!\n", s, error); \
|
||||
dlerror(); \
|
||||
}
|
||||
pthread_mutex_lock(&torsocks_init_mutex);
|
||||
|
|
@ -6,7 +6,7 @@
|
|||
|
||||
PRGNAM=torsocks
|
||||
VERSION=${VERSION:-1.1}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -53,6 +53,8 @@ find -L . \
|
|||
|
||||
# Fix a hardcoded lib path.
|
||||
sed -i -e 's|@prefix@/lib|@libdir@|' src/Makefile.in
|
||||
sed -i -e 's|@prefix@/lib|@libdir@|' src/torsocks.in
|
||||
patch -p0 < $CWD/symbol_lookup.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
|
Loading…
Reference in New Issue