desktop/wbar: Added (quick launch bar)

Signed-off-by: Dave Woodfall <dave@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Damian Perticone 2022-06-07 12:14:29 +01:00 committed by Willy Sudiarto Raharjo
parent a649a237f6
commit 6c1cb0919b
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
8 changed files with 377 additions and 0 deletions

77
desktop/wbar/README Normal file
View File

@ -0,0 +1,77 @@
Wbar is a quick launch bar. It's fast, light and cool eye-candy.
It's hacked in c++ trying to keep code as readable as possible
without sacrificing speed. It works directly on top of X to avoid
going through a lot of layers.
Initially it was developed for Fluxbox, then tested on WindowMaker,
Xfce, and Gnome 2 and it works very well with other window managers,
too.
Since version 1.0 Wbar can run on top of desktops such as xfdesktop
or Nautilus with the -above-desk switch.
CONFIGURATION:
Wbar-config is the recommended tool to customize Wbar. It is completely
optional but very easy to use. You can tweak the icon size and distance,
adjust Wbar's position on the screen and also change effects like
transparency, color filter and jump factor.
See also wbar(1) and wbar-config(1).
5.2. make-conf.sh
If you don't want to install a GUI application to configure Wbar, the
next best solution to create an initial wbar.cfg would be the
make-conf.sh script.
The script searches for installed desktop files in
/usr/share/applications and creates an initial config in /tmp with the
corresponding icons in your pixmaps and hicolor directories in
/usr/share. Just copy the config file to ~/.wbar and you're set.
5.3. Manual method
Wbar will look for your configuration in $HOME/.wbar first or will use
the global configuration file in /etc/wbar.d/wbar.cfg.
.wbar format:
---------------
Commented lines start whith #.
Blank lines are ignored.
Example:
Each icon has the following format:
i: <icon-file-path>
c: <command to execute on click>
t: <text to display on mouse over>
The order of appearance doesn't matter but all 3 of these lines must
appear. If you aren't gonna display text nor have a command associated
for a certain icon you should do the following:
i: <icon-file-path>
c:
t:
The first icon definition has a special meaning:
------------------------------------------------
i: <path-to-the-bar-background-image>
c: wbar --bpress --above-desk --vbar --pos right --isize 64 --idist 5
--nanim 4 --falfa 65
t: <path-to-font-to-display-text-with/size>
IF A FONT ISN'T SUPPLIED THEN NO TEXT RENDERING IS DONE.
Notes:
------
If you're getting window decorations (you shouldn't) when you start
your window manager because you're using the -above-desk switch,
try to give the WM some time to start up before wbar does.
Example (in your startup script): (sleep 5s && wbar) &
Note that the parenthesis surrounding the command are important.

19
desktop/wbar/slack-desc Normal file
View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
wbar: wbar (quick launch bar)
wbar:
wbar: Wbar is a quick launch bar. It's fast, light and cool eye-candy.
wbar:
wbar:
wbar:
wbar:
wbar:
wbar: Home: http://code.google.com/p/wbar
wbar:
wbar:

View File

@ -0,0 +1,71 @@
--- a/configure.ac
+++ b/configure.ac
@@ -83,6 +83,7 @@ AC_DEFINE_UNQUOTED(PIDOF_BIN, "$PIDOF_BIN ", [ program to retreive wbar pid ])
AC_CONFIG_FILES([Makefile \
share/Makefile \
+share/wbar.desktop.in \
etc/Makefile \
etc/wbar.cfg \
etc/wbar.desktop.in \
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -3,7 +3,7 @@ CLEANFILES = *~ $(wbardesktop:.desktop.in.in=.desktop)
defaultdir = @DEFAULT_CONFIGDIR@
default_DATA = $(wbarcfg:.cfg.in=.cfg)
-autostartdir = @DEFAULT_CONFIGDIR@
+autostartdir = $(sysconfdir)/xdg/autostart
autostart_DATA = $(wbardesktop:.desktop.in.in=.desktop)
bashcompletiondir = /etc/bash_completion.d
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,3 +1,4 @@
+share/wbar.desktop.in
share/wbar.glade
src/config/Functions.cc
src/config/Functions.h
--- a/po/POTFILES.skip
+++ b/po/POTFILES.skip
@@ -1,2 +1,3 @@
etc/wbar.desktop.in.in
+share/wbar.desktop.in.in
--- a/share/Makefile.am
+++ b/share/Makefile.am
@@ -1,8 +1,17 @@
-CLEANFILES = *~
+CLEANFILES = *~ $(wbardesktop:.desktop.in.in=.desktop)
gladedir = @GLADE_PACKAGE_DIR@
glade_DATA = @PACKAGE@.glade
+desktopfilesdir = $(prefix)/share/applications
+desktopfiles_DATA = $(wbardesktop:.desktop.in.in=.desktop)
+
+@INTLTOOL_DESKTOP_RULE@
+
+wbardesktop = wbar.desktop.in.in
+
EXTRA_DIST = \
-$(glade_DATA)
+$(glade_DATA) \
+$(wbardesktop) \
+$(wbardesktop:.desktop.in.in=.desktop.in)
--- /dev/null
+++ b/share/wbar.desktop.in.in
@@ -0,0 +1,12 @@
+[Desktop Entry]
+_Name=Warlock Bar
+Type=Application
+Exec=@BINDIR@/@PACKAGE_NAME@
+Terminal=false
+Icon=@PIXMAPDIR@/@PACKAGE_NAME@.png
+_Comment=A light and fast launch bar.
+Categories=Utility;
+X-GNOME-Bugzilla-Bugzilla=GNOME
+X-GNOME-Bugzilla-Product=@PACKAGE_NAME@
+X-GNOME-Bugzilla-Component=general
+X-Ubuntu-Gettext-Domain=@PACKAGE_NAME@

View File

@ -0,0 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@
AC_INIT([wbar], [2.3.4])
AM_INIT_AUTOMAKE([ filename-length-max=256 tar-ustar ])
-AM_CONFIG_HEADER(config.h)
+AC_CONFIG_HEADERS(config.h)
AC_CONFIG_MACRO_DIR([m4])
AC_PROG_CXX

View File

@ -0,0 +1,54 @@
--- a/src/config/Functions.cc
+++ b/src/config/Functions.cc
@@ -11,7 +11,7 @@
#include "Run.h"
#include "OptParser.h"
-#define ICON_DEFAULT PIXMAPDIR"/"PACKAGE_NAME".png"
+#define ICON_DEFAULT PIXMAPDIR "/" PACKAGE_NAME ".png"
static const gchar *authors[] =
{
@@ -304,7 +304,7 @@
if (command.empty())
{
- command = PACKAGE_NAME" "DEFAULT_ARGV;
+ command = PACKAGE_NAME " " DEFAULT_ARGV;
}
if (argc <= 1 || tmpoptparser.isSet( OptParser::CONFIG ))
--- a/src/config/Run.cc
+++ b/src/config/Run.cc
@@ -125,9 +125,9 @@
bool Run::start(std::string command)
{
- if (system ((PACKAGE_NAME" " + command + " &").c_str()) != 0)
+ if (system ((PACKAGE_NAME " " + command + " &").c_str()) != 0)
{
- std::cout << _("Error run program: ") << PACKAGE_NAME" " + command << std::endl;
+ std::cout << _("Error run program: ") << PACKAGE_NAME " " + command << std::endl;
}
return Run::getPID() > 0;
}
@@ -136,7 +136,7 @@
{
if (Run::getPID() > 0)
{
- if (system ("killall "PACKAGE_NAME) != 0)
+ if (system ("killall " PACKAGE_NAME) != 0)
{
std::cout << _("Error kill program: ") << PACKAGE_NAME << std::endl;
}
--- a/src/core/Main.cc
+++ b/src/core/Main.cc
@@ -81,7 +81,7 @@
if (command.empty())
{
- command = PACKAGE_NAME" "DEFAULT_ARGV;
+ command = PACKAGE_NAME " " DEFAULT_ARGV;
}
if (argc <= 1 || tmpoptparser.isSet( OptParser::CONFIG ))

View File

@ -0,0 +1,19 @@
--- a/etc/wbar
+++ b/etc/wbar
@@ -1,7 +1,6 @@
# bash completion for wbar
# Yadickson Soto yadickson@gmail.com
-have wbar &&
_wbar()
{
local cur prev split=false
@@ -106,7 +105,7 @@
-- "$cur") )
fi
-} &&
+}
complete -F _wbar wbar
# Local variables:

View File

@ -0,0 +1,116 @@
#!/bin/bash
# Slackware build script for wbar
# Copyright 2022 Damian Perticone, Berisso, Argentina
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wbar
VERSION=${VERSION:-2.3.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# patches
patch -p1 < $CWD/wbar-2.3.4-c++11.patch
patch -p1 < $CWD/wbar-2.3.4-automake-1.13.patch
patch -p1 < $CWD/wbar-2.3.4-completion.patch
patch -p1 < $CWD/wbar-2.3.3-desktopfile.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -Wno-error=deprecated-declarations" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

10
desktop/wbar/wbar.info Normal file
View File

@ -0,0 +1,10 @@
PRGNAM="wbar"
VERSION="2.3.4"
HOMEPAGE="http://code.google.com/p/wbar/"
DOWNLOAD="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/wbar/wbar-2.3.4.tgz"
MD5SUM="c1ac6b74138937a280904d1bac88115d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="imlib2"
MAINTAINER="Damian Perticone"
EMAIL="mjolnirdam@gmail.com"