graphics/exact-image: Updated for version 0.8.7.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Benjamin Trigona-Harany 2012-04-06 09:40:06 -05:00 committed by Erik Hanson
parent dc5f6f416d
commit 6bfcec9d9a
5 changed files with 20 additions and 19 deletions

View File

@ -1,11 +1,12 @@
ExactImage is an image processing library which reimplements
ExactImage is an image processing library which reimplements
ImageMagick functions with a significant speed improvement.
The library also provides several new algorithms: lossless JPEG
transforms and creation of searchable PDFs from hOCR annotated HTML
created with an OCR program such as Tesseract or Cuneiform (available
at Slackbuilds.org). There are bindings for PHP, Lua, Perl, and Python.
See /usr/doc/exact-image-*/examples/ for information on using exactimage
with Perl, Python, PHP and Lua.
transforms and creation of searchable PDFs from hOCR annotated
HTML created with an OCR program such as Tesseract or Cuneiform
(available at Slackbuilds.org). There are bindings for PHP, Lua,
Perl, and Python. See /usr/doc/exact-image-*/examples/ for
information on using exactimage with Perl, Python, PHP and Lua.
ExactImage requires agg. Lua and evas are optional dependencies available
at Slackbuilds.org, while bardecode is optional but not available.
ExactImage requires agg. lua and evas are optional dependencies
(both available here at Slackbuilds.org) while bardecode is also
optional but not available here.

View File

@ -3,7 +3,7 @@
# Written by Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
PRGNAM=exact-image
VERSION=${VERSION:-0.8.6}
VERSION=${VERSION:-0.8.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

View File

@ -1,10 +1,10 @@
PRGNAM="exact-image"
VERSION="0.8.6"
VERSION="0.8.7"
HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.6.tar.bz2"
MD5SUM="605f19bc33d2bcc49a39e72a181ba137"
DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.7.tar.bz2"
MD5SUM="4469fada7792356749a6b0c356aa4931"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="bosth@alumni.sfu.ca"
APPROVED="Erik Hanson,Niels Horn"
APPROVED="rworkman"

View File

@ -1,6 +1,6 @@
diff -Nur exact-image-0.8.3.orig//api/perl/Makefile exact-image-0.8.3/api/perl/Makefile
--- exact-image-0.8.3.orig//api/perl/Makefile
+++ exact-image-0.8.3/api/perl/Makefile
diff -Nur exact-image-0.8.7.orig//api/perl/Makefile exact-image-0.8.7/api/perl/Makefile
--- exact-image-0.8.7.orig//api/perl/Makefile
+++ exact-image-0.8.7/api/perl/Makefile
@@ -20,5 +20,6 @@
all:: $($(X_MODULE)_BINARY)
install:: $($(X_MODULE)_BINARY)

View File

@ -1,6 +1,6 @@
diff -Naur exact-image-0.8.3-old/codecs/png.cc exact-image-0.8.3/codecs/png.cc
--- exact-image-0.8.3-old/codecs/png.cc
+++ exact-image-0.8.3/codecs/png.cc
diff -Naur exact-image-0.8.7-old/codecs/png.cc exact-image-0.8.7/codecs/png.cc
--- exact-image-0.8.7-old/codecs/png.cc
+++ exact-image-0.8.7/codecs/png.cc
@@ -71,7 +71,7 @@
/* Allocate/initialize the memory for image information. REQUIRED. */
info_ptr = png_create_info_struct(png_ptr);