system/unace: Compress patches.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
e3b3456f95
commit
6700caff98
|
@ -1,52 +0,0 @@
|
|||
#!/bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 01-makefiles.dpatch by Fabian Greffrath <fabian@debian-unofficial.org>
|
||||
##
|
||||
## DP: Fix upstream makefiles
|
||||
|
||||
@DPATCH@
|
||||
|
||||
diff -Nru unace-nonfree-2.5.orig/base.mk unace-nonfree-2.5/base.mk
|
||||
--- unace-nonfree-2.5.orig/base.mk 2003-11-27 20:16:20.000000000 +0100
|
||||
+++ unace-nonfree-2.5/base.mk 2006-01-31 09:33:04.000000000 +0100
|
||||
@@ -427,9 +427,7 @@
|
||||
##############################################################################
|
||||
|
||||
ifndef ISWMAKE
|
||||
-include $(MAKE_DIR)baseace.mk
|
||||
include $(MAKE_DIR)baseuace.mk
|
||||
else
|
||||
-!include $(MAKE_DIR)baseace.mk
|
||||
!include $(MAKE_DIR)baseuace.mk
|
||||
endif
|
||||
diff -Nru unace-nonfree-2.5.orig/makefile unace-nonfree-2.5/makefile
|
||||
--- unace-nonfree-2.5.orig/makefile 2003-11-24 00:24:24.000000000 +0100
|
||||
+++ unace-nonfree-2.5/makefile 2006-01-31 09:40:17.000000000 +0100
|
||||
@@ -18,6 +18,6 @@
|
||||
INCLDIR = //usr/include
|
||||
|
||||
-DEFINES = -D__LINUX__ -D__unix__ -D__GCC__ -D__HAS_IO_H__
|
||||
+DEFINES = -D__LINUX__ -D__unix__ -D__GCC__ -U__HAS_IO_H__
|
||||
|
||||
ifdef DEBUG
|
||||
LSWITCHES =
|
||||
@@ -47,7 +47,7 @@
|
||||
$(APPS_UNACEEXE_CFILES)
|
||||
|
||||
unace: $(UNACEEXELIN_CFILES)
|
||||
- gcc $(LSWITCHES) -Wl,-lncurses -static -I$(INCLDIR) -I$(INCLSYSDIR) -I$(SRCSsl) $(DEFINES) $(UNACEEXELIN_CFILES) -ggdb -o$(EXECS_DIR)unace
|
||||
+ gcc $(LSWITCHES) -Wl,-lncurses -I$(INCLDIR) -idirafter $(INCLSYSDIR) -I$(SRCSsl) $(DEFINES) $(UNACEEXELIN_CFILES) -ggdb -o$(EXECS_DIR)unace
|
||||
ifndef DEBUG
|
||||
tar cfvz linunace25.tgz unace file_id.diz licence
|
||||
#sh linpack.sh
|
||||
diff -Nru unace-nonfree-2.5.orig/unace.mk unace-nonfree-2.5/unace.mk
|
||||
--- unace-nonfree-2.5.orig/unace.mk 2003-11-27 20:17:46.000000000 +0100
|
||||
+++ unace-nonfree-2.5/unace.mk 2006-01-31 09:33:21.000000000 +0100
|
||||
@@ -27,8 +27,6 @@
|
||||
|
||||
ifndef ISWMAKE
|
||||
include $(MAKE_DIR)unaceexe.mk
|
||||
-include $(MAKE_DIR)unacedll.mk
|
||||
else
|
||||
!include $(MAKE_DIR)unaceexe.mk
|
||||
-!include $(MAKE_DIR)unacedll.mk
|
||||
endif
|
Binary file not shown.
|
@ -1,119 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 04-64bit.dpatch by Michael Karcher
|
||||
## <debian@mkarcher.dialup.fu-berlin.de>
|
||||
##
|
||||
## All lines beginning with `## DP:' are a description of the patch.
|
||||
## DP: Replace declare.h by a generic stdint based version.
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad unace-nonfree-2.5~/source/base/all/declare.h unace-nonfree-2.5/source/base/all/declare.h
|
||||
--- unace-nonfree-2.5~/source/base/all/declare.h 2007-11-06 00:11:47.000000000 +0100
|
||||
+++ unace-nonfree-2.5/source/base/all/declare.h 2007-11-06 00:13:18.498574104 +0100
|
||||
@@ -7,76 +7,47 @@
|
||||
#ifndef _DECLARE_H_INCLUDED
|
||||
#define _DECLARE_H_INCLUDED
|
||||
|
||||
-#if !defined(__OS2__) && !defined(_WINDOWS_)
|
||||
- typedef int BOOL;
|
||||
-
|
||||
- typedef char CHAR;
|
||||
- typedef unsigned char UCHAR;
|
||||
- typedef UCHAR *PUCHAR;
|
||||
- typedef char *PSZ;
|
||||
-
|
||||
- typedef short SHORT;
|
||||
- typedef unsigned short USHORT;
|
||||
- typedef USHORT *PUSHORT;
|
||||
-
|
||||
- typedef long LONG;
|
||||
- typedef unsigned long ULONG;
|
||||
-
|
||||
- typedef ULONG *PULONG;
|
||||
-
|
||||
- typedef int INT;
|
||||
- typedef unsigned int UINT;
|
||||
- typedef unsigned int *PUINT;
|
||||
+#include <stdint.h>
|
||||
|
||||
- typedef CHAR *LPSTR;
|
||||
-#endif
|
||||
+typedef int BOOL;
|
||||
+typedef BOOL *PBOOL;
|
||||
|
||||
-#if __WATCOMC__==1060
|
||||
- typedef long __int64[2];
|
||||
- typedef __int64 LONGLONG;
|
||||
- typedef LONGLONG *PLONGLONG;
|
||||
- typedef __int64 ULONGLONG;
|
||||
- typedef ULONGLONG DWORDLONG;
|
||||
-#else
|
||||
- #if !defined(_WINDOWS_)
|
||||
- #if !defined(__WATCOMC__) && !defined(__int64)
|
||||
- #define __int64 long long
|
||||
- #endif
|
||||
+typedef char CHAR;
|
||||
+typedef CHAR *PCHAR;
|
||||
+typedef unsigned char UCHAR;
|
||||
+typedef UCHAR *PUCHAR;
|
||||
+typedef signed char SCHAR;
|
||||
+typedef CHAR *PSZ;
|
||||
+typedef CHAR *LPSTR;
|
||||
|
||||
- typedef __int64 LONGLONG;
|
||||
- typedef LONGLONG *PLONGLONG;
|
||||
- typedef unsigned __int64 ULONGLONG;
|
||||
- typedef ULONGLONG DWORDLONG;
|
||||
- #endif
|
||||
-#endif
|
||||
+typedef int INT;
|
||||
+typedef INT *PINT;
|
||||
+typedef unsigned int UINT;
|
||||
+typedef unsigned int *PUINT;
|
||||
|
||||
+typedef int16_t SHORT;
|
||||
+typedef SHORT *PSHORT;
|
||||
+typedef uint16_t USHORT;
|
||||
+typedef USHORT *PUSHORT;
|
||||
|
||||
-#if !defined(_WINDOWS_)
|
||||
- typedef BOOL *PBOOL;
|
||||
- typedef INT *PINT;
|
||||
-#endif
|
||||
+typedef int32_t LONG;
|
||||
+typedef LONG *PLONG;
|
||||
+typedef uint32_t ULONG;
|
||||
+typedef ULONG *PULONG;
|
||||
|
||||
-#if !defined(__wtypes_h__)
|
||||
- typedef void *PVOID;
|
||||
- typedef CHAR *PCHAR;
|
||||
- typedef SHORT *PSHORT;
|
||||
- typedef LONG *PLONG;
|
||||
- typedef ULONGLONG *PULONGLONG;
|
||||
-#endif
|
||||
+typedef int64_t LONGLONG;
|
||||
+typedef LONGLONG *PLONGLONG;
|
||||
+typedef uint64_t ULONGLONG;
|
||||
+typedef ULONGLONG *PULONGLONG;
|
||||
|
||||
-#if defined(_GNU_H_WINDOWS32_BASE)
|
||||
- typedef LONGLONG ULONGLONG;
|
||||
- typedef ULONGLONG *PULONGLONG;
|
||||
-#endif
|
||||
+typedef void *PVOID;
|
||||
|
||||
-typedef signed char SCHAR;
|
||||
+/* Dear ACE team, please clean your code to remove the following types */
|
||||
+typedef LONGLONG __int64;
|
||||
+typedef ULONGLONG DWORDLONG;
|
||||
|
||||
#ifndef NULL
|
||||
- #if defined(__SMALL__) || defined(__MEDIUM__) || defined(__386__) || defined(__AXP__) || defined(__PPC__)
|
||||
- #define NULL 0
|
||||
- #else
|
||||
- #define NULL 0L
|
||||
- #endif
|
||||
+#include <stdlib.h>
|
||||
#endif
|
||||
|
||||
|
Binary file not shown.
|
@ -73,10 +73,10 @@ find -L . \
|
|||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Thanks to AUR for the patches
|
||||
patch -p1 < $CWD/01-makefiles.dpatch
|
||||
zcat $CWD/01-makefiles.dpatch | patch -p1
|
||||
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
patch -p1 < $CWD/04-64bit.dpatch
|
||||
zcat $CWD/04-64bit.dpatch | patch -p1
|
||||
fi
|
||||
|
||||
make
|
||||
|
|
Loading…
Reference in New Issue