libraries/CXSparse: Updated for version 2.2.5.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
c376c25b96
commit
6600559a54
|
@ -4,7 +4,7 @@
|
||||||
# Written by Kyle Guinn <elyk03@gmail.com>
|
# Written by Kyle Guinn <elyk03@gmail.com>
|
||||||
|
|
||||||
PRGNAM=CXSparse
|
PRGNAM=CXSparse
|
||||||
VERSION=${VERSION:-2.2.4}
|
VERSION=${VERSION:-2.2.5}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -37,6 +37,9 @@ else
|
||||||
LIBDIRSUFFIX=""
|
LIBDIRSUFFIX=""
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
# Recommended by SuiteSparse
|
||||||
|
SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
|
||||||
|
|
||||||
set -e
|
set -e
|
||||||
|
|
||||||
rm -rf $PKG
|
rm -rf $PKG
|
||||||
|
@ -52,14 +55,16 @@ patch -p1 < $CWD/autotoolize.diff
|
||||||
autoreconf -vif
|
autoreconf -vif
|
||||||
|
|
||||||
CFLAGS="$SLKCFLAGS" \
|
CFLAGS="$SLKCFLAGS" \
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
|
||||||
./configure \
|
./configure \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||||
--sysconfdir=/etc \
|
--sysconfdir=/etc \
|
||||||
--localstatedir=/var \
|
--localstatedir=/var \
|
||||||
--mandir=/usr/man \
|
--mandir=/usr/man \
|
||||||
|
--infodir=/usr/info \
|
||||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||||
|
--enable-shared \
|
||||||
|
--disable-static \
|
||||||
--build=$ARCH-slackware-linux
|
--build=$ARCH-slackware-linux
|
||||||
|
|
||||||
make
|
make
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="CXSparse"
|
PRGNAM="CXSparse"
|
||||||
VERSION="2.2.4"
|
VERSION="2.2.5"
|
||||||
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
|
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
|
||||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/CXSparse/versions/CXSparse-2.2.4.tar.gz"
|
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/CXSparse/versions/CXSparse-2.2.5.tar.gz"
|
||||||
MD5SUM="043286037931a96b379b40bf89e44317"
|
MD5SUM="03750f3501fb3ccb7f2518bd24c4abbc"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
MAINTAINER="Kyle Guinn"
|
MAINTAINER="Kyle Guinn"
|
||||||
|
|
|
@ -3,7 +3,7 @@ new file mode 100644
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/Demo/Makefile.am
|
+++ b/Demo/Makefile.am
|
||||||
@@ -0,0 +1,131 @@
|
@@ -0,0 +1,131 @@
|
||||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||||
+LDADD = $(top_builddir)/Source/libcxsparse.la
|
+LDADD = $(top_builddir)/Source/libcxsparse.la
|
||||||
+
|
+
|
||||||
+noinst_HEADERS = \
|
+noinst_HEADERS = \
|
||||||
|
@ -134,16 +134,23 @@ new file mode 100644
|
||||||
+ -./cs_cl_demo3 < ../Matrix/mhd1280b
|
+ -./cs_cl_demo3 < ../Matrix/mhd1280b
|
||||||
+ -./cs_idemo < ../Matrix/t2
|
+ -./cs_idemo < ../Matrix/t2
|
||||||
+ -./cs_ldemo < ../Matrix/t2
|
+ -./cs_ldemo < ../Matrix/t2
|
||||||
|
diff --git a/Include/Makefile.am b/Include/Makefile.am
|
||||||
|
new file mode 100644
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/Include/Makefile.am
|
||||||
|
@@ -0,0 +1,2 @@
|
||||||
|
+pkgincludedir = $(includedir)/cxsparse
|
||||||
|
+pkginclude_HEADERS = cs.h
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -0,0 +1,5 @@
|
@@ -0,0 +1,5 @@
|
||||||
+SUBDIRS = Source Matrix Demo
|
+SUBDIRS = Include Source Matrix Demo
|
||||||
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt
|
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt
|
||||||
+
|
+
|
||||||
+pkgincludedir = $(includedir)/cxsparse
|
+pkgconfigdir = $(libdir)/pkgconfig
|
||||||
+pkginclude_HEADERS = Include/cs.h
|
+pkgconfig_DATA = cxsparse.pc
|
||||||
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
|
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
|
@ -177,7 +184,7 @@ new file mode 100644
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/Source/Makefile.am
|
+++ b/Source/Makefile.am
|
||||||
@@ -0,0 +1,72 @@
|
@@ -0,0 +1,72 @@
|
||||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include
|
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||||
+
|
+
|
||||||
+CS_SOURCE = \
|
+CS_SOURCE = \
|
||||||
+ cs_add.c \
|
+ cs_add.c \
|
||||||
|
@ -248,14 +255,14 @@ new file mode 100644
|
||||||
+
|
+
|
||||||
+libcxsparse_la_SOURCES = cs_convert.c
|
+libcxsparse_la_SOURCES = cs_convert.c
|
||||||
+libcxsparse_la_LIBADD = libcxsparse_di.la libcxsparse_dl.la libcxsparse_ci.la libcxsparse_cl.la -lm
|
+libcxsparse_la_LIBADD = libcxsparse_di.la libcxsparse_dl.la libcxsparse_ci.la libcxsparse_cl.la -lm
|
||||||
+libcxsparse_la_LDFLAGS = -no-undefined -version-info 4:4:2
|
+libcxsparse_la_LDFLAGS = -no-undefined -version-info 4:5:2
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -0,0 +1,31 @@
|
@@ -0,0 +1,37 @@
|
||||||
+AC_PREREQ([2.65])
|
+AC_PREREQ([2.68])
|
||||||
+AC_INIT([CXSparse], [2.2.4], [davis@cise.ufl.edu])
|
+AC_INIT([CXSparse],[2.2.5],[davis@cise.ufl.edu])
|
||||||
+AC_CONFIG_SRCDIR([Source/cs_print.c])
|
+AC_CONFIG_SRCDIR([Source/cs_print.c])
|
||||||
+AC_CONFIG_HEADER([config.h])
|
+AC_CONFIG_HEADER([config.h])
|
||||||
+AM_INIT_AUTOMAKE([foreign])
|
+AM_INIT_AUTOMAKE([foreign])
|
||||||
|
@ -269,7 +276,11 @@ new file mode 100644
|
||||||
+AC_CHECK_LIB([m], [sqrt])
|
+AC_CHECK_LIB([m], [sqrt])
|
||||||
+
|
+
|
||||||
+AC_CHECK_HEADERS([limits.h stdlib.h])
|
+AC_CHECK_HEADERS([limits.h stdlib.h])
|
||||||
+AC_CHECK_HEADERS([UFconfig.h])
|
+
|
||||||
|
+PKG_PROG_PKG_CONFIG
|
||||||
|
+PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
|
||||||
|
+ [],
|
||||||
|
+ [AC_MSG_ERROR([cannot find ufconfig])])
|
||||||
+
|
+
|
||||||
+AC_TYPE_SIZE_T
|
+AC_TYPE_SIZE_T
|
||||||
+
|
+
|
||||||
|
@ -280,8 +291,27 @@ new file mode 100644
|
||||||
+LIBS=$LIBS_SAVED
|
+LIBS=$LIBS_SAVED
|
||||||
+
|
+
|
||||||
+AC_CONFIG_FILES([
|
+AC_CONFIG_FILES([
|
||||||
|
+ cxsparse.pc
|
||||||
+ Makefile
|
+ Makefile
|
||||||
+ Demo/Makefile
|
+ Demo/Makefile
|
||||||
|
+ Include/Makefile
|
||||||
+ Matrix/Makefile
|
+ Matrix/Makefile
|
||||||
+ Source/Makefile])
|
+ Source/Makefile])
|
||||||
+AC_OUTPUT
|
+AC_OUTPUT
|
||||||
|
diff --git a/cxsparse.pc.in b/cxsparse.pc.in
|
||||||
|
new file mode 100644
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/cxsparse.pc.in
|
||||||
|
@@ -0,0 +1,12 @@
|
||||||
|
+prefix=@prefix@
|
||||||
|
+exec_prefix=@exec_prefix@
|
||||||
|
+libdir=@libdir@
|
||||||
|
+includedir=@includedir@
|
||||||
|
+
|
||||||
|
+Name: @PACKAGE_NAME@
|
||||||
|
+Description: An extended version of CSparse
|
||||||
|
+Version: @PACKAGE_VERSION@
|
||||||
|
+Requires.private: ufconfig
|
||||||
|
+Libs: -L${libdir} -lcxsparse
|
||||||
|
+Libs.private: -lm
|
||||||
|
+Cflags: -I${includedir}/cxsparse
|
||||||
|
|
Loading…
Reference in New Issue