system/argyllcms: Fixed build with gcc-5.3.0.

Signed-off-by: David Spencer <baildon.research@googlemail.com>
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
David Spencer 2015-12-29 22:59:01 +00:00 committed by Willy Sudiarto Raharjo
parent c968bf123f
commit 656a421df0
2 changed files with 23 additions and 0 deletions

View File

@ -0,0 +1,20 @@
Description: Fix FTBFS with GCC 5
Author: James Cowgill <james410@cowgill.org.uk>
Bug-Debian: https://bugs.debian.org/777779
Forwarded: no
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/icc/icc.h
+++ b/icc/icc.h
@@ -100,7 +100,11 @@
#define CF64PREC "LL" /* Constant precision specifier */
#ifndef ATTRIBUTE_NORETURN
+#ifdef _MSC_VER
# define ATTRIBUTE_NORETURN __declspec(noreturn)
+#else
+# define ATTRIBUTE_NORETURN __attribute__((noreturn))
+#endif
#endif
#else /* !__STDC_VERSION__ */

View File

@ -75,6 +75,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 640 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch for gcc-5 thanks to Debian
patch -p1 < $CWD/argyllcms-1.8.0-gcc5.patch
### install steps have been shamelessly copied from Arch Linux PKGBUILD
### https://projects.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/argyllcms
sh ./makeall.sh