libraries/opal: Updated for version 3.6.7.
This commit is contained in:
parent
e6dd4502b4
commit
64bba8f1d4
|
@ -0,0 +1,103 @@
|
|||
--- a/plugins/audio/celt/celtcodec.c
|
||||
+++ b/plugins/audio/celt/celtcodec.c
|
||||
@@ -52,7 +52,12 @@ static int init_mode(CELTContext *celt, const struct PluginCodec_Definition * co
|
||||
{
|
||||
int error = 0;
|
||||
|
||||
- celt->mode = celt_mode_create(codec->sampleRate, 1, codec->parm.audio.samplesPerFrame, &error);
|
||||
+ celt->mode = celt_mode_create(codec->sampleRate,
|
||||
+#if !defined(HAVE_CELT_0_7_0_OR_LATER)
|
||||
+ 1,
|
||||
+#endif
|
||||
+ codec->parm.audio.samplesPerFrame,
|
||||
+ &error);
|
||||
if (celt->mode == NULL) {
|
||||
return FALSE;
|
||||
}
|
||||
@@ -65,6 +70,9 @@ static int init_mode(CELTContext *celt, const struct PluginCodec_Definition * co
|
||||
|
||||
static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
|
||||
{
|
||||
+#if defined(HAVE_CELT_0_7_0_OR_LATER)
|
||||
+ int error = 0;
|
||||
+#endif
|
||||
CELTContext * celt = malloc(sizeof(CELTContext));
|
||||
if (celt == NULL)
|
||||
return NULL;
|
||||
@@ -73,8 +81,12 @@ static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
|
||||
free(celt);
|
||||
return NULL;
|
||||
}
|
||||
-
|
||||
+
|
||||
+#if defined(HAVE_CELT_0_7_0_OR_LATER)
|
||||
+ celt->encoder_state = celt_encoder_create(celt->mode, 1, &error);
|
||||
+#else
|
||||
celt->encoder_state = celt_encoder_create(celt->mode);
|
||||
+#endif
|
||||
if (celt->encoder_state == NULL ) {
|
||||
celt_mode_destroy(celt->mode);
|
||||
free(celt);
|
||||
@@ -87,6 +99,9 @@ static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
|
||||
|
||||
static void * celt_create_decoder(const struct PluginCodec_Definition * codec)
|
||||
{
|
||||
+#if defined(HAVE_CELT_0_7_0_OR_LATER)
|
||||
+ int error = 0;
|
||||
+#endif
|
||||
CELTContext * celt = malloc(sizeof(CELTContext));
|
||||
if (celt == NULL)
|
||||
return NULL;
|
||||
@@ -96,7 +111,11 @@ static void * celt_create_decoder(const struct PluginCodec_Definition * codec)
|
||||
return NULL;
|
||||
}
|
||||
|
||||
+#if defined(HAVE_CELT_0_7_0_OR_LATER)
|
||||
+ celt->decoder_state = celt_decoder_create(celt->mode, 1, &error);
|
||||
+#else
|
||||
celt->decoder_state = celt_decoder_create(celt->mode);
|
||||
+#endif
|
||||
if (celt->decoder_state == NULL ) {
|
||||
celt_mode_destroy(celt->mode);
|
||||
free(celt);
|
||||
@@ -142,7 +161,9 @@ static int celt_codec_encoder(const struct PluginCodec_Definition * codec,
|
||||
if (*toLen < celt->bytes_per_packet)
|
||||
return FALSE;
|
||||
|
||||
-#ifdef HAVE_CELT_0_5_0_OR_LATER
|
||||
+#if defined(HAVE_CELT_0_7_0_OR_LATER)
|
||||
+ byteCount = celt_encode(celt->encoder_state, (celt_int16 *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
|
||||
+#elif defined(HAVE_CELT_0_5_0_OR_LATER)
|
||||
byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
|
||||
#else
|
||||
byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, (char *)toPtr, celt->bytes_per_packet);
|
||||
--- a/plugins/configure.ac
|
||||
+++ b/plugins/configure.ac
|
||||
@@ -313,9 +313,12 @@
|
||||
AC_SUBST(CELT_LIBS)
|
||||
AC_DEFINE([HAVE_CELT], [1], [celt])
|
||||
HAVE_CELT=yes
|
||||
- PKG_CHECK_EXISTS([celt >= 0.5.0],
|
||||
- [
|
||||
- AC_DEFINE([HAVE_CELT_0_5_0_OR_LATER], [1], [celt 0.5.0 or later found])
|
||||
+ PKG_CHECK_EXISTS([celt >= 0.7.0], [
|
||||
+ AC_DEFINE([HAVE_CELT_0_7_0_OR_LATER], [1], [celt 0.7.0 or later found])
|
||||
+ ],
|
||||
+ [PKG_CHECK_EXISTS([celt >= 0.5.0], [
|
||||
+ AC_DEFINE([HAVE_CELT_0_5_0_OR_LATER], [1], [celt 0.5.0 or later found])
|
||||
+ ])
|
||||
])
|
||||
],
|
||||
[
|
||||
--- a/plugins/plugin-config.h.in 2010-02-14 16:07:28.000000000 +0100
|
||||
+++ b/plugins/plugin-config.h.in 2010-02-14 16:07:42.000000000 +0100
|
||||
@@ -15,6 +15,9 @@
|
||||
/* celt 0.5.0 or later found */
|
||||
#undef HAVE_CELT_0_5_0_OR_LATER
|
||||
|
||||
+/* celt 0.7.0 or later found */
|
||||
+#undef HAVE_CELT_0_7_0_OR_LATER
|
||||
+
|
||||
/* Define to 1 if you have the <dlfcn.h> header file. */
|
||||
#undef HAVE_DLFCN_H
|
||||
|
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=opal
|
||||
VERSION=${VERSION:-3.6.2}
|
||||
VERSION=${VERSION:-3.6.7}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
@ -52,6 +52,17 @@ cd $TMP
|
|||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
|
||||
# Patch to add celt 0.7 support to opal
|
||||
# Found at
|
||||
# http://packages.gentoo.org/package/net-libs/opal?arches=fbsd
|
||||
patch -p1 < $CWD/opal-3.6.7-celt-0.7-update.patch
|
||||
(
|
||||
cd plugins
|
||||
aclocal
|
||||
autoconf
|
||||
)
|
||||
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
|
@ -76,9 +87,9 @@ rm $PKG/usr/lib${LIBDIRSUFFIX}/libopal_s.a
|
|||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="opal"
|
||||
VERSION="3.6.2"
|
||||
VERSION="3.6.7"
|
||||
HOMEPAGE="http://www.opalvoip.org/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/opalvoip/opal-3.6.2.tar.bz2"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/opalvoip/opal-3.6.7.tar.bz2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM="88076eeadee1351704afb2aeb3532c17"
|
||||
MD5SUM="bd0601c214a4089e86fbdda6aec8d22b"
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Mauro Giachero"
|
||||
EMAIL="mauro dot giachero at gmail dot com"
|
||||
APPROVED="rworkman"
|
||||
APPROVED="dsomero"
|
||||
|
|
Loading…
Reference in New Issue