python/mmpython: Removed.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
0a151297c6
commit
62ea31f9d8
|
@ -1,4 +0,0 @@
|
|||
MMPython is a Media Meta Data retrieval framework. It retrieves metadata
|
||||
from mp3, ogg, avi, jpg, tiff and other file formats. Among others it
|
||||
thereby parses ID3v2, ID3v1, EXIF, IPTC and Vorbis data into an object
|
||||
oriented struture.
|
|
@ -1,20 +0,0 @@
|
|||
--- disc/ifomodule.c~ 2004-07-17 10:46:52.000000000 +0200
|
||||
+++ disc/ifomodule.c 2006-04-11 07:59:38.030697690 +0200
|
||||
@@ -9,6 +9,7 @@
|
||||
#include <unistd.h>
|
||||
#include <assert.h>
|
||||
#include <inttypes.h>
|
||||
+#include <stdint.h>
|
||||
|
||||
#include <dvdread/dvd_reader.h>
|
||||
#include <dvdread/ifo_types.h>
|
||||
--- disc/cdrommodule.c~ 2003-06-23 21:26:16.000000000 +0200
|
||||
+++ disc/cdrommodule.c 2006-04-11 07:58:02.463087444 +0200
|
||||
@@ -36,6 +36,7 @@
|
||||
#include "Python.h"
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
+#include <stdint.h>
|
||||
|
||||
#ifdef __linux__
|
||||
#include <linux/cdrom.h>
|
|
@ -1,60 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for mmpython
|
||||
|
||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
|
||||
PRGNAM=mmpython
|
||||
VERSION=${VERSION:-0.4.10}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Add stdint.h headers
|
||||
patch -p0 < $CWD/mmpython-0.4.10-stdint.patch
|
||||
|
||||
python setup.py build
|
||||
|
||||
python setup.py install --prefix="$PKG/usr"
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING CREDITS PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="mmpython"
|
||||
VERSION="0.4.10"
|
||||
HOMEPAGE="http://mmpython.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/mmpython/mmpython-0.4.10.tar.gz"
|
||||
MD5SUM="3a1f2e754308ac8cacd266c1350dcf34"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="PyXML lsdvd"
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
|
@ -1,21 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|' on
|
||||
# the right side marks the last column you can put a character in. You must make
|
||||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
mmpython: mmpython (Media Metadata for Python)
|
||||
mmpython:
|
||||
mmpython: MMPython is a Media Meta Data retrieval framework. It retrieves
|
||||
mmpython: metadata from mp3, ogg, avi, jpg, tiff and other file formats. Among
|
||||
mmpython: others it thereby parses ID3v2, ID3v1, EXIF, IPTC and Vorbis data
|
||||
mmpython: into an object oriented struture.
|
||||
mmpython:
|
||||
mmpython: Homepage: http://mmpython.sourceforge.net/
|
||||
mmpython:
|
||||
mmpython:
|
||||
mmpython:
|
||||
|
||||
|
Loading…
Reference in New Issue